Jump to content
Sign in to follow this  
Followers 13
OpinioNate

Geocaching.com site update Nov 9th 2010

Recommended Posts

The update appears to have messed with the HTML code for images within cache pages. Some of my cache pages have images that are right-aligned (or left-) within the text, and that code is being ignored - the images are now appearing separate from the paragraphs, surrounded by white space. Not good!
Looking at the source for my caches, it appears that the align attribute is being stripped from images. Please fix this.

 

[edit: fix BBCode]

Edited by niraD

Share this post


Link to post

Not seeing maps, small, medium and large sizes... in windows explorer and Google chrome.. I'm sure you're working on this. Thank you :)

Share this post


Link to post

 

...

 

Don't worry, we will get this fixed today. For now you can use Firefox or Chrome. Who knows, you might like it!

 

Sorry to say this, but I'm using Firefox and also get blank maps.

 

Good luck!

 

- prjames

Share this post


Link to post
Regarding BBCode, it will no longer work and we have a script to convert the old code to HTML. We need to wait and do the conversion slowly because to convert that many logs at once would be insane. Please just leave the logs as they are and we'll do the conversion over time.
Does that mean we need to start using HTML rather than BBCode in our logs? And do we need to use <br> and <p> rather than normal newlines?

I actually hate doing that for cache and coin listings.

 

It's unbearable to use this for my logs as well.

Also I'm quite upset, how my past logs look now. They turned into a mass of lines, no breaks and become litterally unreadable.

 

I hope this will be fixed! I hate seeing my logs being mangled in this way.

Share this post


Link to post

A couple of these issues (view larger map, encrypt/decrypt) I suspect simply need a browser refresh to fix, as I cannot reproduce them. Please make sure you close and reopen your browser before reporting a bug.

 

These should be sorted out very soon. Thanks for all your patience and feedback!

 

I also get the blank box on the map page. Over above the filter box it has a link for me to up grade to Premium, but I am already a Premium member.

 

I am not for sure if those two are related.

 

Thanks for all that ya'll do on these great websites.

 

Same for me.

In Chrome everything seems to work fine, but in IE, the map is just blank and there is an upgrade link above the filters-box (but the filters can still be modified and I am already a Premium Member)

 

I usually only use Chrome, but wanted to test in IE as people seemed to have problems there..

 

Don't worry, we will get this fixed today. For now you can use Firefox or Chrome. Who knows, you might like it!

 

Still broken, and NO, it does not work in Chrome. I'm seeing exactly the same black areas where the map and cache list should be.

Share this post


Link to post

All newlines in old logs are gone. I hope that it's a bug and will be fixed...

 

I hope to correct the problem and not have to manually modify more than 1,000 logs.

Larger maps does not work in Opera 10.63

 

Greetings.

omortsoN

Share this post


Link to post

looks like watchlist emails / owner emails now include HTML.

 

You are receiving this email because you are the owner of this listing.

 

Location: Ontario, Canada

BurnaBees posted a note for Win the Lottery! - CC #1 (Unknown Cache) at 10/3/2010

 

Log Date: 10/3/2010

<p>

Travel bug dip</p>

 

 

http://www.geocaching.com/seek/log.aspx?LU...01-b53d32d4b4e6

Share this post


Link to post

I hope to correct the problem and not have to manually modify more than 1,000 logs.

Larger maps does not work in Opera 10.63

 

Greetings.

omortsoN

 

At this moment Larger maps does work in Opera 10.63.

 

Greetings.

omortsoN

Share this post


Link to post
Regarding BBCode, it will no longer work and we have a script to convert the old code to HTML. We need to wait and do the conversion slowly because to convert that many logs at once would be insane. Please just leave the logs as they are and we'll do the conversion over time.
Does that mean we need to start using HTML rather than BBCode in our logs? And do we need to use <br> and <p> rather than normal newlines?

I actually hate doing that for cache and coin listings.

 

It's unbearable to use this for my logs as well.

Also I'm quite upset, how my past logs look now. They turned into a mass of lines, no breaks and become litterally unreadable.

 

I hope this will be fixed! I hate seeing my logs being mangled in this way.

 

 

Regarding BBCode, it will no longer work and we have a script to convert the old code to HTML. We need to wait and do the conversion slowly because to convert that many logs at once would be insane. Please just leave the logs as they are and we'll do the conversion over time.

 

These should be sorted out very soon. Thanks for all your patience and feedback!

 

Updates happen every month,

 

and every month there are inevitably snags/hitches/glitches.

 

They'll get sorted eventually.

 

Once the bug has been reported why can't folks just sit back, have a drink of whatever, go away from their pc and do something else for a while?

 

"Everything will be OK in the end. If it's not OK, it's not the end."

 

MrsB :)

Edited by The Blorenges

Share this post


Link to post

Another issue I've discovered, emailed logs are going out with HTML encoding. My account is set "Do not send emails from Groundspeak in HTML format when available."

 

Log Date: 11/9/2010
<p>
	Tough 1.5  TNLNSL</p>

Share this post


Link to post

Domo again!!!

 

In the email notifications now, all the logs have the <p>...</p> or pe forward-slash-pea showing sandwiching the logs. Weird!

 

Needs a hot fix, Nate!

Share this post


Link to post
Needs a hot fix, Nate!

what if i want a cold fix instead?

Share this post


Link to post

Fixed in production or waiting for hotfix to live:

 

-Find counts missing on cache page

-Line feeds stripped from cache log formatting

-Map not recognizing Premium status in Internet Explorer

-Feedback tab missing from home page

-Image upload errors

 

Fix in progress:

 

-Souvenir improperly awarded through API (iPhone/Android/WP7)

-Personal cache note not working with French as chosen language

-Map on cache details page doesn't display with French as chosen language

-Adding GPS device to profile causes 500 error

-Previewing a PQ on the map results in zero caches displayed

 

I cannot reproduce the blank map problems reported in Chrome or Firefox, nor the complaints regarding resizing the map (small, medium, large). If anyone can help me with that I'd appreciate it. Thanks.

Edited by OpinioNate

Share this post


Link to post

Before all the comments start flowing, I want to thank all the developers for their hard work. I always feel my $30 is well worth all the work that happens each month.

 

I am more to willing to shell out $50 a year for an ultra premium account if you ever had the option. I'd love to have a few more PQs for a quick idea (most of my PQs I don't use to cache. Just look around the country / globe).

Share this post


Link to post

Another issue I've discovered, emailed logs are going out with HTML encoding. My account is set "Do not send emails from Groundspeak in HTML format when available."

 

Log Date: 11/9/2010
<p>
	Tough 1.5  TNLNSL</p>

 

Domo again!!!

 

In the email notifications now, all the logs have the <p>...</p> or pe forward-slash-pea showing sandwiching the logs. Weird!

 

Needs a hot fix, Nate!

 

Thanks guys. Checking on this.

Share this post


Link to post

Before all the comments start flowing, I want to thank all the developers for their hard work. I always feel my $30 is well worth all the work that happens each month.

 

I am more to willing to shell out $50 a year for an ultra premium account if you ever had the option. I'd love to have a few more PQs for a quick idea (most of my PQs I don't use to cache. Just look around the country / globe).

 

If you're just browsing the globe you don't actually have to schedule the PQ for delivery/download. Create the PQ and preview it like an advanced search.

 

But please keep ideas on User Voice. Things are happening fast in this thread and I'd prefer to keep it focused on getting this release wrapped up. Thanks.

Share this post


Link to post
I am more to willing to shell out $50 a year for an ultra premium account if you ever had the option. I'd love to have a few more PQs for a quick idea (most of my PQs I don't use to cache. Just look around the country / globe).

for $60 a year you'd get two premium accounts :)

Share this post


Link to post

Another issue I've discovered, emailed logs are going out with HTML encoding. My account is set "Do not send emails from Groundspeak in HTML format when available."

 

Log Date: 11/9/2010
<p>
	Tough 1.5  TNLNSL</p>

 

Domo again!!!

 

In the email notifications now, all the logs have the <p>...</p> or pe forward-slash-pea showing sandwiching the logs. Weird!

 

Needs a hot fix, Nate!

 

Thanks guys. Checking on this.

 

Wow, that was quick! No more <p> in notifications!

Though still, lots of space between the log date and the log.

 

Thanks!

Share this post


Link to post

Fixed in production or waiting for hotfix to live:

 

-Find counts missing on cache page

-Line feeds stripped from cache log formatting

-Map not recognizing Premium status in Internet Explorer

-Feedback tab missing from home page

-Image upload errors

 

Fix in progress:

 

-Souvenir improperly awarded through API (iPhone/Android/WP7)

-Personal cache note not working with French as chosen language

-Map on cache details page doesn't display with French as chosen language

-Adding GPS device to profile causes 500 error

-Previewing a PQ on the map results in zero caches displayed

 

I cannot reproduce the blank map problems reported in Chrome or Firefox, nor the complaints regarding resizing the map (small, medium, large). If anyone can help me with that I'd appreciate it. Thanks.

 

First of all, thanks for all the hard work from everyone at Groundspeak, and for all the cool updates!

 

I use a Mac, and I'm still having a problem using Google Maps in Firefox. While all three sizes are working for me after I shutdown and restarted Firefox, it has lost the functionality of showing which ones I've found and which ones are mine.

 

However, I fired up Chrome, and everything is working perfectly - just as it was before the updates today, and I just checked Safari and everything looks fine there too.

Share this post


Link to post

The update appears to have messed with the HTML code for images within cache pages. Some of my cache pages have images that are right-aligned (or left-) within the text, and that code is being ignored - the images are now appearing separate from the paragraphs, surrounded by white space. Not good!

 

Examples:

Spur by the Marsh (image should be on right side of text block, as coded in <img> tag)

Shy Bear Pass

 

This break in the HTML code has really messed up the formatting of my cache pages. Is it on the list to be fixed?

 

In case it's a browser thang, I'm using Safari 4.1.2.

 

This is now fixed. Thanks hydnsek.

 

Edit: still needs to be hotfixed out though.

The problem is still occurring for me, and it wasn't on your list of fixes being pushed out.

Share this post


Link to post

The update appears to have messed with the HTML code for images within cache pages. Some of my cache pages have images that are right-aligned (or left-) within the text, and that code is being ignored - the images are now appearing separate from the paragraphs, surrounded by white space. Not good!

 

Examples:

Spur by the Marsh (image should be on right side of text block, as coded in <img> tag)

Shy Bear Pass

 

This break in the HTML code has really messed up the formatting of my cache pages. Is it on the list to be fixed?

 

In case it's a browser thang, I'm using Safari 4.1.2.

 

This is now fixed. Thanks hydnsek.

 

Edit: still needs to be hotfixed out though.

The problem is still occurring for me, and it wasn't on your list of fixes being pushed out.

Mine are also screwed up. See the Mosquito fleet and Lighthouse series. The text use to flow nicely around the pictures on the left.

Share this post


Link to post

		 <Groundspeak:log id="135224880">
	  <Groundspeak:date>2010-11-09T20:00:00Z</Groundspeak:date>
	  <Groundspeak:type>Write note</Groundspeak:type>
	  <Groundspeak:finder id="230070">caughtatwork</Groundspeak:finder>
	  <Groundspeak:text encoded="False"><p>
This is a test log</p>
<p>
<strong>This is a test log</strong></p>
<p>
<em>This is a test log</em></p>
<p>
<u>This is a test log</u></p>
<p>
<strike>This is a test log</strike></p>
<p>
<a href="http://caughtatwork.com.au">This is a test log</a></p>
<p>
<img src="/images/icons/tongue.gif" /><img src="/images/icons/icon_smile_kisses.gif" /></p>
</Groundspeak:text>
	</Groundspeak:log>

 

The image source is referenced locally in the GPX files and should be absolute referenced when you're not on the GC site.

Share this post


Link to post

Send To GPS "Magellan" does not work in IE8 and Firefox 3.6.10

DeLorme is good!

Share this post


Link to post
The image source is referenced locally in the GPX files and should be absolute referenced when you're not on the GC site.

uh, the GPX gives you HTML in the logs? :)

Share this post


Link to post

Not sure if I missed this on the fix list;

 

My cache GC2E06N has an image which contains a clickable link in a small section of the main image using HTML MAP code

 

see below, with urls removed

 

<img src=

"http://www.exampleurl/image.jpg" usemap=

"#circle" /><map name="circle" id="circle">

<area shape="circle" coords="300,300,45" href=

"http://www.exampleurl/page.html" />

</map></center>

 

Doesn't work now, any chance this could be looked at in the fixes?

 

Thanks for all the hard work guys!

Share this post


Link to post

Domo again!!!

 

At the GC.com Top page, when you're logged in, I noticed that at the Upper Right, just under where it says "You are logged in as Dr.MORO. Log out", the top of your mini-profile window, mine says "HELLO DR.MORO!" all in capital letters. Shouldn't this says "Hello Dr.MORO!" just as in my "Your Profile" page's upper right, properly mixed with Capitals & Smalls?

 

A little thing, but does not look right.

 

Thanks!

Share this post


Link to post

Domo again!!!

 

At the GC.com Top page, when you're logged in, I noticed that at the Upper Right, just under where it says "You are logged in as Dr.MORO. Log out", the top of your mini-profile window, mine says "HELLO DR.MORO!" all in capital letters. Shouldn't this says "Hello Dr.MORO!" just as in my "Your Profile" page's upper right, properly mixed with Capitals & Smalls?

 

A little thing, but does not look right.

 

Thanks!

That's been (broken?) that way for a while.

Share this post


Link to post

Hi

 

Not sure this has been reported but when you use the "zoom to address" option on the maps, the browser flicks as if moving but it just brings you back to your home location. i am using Firefox 3.6.12.

 

Thanks,

 

ToonAl

Share this post


Link to post

The "zoom to address" box on the 'or, search with google maps' page just keeps zooming to Green Lake no matter what I type. Both firefox and chrome.

Share this post


Link to post

Hi

 

Not sure this has been reported but when you use the "zoom to address" option on the maps, the browser flicks as if moving but it just brings you back to your home location. i am using Firefox 3.6.12.

 

Thanks,

 

ToonAl

Share this post


Link to post

HTML comments are broken in cache descriptions.

 

The system strips the code out.

 

Any chance this could be fixed?

Edited by Spatial Distortion

Share this post


Link to post

Hi GC-team,

 

I have only ONE question: Why don´t you first try a server update on a seperate system or page before you upload this update onto the main server? Wouldn´t it be great to have some users to check out the new update on a seperate site for a few days? In my view the whole community is used to eradicate the failures that these updates are producing. I cannot understand this at all!!! :):):)

Every time you released an update I had to change the listings to let it look like before.

 

Here is the problem I have with this update:

 

All the <table align="center"> expressions are ignored. The tables are being placed to the most left position as they would have the expression <table align="left">

 

I am using Firefox 3.6.10

 

Sincerely yours Tissi_2

Share this post


Link to post

 

Though still, lots of space between the log date and the log.

 

Thanks!

 

Same for me.. I can even tell the difference between a pre-update log and a post-update log.. (screenshots will be provided if neede).

Loads of white-space going to waste there..

Share this post


Link to post

Not sure if I missed this on the fix list;

 

My cache GC2E06N has an image which contains a clickable link in a small section of the main image using HTML MAP code

...

Doesn't work now, any chance this could be looked at in the fixes?

 

One of my puzzle caches has stopped working for the same reason:

 

X Marks the Spot - a puzzle cache

 

Clicking on any white square in the grid should take you to a JPEG image showing a digit, but as of today it no longer works.

 

Originally, you could just hover the mouse over a square and a small box would appear showing the digit; it worked by using "title" tags in the definition of the map. But that feature went away in a previous update a year or two ago, and has never come back.

Share this post


Link to post

We're putting together a new build to push live shortly. These cases will be put to bed:

 

-Find counts missing on cache page

-Line feeds stripped from cache log formatting

-Map not recognizing Premium status in Internet Explorer

-Feedback tab missing from home page

-Image upload errors

-Souvenir improperly awarded through API (iPhone/Android/WP7)

-Previewing a PQ on the map results in zero caches displayed

-Image alignment in cache details

 

Fix in progress:

 

-Image maps getting stripped out of HTML code in cache details

-HTML comments being stripped from cache details

-Zoom to address on GC Google maps just refreshes the map

-Error viewing Trackable in Firefox when not logged in

-Personal cache note not working with French as chosen language

-Map on cache details page doesn't display with French as chosen language

-Adding GPS device to profile causes 500 error

 

Thank you all for your patience!

Share this post


Link to post

Great news on your progress!

 

I additon to adding WYSIWYG editor to logs, you have partly fixed the problem with extended UTF-8 characters. I can see correct latvian characters when I write "glāšķūņu rūķīši" in log entry or trackable descriptions. Now you only need to fix that for cache dedcriptions!

Share this post


Link to post

I have only ONE question: Why don´t you first try a server update on a seperate system or page before you upload this update onto the main server? Wouldn´t it be great to have some users to check out the new update on a seperate site for a few days? In my view the whole community is used to eradicate the failures that these updates are producing. I cannot understand this at all!!!

Every time you released an update I had to change the listings to let it look like before.

 

Here is the problem I have with this update:

All the <table align="center"> expressions are ignored. The tables are being placed to the most left position as they would have the expression <table align="left">

I am using Firefox 3.6.10

This sounds like the same issue as with the <img> tag - the align attribute is being ignored. It sounds like several coding things were broken with this release, but I'm sure they're working to get them all fixed.

 

I agree that in my experience on several web teams, we tested releases on staging servers before sending them live. And that may be happening, but perhaps it's hard to catch everything. Groundspeak does push releases more frequently than any place I've worked, and kudos to them for the frequent upgrades we're getting, even if a few kinks have to be worked out (they're usually fixed within a day, and the lackeys are responsive and interactive with us, vs. many sites - just sayin').

Share this post


Link to post

 

Though still, lots of space between the log date and the log.

 

Thanks!

 

Same for me.. I can even tell the difference between a pre-update log and a post-update log.. (screenshots will be provided if neede).

Loads of white-space going to waste there..

 

We are in the process of switching over to a new message server. The whitespace is a temporary effect caused by what is essentially a hack to remove the HTML that is appearing in notifications during this transition. It will go away when the server move has been completed.

Share this post


Link to post

Code is being stripped out of the IMG tag.

 

Example, my cache has this html code :

 

<img style="border: 2px solid ; width: 250px; height: 231px;" alt=

"" src=

"http://img.geocaching.com/cache/a32781d8-49f2-47dc-9952-dcf33a758de4.jpg"

align="right" hspace="20" />

 

And the page is rendered with this line :

<img alt src="http://img.geocaching.com/cache/a32781d8-49f2-47dc-9952-dcf33a758de4.jpg" style="border:2px solid ;width:250px;height:231px;" />

 

The code "align="right" hspace="20"" is missing which makes the picture show on the top left instead of indented in the text on the right.

 

PS - Already reported. Just adding my voice. :)

Edited by ZeMartelo

Share this post


Link to post

We're putting together a new build to push live shortly. These cases will be put to bed:

...

-Line feeds stripped from cache log formatting

...

 

I was just getting my blood pressure up about this one.. editing field_notes.txt before uploading it from my gamin I use a lot of newlines that then got stripped after uploading it to the site.. I hope fixing that is what this means..

 

The proper formatting is back for existing logs though, which is nice..

Share this post


Link to post

We're putting together a new build to push live shortly. These cases will be put to bed:

 

-Find counts missing on cache page

-Line feeds stripped from cache log formatting

-Map not recognizing Premium status in Internet Explorer

-Feedback tab missing from home page

-Image upload errors

-Souvenir improperly awarded through API (iPhone/Android/WP7)

-Previewing a PQ on the map results in zero caches displayed

-Image alignment in cache details

 

Fix in progress:

 

-Image maps getting stripped out of HTML code in cache details

-HTML comments being stripped from cache details

-Zoom to address on GC Google maps just refreshes the map

-Error viewing Trackable in Firefox when not logged in

-Personal cache note not working with French as chosen language

-Map on cache details page doesn't display with French as chosen language

-Adding GPS device to profile causes 500 error

 

Thank you all for your patience!

Thanks Nate,

You guys are the BEST

Share this post


Link to post

WYSIWYG

 

What-You-See-Is-What-You-Get makes a reappearance in this month's release. This time you'll find the new simplified text editor added to the geocache and Trackables logging page. In the next release we'll finish the job by adding a more feature-rich version to the cache details and profile pages.

 

Good to know!

 

18880: Allow the "My Finds" Query to run every 3 days

Increased frequency with which PMs can request the My Finds Pocket Query

 

Awesome!

 

20377: Create new Trackable Tattoo Trackable Type (Icon)

Added new Trackable type for trackable tattoos, email contact@geocaching.com with pic to request

 

Wow! Now need to look for one!

 

18687: Put Hider's Name on the Log a Cache Page

Now reads: "In reference to {cache} by {cache owner}"

 

Nice!

 

19281: Add Mass Delete to watch list functionality

Added checkboxes to watchlist to mirror bookmark functionality

 

Nice again!

 

19806: Link "you logged this as found on..." to the log

This text on cache pages will now link to that log

 

Nifty!

 

Coming soon:

 

Stats, Ratings and Maps. Oh My!

 

Oh My!!! Can't wait!!!

 

Awesome improvements, GS Lackeys & the hampsters!

 

Keep up the great work!

 

~ Dr.MORO

I have to concur. I think you guys have made some very nice enhancements with this release. Thanks!

Share this post


Link to post

Just a reminder on the issue of broken Geochecker links:

After the update, _all_ "&" characters, including those in linked URLs, are replaced by "&". This breaks Geochecker, which is definitely fatal for loads of puzzle caches.

 

This error, together with the log formatting catastrophe, makes this update by far the worst since I joined geocaching.com 3 years ago :-((.

Share this post


Link to post

If you try to pre-write logs for challenges all line breaks are stripped out of the text making things unreadable. This has already been an issue when one wished to print a cache listing. The descriptions in the listing were made particularly difficult to read. It would be nicer if this problem had been addressed rather than being compounded by the problem now doing the same thing as we try to log caches.

 

I wish I was getting the impression that this was going to be addressed. I don't.

Edited by two bison

Share this post


Link to post

I was just reading about some of the HTML issues and thought I'd check on some of mine.

 

Sure enough several of my caches are now broken because of this HTML stripping that seems to be going on.

 

I trust you will be fixing these issues, and hopefully these changes to the code is being done on the fly and not in the database. So restoring things to the way they were will not be automatic.

Share this post


Link to post

In the newly constituted "Comments" box when we hit "Enter" it appears to double space or more leaving way too much white space between lines.

Share this post


Link to post

I was just reading about some of the HTML issues and thought I'd check on some of mine.

 

Sure enough several of my caches are now broken because of this HTML stripping that seems to be going on.

 

I trust you will be fixing these issues, and hopefully these changes to the code is being done on the fly and not in the database. So restoring things to the way they were will not be automatic.

 

If you wrote your listings in HTML those the links aren't broken ... or at least those of mine that I checked are not.

 

I find it amusing the BBCoding appears to be alive and well, at least in the italics, in this forum post.

Edited by two bison

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 13

×
×
  • Create New...