Jump to content

New Software Version for 60C


benjamin921
Followers 5

Recommended Posts

v3.70

 

Changes made from version 3.60 to 3.70:

 

* Fixed transfer problem with custom waypoint symbols.

* Now reports DEM map support to PC software.

* Fixed lockup that could happen when selecting a Tracback point.

* Fixed shutdown caused by viewing some marine light points.

* Fixed problem with Indonesian Southern Grid using wrong longitude of origin.

* Added advanced NMEA support settings to support certain marine autopilot units.

* Fixed problem where the interaction with certain beacon receivers was not displayed.

* Added 'Select Map' option for Address and Intersection searching.

* Fixed problem where waypoint depth was not being saved as invalid when it was unknown.

* Fixed problem where waypoints could not be saved in certain areas of BlueChart maps.

* Fixed lockup that could occur when selecting symbols for waypoints.

* Added warning message about removing batteries when Pressure Trend Recording is always on.

* Fixed lockup that could occur when approaching certain roads on the map.

* Added Jumpmaster support under Setup.

* Made the way intermittent water areas are drawn more visible.

* Fixed problem where compass pointer could transition to the next turn too quickly.

* Fixed problem with bearing being adjusted improperly when projecting waypoints with a non-zero north reference.

* Fixed lockup that would occur when 'finding by name' and then viewing map information for the point.

* Fixed problem in tide charts where local time axis would not match the station time axis.

* Changed tide stations to show selected date when saved on a calendar day.

* Fixed a potential problem where the wrong number of bytes could be sent for USB get requests.

* Fixed problem with displaying 'Waypoint At Destination' while doing a tracback.

* Fixed lockup that could occur when approaching certain roads on the map.

* Fixed problem where route recalculation would slowly go to 100% and lock up.

* Improved WAAS search and selection process to be smarter in its handling of multiple SBAS service providers, overlapping service volumes, and exceptional conditions.

* Fixed lockup that could occur when selecting a tracback point.

Edited by benjamin921
Link to comment

The link has been posted for the 60C, but it does NOT appear to be posted for the 60CS at this time. WEBSCOUTER.'S link above DOES WORK to download a version 3.70 for the CS. But since it isn't actually posted right now, maybe there's a good reason why... like maybe you shouldn't download it... like maybe there's a problem with it :blink:

Link to comment

After it unzips the three files that it asks about then does it automatically update the software? My unit is plugged in and turned on. Thanks for the link to the download site. Now I can embark on some caching this weekend with updated (if not entirely needed) software in the unit.

Link to comment

3.7 works pretty good, it may be my imagination but the geocache list in FIND seem to refresh faster. It picked up WAS bird 35 quicker than normal, and was looking for bird 38, which it has not done before.... Tracks lay down about the same , backtrack seems to work better.... oof for another trip... :lol:

Link to comment
Now my unit does not work and the screen says I have no software!!!!

 

What I do now ???  Ugh!!!

Hi GeoWomyn_SF_CA,

 

Do not dispare, yet. I had the same problem with my 60C today. I wrote to Garmin and no answer came, so I took these steps by myself and I got it updated and it works fine.

 

It may be too late to back-up any of your data in your unit, such as waypoints, tracks, routes. I always back-up my data before a firmware update so I'm OK, this time.

 

First, re-boot your computer, and don't have any other applications running. Turn OFF any screensavers, too. With your unit turned OFF, hold the PAGE and ENTER button down while doing a POWER-ON. This will prompt you to do a full re-set. Say OK, or Yes. Next, connect your unit with the USB cable.

 

Find the "Updater.exe" where you saved it, and double-click. The Updater will do its thing and you will see a progress window, saying it is erasing the old version of firmware, followed by it indicating it is updating to version 3.70. It takes a few minutes.

 

At least worked for me. In my case I think my update was interupted by an incoming email notification. That's when my problem hit, as I saw the message flash.

 

Good luck, and let me know if this worked for you?

-Timpat

Link to comment
Now my unit does not work and the screen says I have no software!!!!

 

What I do now ???  Ugh!!!

Hi GeoWomyn_SF_CA,

 

Do not dispare, yet. I had the same problem with my 60C today. I wrote to Garmin and no answer came, so I took these steps by myself and I got it updated and it works fine.

 

It may be too late to back-up any of your data in your unit, such as waypoints, tracks, routes. I always back-up my data before a firmware update so I'm OK, this time.

 

First, re-boot your computer, and don't have any other applications running. Turn OFF any screensavers, too. With your unit turned OFF, hold the PAGE and ENTER button down while doing a POWER-ON. This will prompt you to do a full re-set. Say OK, or Yes. Next, connect your unit with the USB cable.

 

Find the "Updater.exe" where you saved it, and double-click. The Updater will do its thing and you will see a progress window, saying it is erasing the old version of firmware, followed by it indicating it is updating to version 3.70. It takes a few minutes.

 

At least worked for me. In my case I think my update was interupted by an incoming email notification. That's when my problem hit, as I saw the message flash.

 

Good luck, and let me know if this worked for you?

-Timpat

Dear TimPat,

Thank you for trying to help me.

 

I was so hopeful but when I followed your steps (PAGE + ENTER while powering on) my GPS let out a big wail and said "software missing." Or maybe that was me wailing. I had rebooted my computer, I dont have any screen savers and I turned off my virus protection program.

 

It is interesting to know that the first time I was downloading the s/w, installed it and lost everything my phone rang. So I wonder if someone was trying to call me while I was downloading the s/w off the Garmin site.

 

I am open to anymore ideas !

Link to comment
I am open to anymore ideas !

Sorry to hear this. The only other thing I can think to try is to remove the batteries, and re-do the hard re-set, then the listed steps again. When you did the re-set before, did it let you get anywhere before it gave the big wail?

Link to comment

Try downloading the update again from scratch...delete the first update and also the folder/files where the update is extracted to when you run the downloaded file (the default extraction folder is C:\Garmin...take care not to delete your MapSource installation just in case you happened to install it in C:\Garmin) and try to re-do the update. Sometimes a download will say it's successful but in reality, some bits have been dropped or lost in cyberspace...

Edited by SergZak
Link to comment

GeoWomyn_SF_CA

 

Don't reset your unit yet.

 

During my first software update I didn't wait long enough for files to be uninstalled/ installed and I got the "software missing" message. Plug your 60cs into the computer, turn it on and look for the file Updater.exe in the Garmin folder. Open Updater.exe and in the dialog box set your connection option. Now the hard part is to wait for two or three minutes until files are uninstalled and new files installed.

 

Hope this helps!

Link to comment
GeoWomyn_SF_CA

 

Don't reset your unit yet.

 

During my first software update I didn't wait long enough for files to be uninstalled/ installed  and I got the "software missing" message. Plug your 60cs into the computer, turn it on and look for the file Updater.exe in the Garmin folder. Open Updater.exe and in the dialog box set your connection option. Now the hard part is to wait for two or three minutes until files are uninstalled and new files installed. 

 

Hope this helps!

:blink: Success!!

 

It turns out I did not wait long enough as jeepntj stated.

I re-ran the updater exe file, and this time I waited patiently.

 

I am very happy to say I now have a fully functioning GPS!!

 

Thank you everyone for your contributions to my problem.

Not only did you save me money in returning this unit back to Garmin

I can now continue caching!

 

You are truly a dream team :unsure::wacko::lol:

Link to comment

I almost did the same to my 60C, but when I updated 15 minutes ago, I then used my 2nd PC, so I would not touch a thing on the PC doing the updating. Good thing is to never touch the PC or GPS for the 2 or 3 minutes, untill you see the GPS REBOOT itself to the welcome screen.

Link to comment
v3.70

 

Changes made from version 3.60 to 3.70:

 

* Fixed lockup that could occur when approaching certain roads on the map.

[...]

* Fixed lockup that could occur when approaching certain roads on the map.

This must have been particularly bad as they fixed it TWICE! :blink:

 

Thanks for posting the update. :ph34r:

Link to comment
This must have been particularly bad as they fixed it TWICE! :blink:

Well, they had posted that fix once before, for the beta update last month, and it got me all excited. But it wasn't fixed, at least for me when approaching certain roads with guidance text "always on" and not autorouting.

 

I exchanged e-mails with Garmin (thanks to one of my posts here and some help from a Groundspeak member), and was told they were aware it was a problem and this time they fixed it, and it would be in the next non-beta release. I'm assuming this v3.70 is the release they meant, and this new fix is why they listed it again in the release notes.

 

I haven't had a chance to test v3.70 yet, but my fingers are crossed. It will be easy for me to test -- one of the spots where it locks up every time for me is on my way to work. Firmware v3.40 and earlier doesn't lock up, but the betas that followed v3.40 and everything since has locked up.

 

As I said, my fingers are crossed, and I'll definitely post here if it actually (finally!) works for me! At the very latest, I'll find out Monday when I drive to work.

Link to comment

Holy cow -- this time they really did fix the lockup problem I've been having since v3.43beta! I tested it this morning at a location where it locked up 100% of the time before. See my old thread here about the problem I was having: http://forums.Groundspeak.com/GC/index.php?showtopic=90319

 

I am pleased I can finally use the guidance text "always on" option again while driving! Thanks, Garmin! :rolleyes:

Edited by 4x5shooter
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 5
×
×
  • Create New...