Jump to content

Oregon 2.94 beta released


Followers 10

Recommended Posts

Here's hoping that they fixed the shutdowns. Some nice minor feature enhancements which have been on the wish list since the Colorado days. Downloading now, will post more over on GPSFix and the wiki.

 

http://www8.garmin.com/support/download_details.jsp?id=4393

 

Changes made from version 2.93 to 2.94:

 

* Report any problems with beta software to OregonBeta@garmin.com

* Note: After updating, the first GPS acquisition will take longer than normal. After the Oregon has been on long enough to collect the necessary GPS data, acquisition times will return to normal.

* Added ability to see a list of points from the map when several points are at the same location

* Added ability to edit a waypoint from the waypoint review

* Improved render quality of GB Discoverer maps and maps with satellite imagery

* Improved Main Menu setup and added option to add and remove items.

* Improved readability of configurable data fields

* Fixed increased battery consumption and shutdowns in some units

Link to comment

http://www8.garmin.com/support/download_details.jsp?id=4397

 

Changes made from version 2.93 to 2.94:

 

* Report any problems with beta software to OregonBeta@garmin.com

* Note: After updating, the first GPS acquisition will take longer than normal. After the Oregon has been on long enough to collect the necessary GPS data, acquisition times will return to normal.

* Added ability to see a list of points from the map when several points are at the same location

* Added ability to edit a waypoint from the waypoint review

* Improved render quality of GB Discoverer maps and maps with satellite imagery

* Improved Main Menu setup and added option to add and remove items.

* Improved readability of configurable data fields

* Fixed increased battery consumption and shutdowns in some units

Link to comment

Fantastic

Improved readability of configurable data fields

Improved Main Menu setup and added option to add and remove items.
Improved render quality of GB Discoverer maps and maps with satellite imagery

 

411.png...393.png...374.png

 

 

363.png...346.png...338.png

 

The quality of the Discoverer Maps is sooooooooo improved :)

Edited by strumble
Link to comment

Can people verify this:

 

In automotive mode (or at least with Automotive map orientation) go to the map page and tap the page. This should cause the map to jump to Track/North Up and hit the "return" arrow. Does your Oregon shutoff?

No, my Oregon 300 does not turn off with 2.94

Link to comment

Can people verify this:

 

In automotive mode (or at least with Automotive map orientation) go to the map page and tap the page. This should cause the map to jump to Track/North Up and hit the "return" arrow. Does your Oregon shutoff?

 

No but it jumps to non-Automotive mode and North up

Link to comment

Fantastic

The quality of the Discoverer Maps is sooooooooo improved :)

 

I've only just received my South West Coast Path (south) OS GB Discoverer and the map quality is just as I had originally hoped it would be when I first saw it. I think I bought the maps at exactly the right time!

 

I love the menu sorting/display changes too, and the customisable data fields are much clearer now too.

 

Lovely!

Link to comment
Can people verify this:

 

In automotive mode (or at least with Automotive map orientation) go to the map page and tap the page. This should cause the map to jump to Track/North Up and hit the "return" arrow. Does your Oregon shutoff?

 

My 400c does not shut off.

 

The width of the active track line (black line) has been decreased in width considerably, good width now, not obscuring.

Edited by eaparks
Link to comment

Funny - I was able to reproduce the problem at will on the way home tonight but now it works fine again. One other user on the wiki has complained about a similar problem. Maybe a variant on the 2.93 shutoff issue.

 

The map display issue is still there at least in automotive mode. If you drag (pan) into the status bar at the top the map display freezes and doesn't redraw.

 

One other minor issue:

 

Select a map point which contains a waypoint and some other feature on the map. Press the new map list button and select the waypoint at the top of the list. Delete the waypoint using the new edit waypoint feature. At that point you will return to the map page and the name of the deleted waypoint is still visible in the status bar at the top, pressing this will lead to an empty screen with a Go button and the unit will be frozen. Press and hold the power to reset.

Link to comment

I just traded in my Etrex legend Hcx for an Oregon 200. I have loaded the 2.94 on it. BUT I haved noticed sometihng. If I am driving on road and miss a turn it takes FOREVER for it to recalculate, and if I am in off road, it has a slow responce time to update if I am walking..Anyone else have this problem..

Thakns

Eric

Link to comment

I'm finding it quite easy to shut the unit down while playing with the new map list button...in particular being in automotive view, bringing the list up (which means switching to north-up by clicking on the screen), examining a waypoint, and then returning to map view and then hitting the "return" to automotive view button. Almost guaranteed shut down to black screen on my unit.

 

edit:ugh now it's hard to reproduce..so variable. hate those kind if bugs.

 

edit: now I realise this was another variant of your issue Scott way up there. And it was in simulation mode. Now it isn't...so ..confirmed what you're seeing :)

Edited by Maingray
Link to comment

Well I've had my first shutdown ever on my Oregon 300. Using version 2.94 I was navigating an active route with WAAS on, backlite on, using only battery power (half charged), and orientation set for track up. While making a left turn the screen was adjusting for the turn while I was zooming (don't remember if it was in or out). All of a sudden the power shuts off. I powered back up and the route navigation resumed. I'm guessing I may have put too much of a demand on the software or the NiMH batteries.

Link to comment

Well I've had my first shutdown ever on my Oregon 300. Using version 2.94 I was navigating an active route with WAAS on, backlite on, using only battery power (half charged), and orientation set for track up. While making a left turn the screen was adjusting for the turn while I was zooming (don't remember if it was in or out). All of a sudden the power shuts off. I powered back up and the route navigation resumed. I'm guessing I may have put too much of a demand on the software or the NiMH batteries.

 

Is there another way to power this thing?

Link to comment

The Main Menu setup changes are INCREDIBLE. You can delete buttons you don't want. And to move buttons around you simply touch the one you want to move and then touch where you want to move it to. AWESOME.

 

I have been unable do this!!!

Any Help please

Just found it!

Edited by strumble
Link to comment

The Main Menu setup changes are INCREDIBLE. You can delete buttons you don't want. And to move buttons around you simply touch the one you want to move and then touch where you want to move it to. AWESOME.

 

I have been unable do this!!!

Any Help please

 

In any profile go to 'Setup' and then 'Main Menu'.

Link to comment

I must be doing something wrong. I can't get it to power off while navigating in auto mode and touching the screen.

 

..and then hitting the "back" arrow to return to the auto-screen. thats when the crash happens. And you got to be moving pretty fast.

 

Ah. My living room isn't big enough for me to move "pretty fast".

 

I will give it a try later today. Thx.

Link to comment

I got a power off!!!!!!

 

Route Planner/Create Route/Select First Point/Use Map

 

POOF!!!!!!!!

 

I just got the same thing, but I was selecting the Second Point when it happened.

 

Sometimes it happens when I touch Use Map. Other times I have to actually touch the map.

 

BTW, Garmin responded within minutes and asked for the GarminError.xml file that is under /Garmin/Debug on the Oregon.

 

Great customer service.

Link to comment

I too can confirm the bug where the Garmin crashes when touching the map while navigating somewhere and then returning to the automotive map by pressing that arrow in the lower left corner... Doesn't happen all the time though but still often enough...

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 10
×
×
  • Create New...