Jump to content
Sign in to follow this  
Followers 15
Mineral2

Garmin GPSMAP 66 series announced on 2018-08-06

Recommended Posts

Posted (edited)
45 minutes ago, RecipeForDisaster said:

Here's what I'm doing now: geocaching/menu click/GC live download/download near/map point 50 miles away. Every single time I get "no results found". I understand it's not supposed to work this way, but this is what i get. 

 

I am able to duplicate this behavior only when I intentionally search in areas where I know there are no geocaches (Indian reservations, for example).

 

When purposely enabling filters for cache types that I know are not present for any given location, then searching near that location, I also get the 'no results found' screen.

 

You need to enable the 'Show All' filter.

 

Edited by Atlas Cached

Share this post


Link to post

Yes, it's a custom filter.

 

And yes it's very clear to me that the caches are centered on my current location-I own most of them and are very familiar with them :)

Share this post


Link to post

I had thoroughly read the rChive but will look it over again to de how to access Show All. You'd think it be self explanatory as it isn't with my other devices... but resetting it would definitely remove filters, and I had this same behavior right after a reset. Plus, search near should work in my list of downloaded caches when I have my SD card in. 

 

I am throughly sure there are caches where I'm searching-the map point I am picking is a large city, for instance.

Share this post


Link to post
17 hours ago, RecipeForDisaster said:

Yes, it's a custom filter.

 

And yes it's very clear to me that the caches are centered on my current location-I own most of them and are very familiar with them :)

 

17 hours ago, RecipeForDisaster said:

I had thoroughly read the rChive but will look it over again to de how to access Show All. You'd think it be self explanatory as it isn't with my other devices... but resetting it would definitely remove filters, and I had this same behavior right after a reset. Plus, search near should work in my list of downloaded caches when I have my SD card in. 

 

I am throughly sure there are caches where I'm searching-the map point I am picking is a large city, for instance.

 

Well, nuts. 

 

I am running out of ideas!

 

Seems you have some bad luck with these units that others are not experiencing...

 

Maybe get a third GPSMAP 66 and see if your luck improves?

Share this post


Link to post

I did apply "show all" to see if my luck changed (at least I know where that setting is now). Nope. I'm pretty good with technology but I do have lousy luck! I doubt they'll replace this again... I guess I can live with this failure, but it's hard to stomach with a splurge on a new device. My only real hope is that when they get my old one back, they actually test it and figure out what the problem is, then release an update to fix it. 

 

I haven't gotten to try all of the other features to see whether the other bugs have persisted, but I sure hope not. Overall, I really like it!

 

That said, my old eTrex 20 works beautifully-it's just that the skin is loose and the plastic is cracked. My Oregon 400 works very well but sometimes has erroneous location data, to the tune of 0.25 miles off when it claims to have great signal! I've never figured that one out.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 15

×