Jump to content

Latest of the ubiquitous Server Error in '/' Application


Nazgul
Followers 1

Recommended Posts

Besides the site being intermittently very slow, now I get this when I try to log a find from today:

 

Server Error in '/' Application.

Runtime Error

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

 

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

 

<!-- Web.Config Configuration File -->

 

<configuration>

<system.web>

<customErrors mode="Off"/>

</system.web>

</configuration>

 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

 

<!-- Web.Config Configuration File -->

 

<configuration>

<system.web>

<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>

</system.web>

</configuration>

 

Has someone made a "Server Error in '/' Application" geocoin yet? Now *that* I would buy. <_<

Link to comment

I'm getting the same error every time I follow a link from the forums directly to a cache page. However, if I click the user's profile link (also from the forum) and then get the list of the person's caches and then click to the cache in question that way, it works. Very odd and quite annoying... It's been going on since yesterday afternoon sometime (UK time).

Link to comment

Add me to the list of users having this problem. It seems to be affecting some caches but not all. I first noticed the problem from links in notify emails, but it's not restricted to links in emails: even pasted direct into the browser a link that should work doesn't.

 

For example:

http://www.geocaching.com/seek/cache_detai...3b-59a03e3c29f0 (pasted direct from a notify email) returns the error quoted by the OP.

This is actually GCNFYN, and:

http://www.geocaching.com/seek/cache_details.aspx?wp=GCNFYN

doesn't work either.

But entering GCNFYN into the waypoint search at http://www.geocaching.com/seek does.

 

This problem seems to affect about 1 cache in 4, so it's rather frustrating :blink:

 

In case it matters: IE6 XPProSP2.

Link to comment

I think it has something to do with the ASP_session cookies:

If you have not visisted gc.com in this session, a direct link to a cache_details page (sometimes) fails. If you visit gc.com main page, and try the link again it suddenly works. (In the meantime the server has sent an ASP_SESSION_id cookie to your browser)

 

try this:

(first close all browser windows, or make sure you have not visited gc.com in this session)

visit link http://www.geocaching.com/seek/cache_detai...3b-59a03e3c29f0

if this gives an error, goto: http://www.geocaching.com/seek

and after that retry the link above; it suddenly works like it should.

Edited by Kalkendotters
Link to comment

Today, getting to any page is typically taking me about 20-60 seconds to start getting the information back from the server.

 

The google map took about three minutes to load up fully. When it did load, it's not working correctly: It's not reliably loading up caches; it's giving the you are zoomed out too far" message when I am not anywhere near zoomed out so far; and I've clicked on the cache I was interested in multiple times before it finally brought up the info balloon.

 

I like the new google maps, but I prefer the maps to be *reliable* and work when I need them to work. Same goes for the rest of the site.

Link to comment

I think it has something to do with the ASP_session cookies:

If you have not visisted gc.com in this session, a direct link to a cache_details page (sometimes) fails. If you visit gc.com main page, and try the link again it suddenly works. (In the meantime the server has sent an ASP_SESSION_id cookie to your browser)

 

try this:

(first close all browser windows, or make sure you have not visited gc.com in this session)

visit link http://www.geocaching.com/seek/cache_detai...3b-59a03e3c29f0

if this gives an error, goto: http://www.geocaching.com/seek

and after that retry the link above; it suddenly works like it should.

I don't pretend to understand that, but it certainly works as you describe.

 

But what does it prove? And, more importantly, how do I fix it permanently? Or is this something for Groundspeak? It certainly didn't happen before last week's changes.

Link to comment

I think it has something to do with the ASP_session cookies:

If you have not visisted gc.com in this session, a direct link to a cache_details page (sometimes) fails. If you visit gc.com main page, and try the link again it suddenly works. (In the meantime the server has sent an ASP_SESSION_id cookie to your browser)

 

try this:

(first close all browser windows, or make sure you have not visited gc.com in this session)

visit link http://www.geocaching.com/seek/cache_detai...3b-59a03e3c29f0

if this gives an error, goto: http://www.geocaching.com/seek

and after that retry the link above; it suddenly works like it should.

I don't pretend to understand that, but it certainly works as you describe.

 

But what does it prove? And, more importantly, how do I fix it permanently? Or is this something for Groundspeak? It certainly didn't happen before last week's changes.

This gives you a workaround till Grounspeak corrects it:

first open www.geocaching.com in a separate IE-window, and only then click on the cache-links.

Link to comment

I think it has something to do with the ASP_session cookies:

If you have not visisted gc.com in this session, a direct link to a cache_details page (sometimes) fails. If you visit gc.com main page, and try the link again it suddenly works. (In the meantime the server has sent an ASP_SESSION_id cookie to your browser)

 

try this:

(first close all browser windows, or make sure you have not visited gc.com in this session)

visit link http://www.geocaching.com/seek/cache_detai...3b-59a03e3c29f0

if this gives an error, goto: http://www.geocaching.com/seek

and after that retry the link above; it suddenly works like it should.

And the final part of the puzzle:

This only happens when the cache has additional waypoints. If no additional waypoints have to be shown for this cache the direct link wil not give an error. If there are add-wps the site has to have a correct asp_session_id or you will receive the server-error.

Link to comment

To plan caching trips, I often have opened the results of a pocket query for the appropriate area in MapSource and then veiw the results in GoogleEarth. In the past I've then been able to click on the icon for any of the caches and then open the link to the cache page. Recently I've been having problems and getting the "server error notice" on what I thought were random caches when I try to open them that way. I now see that this is happening only on those caches that have addittional waypoints for parking, etc. Kind of frustrating. What ever is the problem, I wish it would get fixed soon.

Link to comment

I received several "New Cache" Notifications this morning and clicked the links in my email in order to view them. All of them opened except for this one.

 

Here is the email message:

For GC16TK0: The Flume Stoppeths Nearby (Traditional Cache) Location: California, United States 11.5mi NW (18.6km NW) Marko Ramius published The Flume Stoppeths Nearby (Traditional Cache) at 10/19/2007 Log Date: 10/19/2007 Published Visit this log entry at the below address:
Visit Traditional Cache The Flume Stoppeths Nearby
Profile for Marko Ramius:
Notification: New Traditional Caches

 

And here is the error I get:

Server Error in '/' Application.

Security Exception

Description: The application attempted to perform an operation not allowed by the security policy. To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

 

Exception Details: System.Security.SecurityException: Requested registry access is not allowed.

 

Source Error:

The source code that generated this unhandled exception can only be shown when compiled in debug mode. To enable this, please follow one of the below steps, then request the URL:

 

1. Add a "Debug=true" directive at the top of the file that generated the error. Example:

 

<%@ Page Language="C#" Debug="true" %>

 

or:

 

2) Add the following section to the configuration file of your application:

 

<configuration>

<system.web>

<compilation debug="true"/>

</system.web>

</configuration>

 

Note that this second technique will cause all files within a given application to be compiled in debug mode. The first technique will cause only that particular file to be compiled in debug mode.

 

Important: Running applications in debug mode does incur a memory/performance overhead. You should make sure that an application has debugging disabled before deploying into production scenario.

 

Stack Trace:

 

[securityException: Requested registry access is not allowed.]

System.ThrowHelper.ThrowSecurityException(ExceptionResource resource) +48

Microsoft.Win32.RegistryKey.OpenSubKey(String name, Boolean writable) +2752377

System.Diagnostics.EventLog.CreateEventSource(EventSourceCreationData sourceData) +360

System.Diagnostics.EventLog.VerifyAndCreateSource(String sourceName, String currentMachineName) +212

System.Diagnostics.EventLog.WriteEntry(String message, EventLogEntryType type, Int32 eventID, Int16 category, Byte[] rawData) +211

System.Diagnostics.EventLog.WriteEntry(String source, String message, EventLogEntryType type, Int32 eventID, Int16 category, Byte[] rawData) +80

System.Diagnostics.EventLog.WriteEntry(String source, String message, EventLogEntryType type) +14

Geocaching.UI.GpxWptListControl.DisplayWaypoints() +687

Geocaching.UI.cache_details.BuildCachePage() +6633

Geocaching.UI.cache_details.Page_UserLoggedIn(Object sender, EventArgs e) +57

Geocaching.UI.WebformBase.LoginUser(User user, Boolean saveToken) +1490

Geocaching.UI.WebformBase.IsLoggedIn() +1072

Geocaching.UI.cache_details.Page_Load(Object sender, EventArgs e) +573

System.Web.UI.Control.OnLoad(EventArgs e) +99

System.Web.UI.Control.LoadRecursive() +47

System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +6978

System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +213

System.Web.UI.Page.ProcessRequest() +86

System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context) +18

System.Web.UI.Page.ProcessRequest(HttpContext context) +49

ASP.seek_cache_details_aspx.ProcessRequest(HttpContext context) +4

System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +303

System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +64

 

Version Information: Microsoft .NET Framework Version:2.0.50727.832; ASP.NET Version:2.0.50727.832

 

Opera 9.23

Win XP Media Edition

Link to comment

Ditto i cant list a new cache, all my bookmarks of owned caches do the same i have to go to my profile click on owned caches to get in.

 

CLicking on notification links either works or fails a few refreshes and sometimes it works.

 

Log out clear browser history go back in sometimes works and then it doesn't.

 

Been like this for a while now. :(

Link to comment

I have seen the exception for, perhaps, 10-20% of the recently-published caches I bring up (view cache details). Of the times I remember, I always pull the cache by the "wp" query string (so I am not clicking on a link, but manually entering a URL via my Firefox bookmark keywords). At times, a security exception is thrown.

 

Workaround:

When I try to view a cache page and an exception is thrown, I pull up the log page for the same cache (again, a manual URL entry with bookmark keywords), then click the cache title. This almost always works and I am able to see the cache description. Other than that, I just wait for a minute and try again.

 

Periodic exceptions are a pain to repro and debug. You never know if the current thread you're stepping through will produce the exception, nor if the act itself of stepping through will never repro the exception. Being a .Net web developer myself, I understand the pain.

Link to comment

I get this wonderful error about half of the time when I'm clicking submit when editing a cache or uploading an image >>

 

Server Error in '/' Application.

--------------------------------------------------------------------------------

 

Runtime Error

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

 

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

 

<!-- Web.Config Configuration File -->

 

<configuration>

<system.web>

<customErrors mode="Off"/>

</system.web>

</configuration>

 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

 

<!-- Web.Config Configuration File -->

 

<configuration>

<system.web>

<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>

</system.web>

</configuration>

 

 

What a buggy site! :)

Link to comment

A custom error should be enabled that says...

 

"Processing... Please Wait..."

 

Most people would then be happy not to see the typical unhandled server error and would patiently wait (forever).

 

I prefer a real message that says...

 

"Your issue has been logged and our support staff alerted. Please do not post this to the forums as you are trippling the traffic by talking about it."

 

Either way we would not see any more Server errors...

Link to comment

I would just like to say that maybe when Groundspeak performs there "upgrades" Maybe the should make sure they fix everything so folks don't watse their money or just leave well enough alone. Everytime they"upgrade" none of my tabs work. Geocaches, trackables, gallery, bookmarks. When they do decide to fix it, they decide to screw it up again. Can someone please fix the problems and leave the site alone. I am tired of seeing this:

 

Server Error in '/' Application.

--------------------------------------------------------------------------------

 

Runtime Error

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

 

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

 

<!-- Web.Config Configuration File -->

 

<configuration>

<system.web>

<customErrors mode="Off"/>

</system.web>

</configuration>

 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

 

<!-- Web.Config Configuration File -->

 

<configuration>

<system.web>

<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>

</system.web>

</configuration>

 

I can tell you this, next year I will be $30 richer.

Thanks for all that you don't do!

Link to comment

HELLO!!!!!! Is anybody going to fix this. I am tired of all of the site issues. Maybe you should just leave it alone. Or if you are going to keep screwing things up give folks their money back.

 

I would just like to say that maybe when Groundspeak performs there "upgrades" Maybe the should make sure they fix everything so folks don't watse their money or just leave well enough alone. Everytime they"upgrade" none of my tabs work. Geocaches, trackables, gallery, bookmarks. When they do decide to fix it, they decide to screw it up again. Can someone please fix the problems and leave the site alone. I am tired of seeing this:

 

Server Error in '/' Application.

--------------------------------------------------------------------------------

 

Runtime Error

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

 

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

 

<!-- Web.Config Configuration File -->

 

<configuration>

<system.web>

<customErrors mode="Off"/>

</system.web>

</configuration>

 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

 

<!-- Web.Config Configuration File -->

 

<configuration>

<system.web>

<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>

</system.web>

</configuration>

 

I can tell you this, next year I will be $30 richer.

Thanks for all that you don't do!

Link to comment
Guest
This topic is now closed to further replies.
Followers 1
×
×
  • Create New...