Jump to content

Loading Lists/PQ from iPad to eTrex 20x


Recommended Posts

iPad OS recently allows the USB-C port to access jump drives.  Is there a way to send Lists or PQs from an iPad to an ETrex 20x (either by attaching my eTrex via cable like I do with my Windows laptop or by writing to the micro SD card via the USB-C port)?

Link to comment

Prompted into action by this post I think I have successfully transferred a PQ to an SD card using the apple sd card attachment


i downloaded the zip to my iPhone 8 IOS13

 the file goes into a new “ Download” folder

From there transfer To

 Izip Pro. -My unzip app

I unzipped the files

selected the  gpx file and hit share


from there I opened the “USB” folder went down and found the GPX folder and transferred the file

job done


Things learnt

 when I started the SD card was blank

I could use the access route from Izip pro into the card to create Folders and sub folders. ie Garmin>GPX

There is an icon of a folder eith a plus sign

the option to create folders does not seem to exist using iOS Files app

(I also have an app Filebrowser, this allowed me to create folders as well but 

 if you have a properly set up SD card this is not a problem








Link to comment





 This morning firing up my 66ST it reset it self

 it went back to initial settings.  Maps  would not load. 
i called to one map snd got a different one!!
started to reset and went back to basics

i keep maps, gpx on an SD card 

so at home I checked the sd card on a pc and there was a hidden file Folder


spotlight v100 folder


this is a virus




i deleted it and reloaded via iphone it was there again

btw the down load folder from ios will unzip files


 i then used old method to load gpx file and that was ok


 going to call Apple now!!

Link to comment
42 minutes ago, HHL said:

The GPX shouldn't have a decimal point in its name.


It looks like you're right!  It creates a big problem.


I made a pocket query and named it “12345_Testzip_9.4m”.

It downloaded as “12345_Testzip_9.4m.zip” to my iPhone 8, and I unzipped it using Izip.

It unzipped just fine to 12345_Testzip_9.4m.gpx.  So far, so good.


The problem occurs when I try to save that file internally to the iPhone. It saves as “12345_Testzip_9.4m”, which is not a GPX file. It appears that the iPhone file service “fixes” the file name to remove the “extra file extension”, which in this case is the “.gpx” part.  It's the same thing shown in the screen shot above where "8621903_stamford 9.4m.zip" saved as "8621903_stamford 9.4m".


This would be unexpected behavior in Windows. Iphone does it differently, it seems. How a Garmin GPS handles a “.4m” file extension, I can't guess. But it at least occupies space on an SD card.




I stopped playing around when I got that screwy file extension.  But rather than use my Garmin as a Guinea pig to just see what happens next, I think I'd instead make my PQs without the period in the name.  That might be a lot better.



Edited by kunarion
Link to comment

Thanks for your comments And I have been researching via an IOS FORUM as well


Yes the spotlight folder added by ios is not a virus and I think my eyes went another part  of the web page which referred to the  Spotlight v100.exe virus which I think is real 


In this case the new folder does appear to  interfere with the indexing by the gpsr..

 I tried for instance to select a downloaded UK map and it gave a downloaded French one. But I said it was the UK one

Thus therefore in the short term this new facility does not sadly work for me 


Perhaps others may wish to try 


Back to using File browser and Ravpower Filehub



Link to comment
28 minutes ago, mikeD said:

Thus therefore in the short term this new facility does not sadly work for me


There are (or were) Android Geocaching Apps that could send cache GPX files to a Garmin via USB.  That would be on my wish list, a one-click way to send files.  I don't know if I'd be sending maps all the time, that's more of a desktop PC thing anyway.


One problem I had with connecting directly to a phone is that the GPS device is then powered by the phone.  Not all of them play nice, they use too much power.  One of mine starts charging its internal batteries when plugged into USB.


If you remove the Micro SD card and send files to just that, it could work, except that you don't want to ever touch the Micro SD card in a Garmin unless absolutely necessary.  The teeny clip that holds the card is not so hot.

Link to comment
3 hours ago, mikeD said:

I tried for instance to select a downloaded UK map and it gave a downloaded French one. But I said it was the UK one

Maps are tricky. Were the downloaded maps, by chance, downloaded from Open Street Map? (garmin.openstreetmap.nl)
Maps are given a name that is independent of the file name, and OSM maps are all named the same thing. So if you attempt to install two different OSM maps, the device can only recognize and display one of them. If you're using OSM to get maps of the UK and France, I suggest creating a single map that includes both regions.

If you're using another source, it's possible the same issue is occuring. Or it could be something else. But I doubt that the hidden spotlite folder is the cause of your woes.

Link to comment

the maps were one osm and the other built in Garmin topo

it just got the two mixed up pick one and it showed the other


 since this started this morning i have been retesting 

taking on on HHL’s comment on the extra dot / period in the file name i have redone the PQ.  No extra dot

i saw comment that the spot light wouldnt interfere with indexing unless there was something wrong ( according to ios). Perhaps the xtra dot threw it

i transferred raw gpx files again and it seems to work without crashing

 you have to be careful that the file is not transferred as a folder with the gpx imbedded in it. 
This happened a couple of times

all good so far

I transferred 5 gpx files  but when i checked on the pc there were 10 files

screen shot attached
each file has extra characters and and underscore ahead of the file name

is this another issue with mac/ios gile management?

it works ok though

screenshot 2019-10-11 17.29.48.png

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...