Jump to content
Sign in to follow this  
Followers 4
Autumn Nelson

Basic Membership problems downloading to Magellan eXplorist GC

Recommended Posts

I just received a Magellan eXplorist GC GPS, and I am having problems downloading geocaches onto the device. When I click "send to GPS," a separate window pops up that asks me to read and accept the license agreement. I check the box that says "I accept the license agreement" and click submit, but nothing happens. The scroll box with the agreement in it just pops back up to the top, and the screen doesn't go away or change or anything. I am using Google Chrome on a Mac OS computer.

 

Also, I am not a premium member yet, and if there is a way to download the caches to my gos (and I'm sure there is), I would rather go that route. Please help! Thank you!

Share this post


Link to post

Hey Tadpole, where do you see the "Send to GPS" button? We've been looking everywhere.... We have a Premium Membership and are trying to download to a eXplorist GC. I think I've accepted the licence agreement about 8 times so far...

Edited by Jim & Nathalie

Share this post


Link to post

It should be right above the cache description. That's where mine is at least. That's the problem I have been having, too! I keep agreeing to the terms and conditions, but it does nothing.

Share this post


Link to post

Maybe the problem isn't your eXplorist.

 

If you are using IE 11 or even some other version of IE (there apparently was a recent "automatic" update), you will most likely need to check the compatibility mode of your browser. Find it under "Tools".

 

 

...or you can switch to either Firefox or Google Chrome.

Share this post


Link to post

I'm using Chrome, have looked in tools. Is there something that should stand out in tools? Compatibility mode doesn't jump out there.

 

JB

Share this post


Link to post
I'm using Chrome, have looked in tools. Is there something that should stand out in tools? Compatibility mode doesn't jump out there.

Compatibility mode is an IE problem. If you're using Chrome, you should be fine.

Share this post


Link to post

I just received a Magellan eXplorist GC GPS, and I am having problems downloading geocaches onto the device. When I click "send to GPS," a separate window pops up that asks me to read and accept the license agreement. I check the box that says "I accept the license agreement" and click submit, but nothing happens. The scroll box with the agreement in it just pops back up to the top, and the screen doesn't go away or change or anything. I am using Google Chrome on a Mac OS computer.

 

Also, I am not a premium member yet, and if there is a way to download the caches to my gos (and I'm sure there is), I would rather go that route. Please help! Thank you!

 

Sending the whole cache-description, hints, and all, is a premium member feature. To get the most from both the GPS and the website, you should upgrade-however it is possible to cache as a basic member-although you will get the co-ords and nothing else. I believe you have to select LOC file instead. I may be wrong though...

Share this post


Link to post

I've have the same problem on all modern browsers (IE, Firefox, Chrome and Safari) I'm a programmer by trade and this is just a poor quality software problem on both Magellan and Geocaching.com's part. I'm going to send my device back and cancel my Premium membership (that made no difference). All that is needed is to copy some text files and it shouldn't take anyone all morning to achieve that (as it has with me). Vote with your wallet.

Share this post


Link to post

I had issues trying to use IE to load caches for my mom (I am experienced enough to generally know what I am doing and she is a total newbie with a brand new Magellan GC for Xmas). Once I switched to Chrome, I had no further issues. I don't remember having to agree to any terms, but maybe I did a month ago when I first figured out how her GPSr worked before I gave it to her.

Share this post


Link to post

I had issues trying to use IE to load caches for my mom (I am experienced enough to generally know what I am doing and she is a total newbie with a brand new Magellan GC for Xmas). Once I switched to Chrome, I had no further issues. I don't remember having to agree to any terms, but maybe I did a month ago when I first figured out how her GPSr worked before I gave it to her.

Also, once we were using Chrome, just clicking "send to GPS" worked (although it does not include hint, description, etc). She is a basic member.

Share this post


Link to post

I have a premium membership and I'm having the same problem. Either I get a pop-up to accept terms or download software. I downloaded and installed the software and nothing has worked so far. I'm Running the latest version of Firefox. I have sent a request for help to Groundspeak. Maybe I'll get some help there.

Share this post


Link to post
:P I just learned that Firefox had a new download that deals with security and connection problems. I downloaded it and things seem to be working. I just downloaded four caches with no problem.

Share this post


Link to post

Glad to hear the problem is fixed. Downloading PQ's is easy, I've just signed up for premium, after a year of basic, but still can not download individual caches. I hope this update will fix this issue.

Share this post


Link to post

Am having the same problems. I have used Firefox - that gave me the revolving door agreement page. I tried IE - that wouldn't allow me to pick the Magellan explorist GC. I have tried Chrome and it gets me to the Magellan tab but tells me to download things. So I did and still nothing.

 

I just want to use my Christmas gift!!

 

Any other ideas?

Share this post


Link to post

I am also having problems....

I have used my GPS before without any problems. Love it.Only been caching for about 6 months and this is my first problem with it.. But now I can not send caches to it. The window pops up and it has the 5 different GPS'S. The Delorme is up, but you can't click on the tab that is Magellan. I have tried so many different things to fix this issue. I have re-installed my GPS.. Nothing. I went to delete my device, now it won't even let me put a primary device back in. I choose my device and hit submit... Nothing. Was thinking it was maybe the website. E-mailed them, Havent heard back yet. But someone above mentioned that it may be the updates to IE 11???? Was looking at the tools.. Didn't see what they were talking about. I'm getting very frustrated.. Please someone help me out! :mad:

Share this post


Link to post

I finally got my GPS to work!!! It turns out the software on the GPS was out of date (why they sent me a brand new GPS with out of date software, I do not know). I downloaded the up to date software from the internet. I also had to use Safari instead of Google Chrome. Now it works perfectly! I still will have to get a premium membership to use all the features, but at least I know it works!

Share this post


Link to post

I had the same issue when I began and changed to chrome which helped. I also found out about software called vantage (maybe vantage point) and that's awesome. You run your pocket query in geocaching website which will sync to vantage and then when you plug your gc in to connect you choose to sync and a few minutes later you are loaded with caches and ready to roll. Have a look on you tube there are some videos showing you step by step how to do this.

Share this post


Link to post

Try:

Accept terms, sign out of site, log back in.

 

thanks bear. this worked

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 4

×