Jump to content
Sign in to follow this  
Followers 10
RaffeR

COMPLETED (25129) - [BUG] Caches do not display on beta map on mobile devices

Recommended Posts

I've been working on a tablet pc with Android for the last few weeks.

The geocaching.com website functions quiet well with the normal browser except for the map.

 

The beta map is not displaying any caches. I have tried several browsers but none of them showed the caches.

The maps themselves are visible, as well as the left side pane where you can choose your options, search, pocket queries and so on.

 

Can you please investigate why the caches are not appearing?

 

PS: If I click on the link to go back to the original map it works. The caches are displayed on the old original map but this map is quiet useless to work with :)

Edited by RaffeR

Share this post


Link to post

Hi,

 

Nobody has a clue?

 

I have the same problem on my Galaxy Tab with Android.

Edited by CachePac

Share this post


Link to post

I have also got this problem, and had been trying to figure out a workaround for a while. I am using an Asus Eee Pad Transformer.

 

Browsers tried:


  •  
  • Stock Android browser
  • Firefox Mobile (Fennec) beta versions between v7.0.1 and 10.0.1
  • Firefox Mobile (Fennec) release versions between v7.0.1 and 9.0.1
  • Opera Mobile v11.50
     

 

The beta map website does work on all these browsers, it's just unusably slow. What normally happens is that the main page loads up fine, with the Google base map. However, the map tiles from the geocache overlay either take ages to load, or don't load at all. The best you can normally hope for is that after a few minutes, you end up with only one or two tiles of caches loaded - sometimes resulting in "sliced" cache icons, where the the cache was on the edge of a tile.

 

The cache location data is loaded separately from the geocache map overlay. Sometimes, if you happen to know where a cache is located, you can click on the map and see the cache details pop-up, even though you can't see the icon. However, this doesn't always seem to work either.

 

I know that there isn't some fundamental conflict between Android browsers and Beta Maps, because occasionally it works. Also the developers' desktop version of Fennec is fine. My guess is that something is causing the overlay tiles and geocache data to load so slowly on the tablet that they time-out and do not get displayed. I don't think that my internet connection is the issue, because I am using the same home wifi connection as my normal laptop. I don't think it's the processing power of the tablet either, because it is fine with other web apps that use the Google Maps API. Also, all the normal map features (scrolling, zooming, etc.) work fine on Geocaching.com - it's just the geocaching specific bits that are the problem. It's not a browser-specific issue either, as the problem happens in browsers with three different engines.

 

A few months ago, the Beta Maps were working OK on my tablet, but only when I used Firefox Mobile with the user agent set to spoof desktop Firefox. If I used the other browsers, or the normal user agent, I got the problems above. Unfortunately that workaround doesn't seem to work any more. This made me think it was a configuration issue with the geocaching.com servers, but I'm also suspicious of the number of errors and warnings you see in the browser console when you load the site (especially in Chrome). Maybe excessive error-handling is slowing things down?

 

It would be great to get this fixed - the Android tablet is fast becoming my browser of choice, both around the house and when on the road.

Share this post


Link to post

Screenshot from Firefox Mobile v9, taken on ASUS Eee Pad:

 

P20120114123907.JPG

 

Here's the problem. This view should show four geocaches, with a fifth under the pop-up. As only one tile of the geocache overlay loaded, you can only see one and a half. But since I checked on my PC and clicked in the right place, I've popped up the details of one of the missing ones...

Share this post


Link to post

Is there a way to bring this topic to the attention of Groundspeak? I have no clue that they have read this topic.

Share this post


Link to post

I've been working on a tablet pc with Android for the last few weeks.

The geocaching.com website functions quiet well with the normal browser except for the map.

 

The beta map is not displaying any caches. I have tried several browsers but none of them showed the caches.

The maps themselves are visible, as well as the left side pane where you can choose your options, search, pocket queries and so on.

 

Can you please investigate why the caches are not appearing?

 

PS: If I click on the link to go back to the original map it works. The caches are displayed on the old original map but this map is quiet useless to work with :)

 

!!! This topic was started in the Q&A section. I think this was the wrong place. I found no way to move the topic therefore I created a new one in this section !!!

Share this post


Link to post

From: CachePac

 

Hi,

 

Nobody has a clue?

 

I have the same problem on my Galaxy Tab with Android.

Share this post


Link to post

From jri:

 

I have also got this problem, and had been trying to figure out a workaround for a while. I am using an Asus Eee Pad Transformer.

 

Browsers tried:

 

Stock Android browser

Firefox Mobile (Fennec) beta versions between v7.0.1 and 10.0.1

Firefox Mobile (Fennec) release versions between v7.0.1 and 9.0.1

Opera Mobile v11.50

 

 

The beta map website does work on all these browsers, it's just unusably slow. What normally happens is that the main page loads up fine, with the Google base map. However, the map tiles from the geocache overlay either take ages to load, or don't load at all. The best you can normally hope for is that after a few minutes, you end up with only one or two tiles of caches loaded - sometimes resulting in "sliced" cache icons, where the the cache was on the edge of a tile.

 

The cache location data is loaded separately from the geocache map overlay. Sometimes, if you happen to know where a cache is located, you can click on the map and see the cache details pop-up, even though you can't see the icon. However, this doesn't always seem to work either.

 

I know that there isn't some fundamental conflict between Android browsers and Beta Maps, because occasionally it works. Also the developers' desktop version of Fennec is fine. My guess is that something is causing the overlay tiles and geocache data to load so slowly on the tablet that they time-out and do not get displayed. I don't think that my internet connection is the issue, because I am using the same home wifi connection as my normal laptop. I don't think it's the processing power of the tablet either, because it is fine with other web apps that use the Google Maps API. Also, all the normal map features (scrolling, zooming, etc.) work fine on Geocaching.com - it's just the geocaching specific bits that are the problem. It's not a browser-specific issue either, as the problem happens in browsers with three different engines.

 

A few months ago, the Beta Maps were working OK on my tablet, but only when I used Firefox Mobile with the user agent set to spoof desktop Firefox. If I used the other browsers, or the normal user agent, I got the problems above. Unfortunately that workaround doesn't seem to work any more. This made me think it was a configuration issue with the geocaching.com servers, but I'm also suspicious of the number of errors and warnings you see in the browser console when you load the site (especially in Chrome). Maybe excessive error-handling is slowing things down?

 

It would be great to get this fixed - the Android tablet is fast becoming my browser of choice, both around the house and when on the road.

Share this post


Link to post

From jri:

 

Screenshot from Firefox Mobile v9, taken on ASUS Eee Pad:

 

Resized to 93% (was 1280 x 800) - Click image to enlargePosted Image

P20120114123907.JPG

Share this post


Link to post

From CachePa:

 

When will this be fixed.

 

Its not usable in this way Groundspeak!

Share this post


Link to post

We are aware of issues with cache display on mobile device browsers. We are currently working on significant map changes on the site and this is being investigated. Note that this is not an Android-specific issues but affects other mobile platforms as well.

Share this post


Link to post

Hello,

 

my friends and mine Android cell phones and tablets Beta Map from geocaching.com

Dont shows caches on the map.

 

When will this be fixed, because the normal map is dont worth it to work with it.

 

Thx

Share this post


Link to post

As of this posting I am still not able to view caches in MAP view on my iPad or iPhone. Doesn't matter if we use the Beta Maps, or the Non-Beta Maps.

 

TGC

Share this post


Link to post

Why does the beta map doesnt shows caches on my android tablet and phone?

 

When will this be fixed?

 

Please dont delete this thread again, thx.

Share this post


Link to post

The beta map on the website? This forum is just for the Groundspeak Android App.

 

I didn't do much with it, but I was pleased to see that the stock browser on Android 4.0.1(Ice Cream Sandwich) seemed to handle the beta map page somewhat better.

Share this post


Link to post

Why does the beta map doesnt shows caches on my android tablet and phone?

 

When will this be fixed?

 

Please dont delete this thread again, thx.

 

No one deleted your thread; you will see that this is being discussed elsewhere here and here, and your duplicate thread was merged into the former. I will now merge all of these threads into the main one.

Share this post


Link to post

When I go to the Pocket Queries screen in gc.com on my Android phone (using the Dolphin browser)....and I click the Preview In Google Maps button I get a new screen that contains no map and no caches. It's just a blank box. I can use Preview Pocket Query and see the list of caches in that screen.....but then if I say Map This Location I get the same blank map box. Does anyone know how to fix this so that I can see the caches in a preview screen or map page? Thanks!

Share this post


Link to post

I'm in a debate whether to buy an Apple iPad or step up to the Apple Macbook Air.

One of the common sites I visit is the beta maps page on the GC.com website to see, globally, all the caches of certain areas.

I've noticed on the iPad, the graphical icons of the caches on the beta maps screen do not seem to show up. Sometimes I get one or two caches to display, but not a city of caches as it would display as if I were on a desktop computer (compare the beta maps screen on a desktop computer compared to the same page on an iPad).

Would it be possible to tweak the beta maps feature to work on an iPad as it would on a desktop? This would make my purchase decision much easier on which platform to buy.

Thank you for all your hard work on this.

 

SuperDave_GPS

Edited by SuperDave_GPS

Share this post


Link to post

I have tablets from different manufacturers, running various versions of Android OS and they ALL fail to render caches on the map. Same is true with iPad.

 

I have a diverse enough collection of devices to say this is not isolated and GS need to get with it and make the necessary correction. It has been broken LONG ENOUGH!

Share this post


Link to post

This issue stems from most mobile browsers being incompatible with the technologies we use to display the caches on the beta map. The good news, however, is that we are completely overhauling the beta map in the wake of Google's change of licensing terms. The new map - which should be available in next week's site update or at least by the March release - works much better with mobile browsers and does not suffer from this limitation. (It also shows only the caches contained in a PQ rather than all caches!)

Share this post


Link to post

This issue stems from most mobile browsers being incompatible with the technologies we use to display the caches on the beta map.

For the Tech lovers out there could you expand on the Technologies you're using that dont work on the Google Android system while running Googles Maps ?

Share this post


Link to post

After the new update today. The caches are now showing in the map.

 

Strange thing..... The caches are loading & showing on my iPhone & iPad in Safari about twice as fast as they are on any of my computers.

 

TGC

Share this post


Link to post

Hi there,

 

The new maps are more or less good and the caches are even shown completly on the map. But I've got the problem that if I click on a cache symbol at the map no tooltip with the cache informations occur. Currently I'm using a IPad1 with iOS5 (browser: Safari).

If I choose a PQ the contained caches were shown properly and the caches are clickable, but only on the side bar not on the map. Simply nothing happen if I click on a cache icon on the map. Do I something wrong or is this a (known) bug?

 

Regards

Brunus

Share this post


Link to post

 

If I choose a PQ the contained caches were shown properly and the caches are clickable, but only on the side bar not on the map. Simply nothing happen if I click on a cache icon on the map. Do I something wrong or is this a (known) bug?

 

 

There are reports of this happening intermittently. Please let us know if it clears up for you or persists.

Share this post


Link to post

The JavaScript library we use seems to have issues on various mobile devices.

 

So are there plans to switch to a Javascript library that doesn't seem to have issues on various mobile devices, especially considering your release notes tout the phrase

 

Support for tablets like the iPad and other mobile devices

 

Seems counter-intuitive...

 

--MGb

Share this post


Link to post

Got the same problem on my ipad2 and smartphone. I can now see the caches but can't get them to open, thus I can't get the GC codes or details off.

It's worse than the previous issue, which I could work around by adjusting the zoom level.

I have checked on and off every day since the update on Tuesday, and it still doesn't work so I'd say it's more than a temporary glitch.

Can we get this resolved please ?

Share this post


Link to post
I'd say it's more than a temporary glitch.

Can we get this resolved please ?

Based on history, I'm guessing that Groundspeak doesn't see this as a critical issue that needs to be hot-fixed. It will probably get fixed at the next site update in 2-4 weeks.

Share this post


Link to post

Hi there,

 

The new maps are more or less good and the caches are even shown completly on the map. But I've got the problem that if I click on a cache symbol at the map no tooltip with the cache informations occur. Currently I'm using a IPad1 with iOS5 (browser: Safari).

If I choose a PQ the contained caches were shown properly and the caches are clickable, but only on the side bar not on the map. Simply nothing happen if I click on a cache icon on the map. Do I something wrong or is this a (known) bug?

 

Regards

Brunus

 

I am having the exact same issues on my iPad 2 w ios 5. It's crazy that we've swapped out one set of bizarre map problems for a different set. In addition, the maps available in a regular computer web browser now have a completely different set of NEW problems created by the switch away from Google! This is very puzzling and disappointing. I can only hope there is a massive effort to fix all the problems with mapping and focus less on creating new activities like Challenges.

Share this post


Link to post

I'm also having the same problem with my iPad2. Since I usually use my iPad for planning routes using the maps, this is now useless as I can't tap the cache icon to get cache name and gc number etc.

 

Grounds peak, if you are reading, can you resolve this issue or even advise that you are aware and looking into it. Cheers.

Share this post


Link to post

I can confirm that the new maps are not working on the iPad.

 

I can see all of the caches on the map, but tapping on them doesn't open the popup as it should.

 

Based on history, I'm guessing that Groundspeak doesn't see this as a critical issue that needs to be hot-fixed. It will probably get fixed at the next site update in 2-4 weeks.

 

Please take note that this is indeed a critical issue. I am using the iPad as my main method for planning Geocaching trips. I don't own a laptop and the way it currently is I am unable to plan my Geocaching trips while I'm on the go. I also have several vacation trips planned this year, where I completely rely on the iPad for this.

 

With the BETA maps it was at least possible to switch back to the old-style maps, which worked on the iPad.

 

I don't usually complain and I can really see the benefits of switching to OSM maps. But please see that this currently is a worst-case scenario for tablet users and don't just delay a fix for a site update in 2 weeks or a month or even later.

 

Please release some kind of solution as soon as possible. Even a temporary solution would be great for the moment. Maybe it is possible to temporarily bring back the old-style maps for tablet users based on the HTTP user-agent of the browser? But maybe you have better ideas or can fix the bug quickly. Some kind of solution is necessary.

Share this post


Link to post

Groundspeak is aware of the issue with informational pop-ups failing to appear when clicking on cache icons on the map on mobile devices. This is something that works properly on the test server, so we suspect a config difference on the production servers to be the cause of the problem. We are investigating.

Share this post


Link to post

A while back I wrote a Greasemonkey userscript that lets you switch from the Geocaching Maps page to the old-fashioned list of geocaches near to the point at the middle of the map. I've updated that script to work with the new Geocaching Maps page, and it now makes a simple workaround for the problem of the cache details not showing up. Use the new maps to find the general area you want, then switch to the list to see the cache details.

 

The basic userscript should run in any desktop browser that supports Greasemonkey scripts. Userscript support is pretty patchy for mobile devices, so I've also compiled the userscript into a Firefox Mobile addon. This works fine for me in Firefox 10, on both my Asus Transformer tablet (Android 3.2) and my HTC Desire phone (Android 2.2) (although you have to tell Firefox to always allow popups from geocaching.com).

 

I guess this isn't too helpful for the iOS users, but hopefully it'll help out some of the Android folk!

Share this post


Link to post

Groundspeak is aware of the issue with informational pop-ups failing to appear when clicking on cache icons on the map on mobile devices. This is something that works properly on the test server, so we suspect a config difference on the production servers to be the cause of the problem. We are investigating.

 

Thanks for updating us. Cheers

Share this post


Link to post

Just to add to the discussion...

 

On our Toshiba Thrive tablet, the geocaching.com site always worked fine on the included browser with the old maps on your site, INCLUDING the map and tap-on-a-cache-for-details function on the map... until today. Now, as others have said with the new "upgraded" maps, tapping on a cache does nothing. On a standard laptop running Firefox that click-for-details function works, but not on the Android operating system on the tablet.

 

When may we expect a resolution?

 

Thanks.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 10

×
×
  • Create New...