Jump to content

Garmin etrex venture fault

Recommended Posts

I bought my first Garmin etrex Venture HC in August 2009. That failed :D and was changed on 1st October 2009. That failed :( and was exchanged in January 2010.

That one - my 3rd!!! has just failed. :( aaaaargh.

They have all failed in exactly the same way: I switch it on, the opening and welcome screen come on - then fade out and the unit switches off.


I tried back in January to get someone - my local dealer in Eastbourne, Sussex, or Garmin's 'help' line to explain to me why this was happening. They had no explanation. One of those things. Very odd. Never happened to anyone else. Each unit has been in shop-perfect condition, not a scratch, not a fall, not a mark on any of them. I use it for caching in woodlands, towns and parks: the tamest of GPS users.


I'm about to insist they let me exchange it for a etrex Vista as this seems as uncomplicated as the Venure. Since February I have also used an iphone so it's the Garmin's cache marking properties for new caches that I really want.


Can anyone explain why this has happened? Has it happened to anyone else? Could it be because I used rechargeable batteries? Put it close to the radio in my car when out caching? Have a border collie? Am a Scot? Drive a Citroen? Like banana milkshake??? As you can see, I'm open to suggestions? :)

Link to comment

I have a Garmin Venture HC and that happens to me.


I got it way back in Summer 2007 and still use it as my primary GPS device. The fading and going off started in maybe Fall/Winter 2008. At first I found that it did it when I tried to use cheap generic batteries. Then I tried energizer and it kept doing it. Now I use Duracells and it does it less than usual.


I get what you are describing when you start it and after the splash screen it fades out. I get where it starts and when it goes to the map, I hit the button to bring up the backlight and once I hit the button it fades out and turns off. I've also gotten to where if I just barely set it down on my car hood, the impact of it touching the hood turns it off. Any sudden impact and it turns off.


I've found that barring sudden impacts, once I put in new batteries, it works like a charm untill it hits 1/2 battery life and then it starts doing the fade out thing. I always just turn it back on and keep caching until it does it so often that I decide to change batteries and start over again.


The 3 biggest factors I've noticed to cause it to fade and turn off are:

1. The batteries

2. Pushing the power button and the bottom button on the left side.

3. Sudden impacts or josttling


These observations lead me to believe that it has something to do with either the batteries or metal battery connectors josttling in the battery compartment and/or the pushing of the two buttons somehow causing the power outage.


I've been very happy with my Venture, but once it totally goes kaput, I'm gunna upgrade.

Link to comment

The earlier Garmins had an issue with battery contacts not making good contact with the batteries. This was made worse by using different types/brands of batteries as they are different lengths, even if it is very slight.


Garmin fixed this by putting a piece of foam rubber under the metal contacts to provide more pressure to the contacts.


You can also try cleaning the contacts with a pink pencil eraser.


Something to check for.

Link to comment

That model has (according to the manual) a selection under the setup section for making a setting for the battery type being used. On my old GPS MAP12 I tinkered with this setting when trying out rechargeable batteries and found that the MAP12 would behave in a manner similar to what has been described with rechargeable batteries or with alkaline batteries if the setting was incorrect. I switched back to using just alkaline batteries and rarely have trouble.


One other thing - I used to drive a Subaru Baja and discovered that laying the GPSr on the dashboard just above the radio would cause it to do pretty much what you have described. As I recall, I would have to reset the unit to get it back up and running - but I'm not positive about the reset part of that statement. Swapped the Subaru for a Jeep and got a 60CSx. Problem gone.


edit to remove redundant word

Edited by gpsfun
Link to comment

I had a similar problem with my Legend HCX's, I have 2 and both did the same thing. When I powered them up and I tried to press a button before it fully turned on and went to the satellites page they would turn off. This occurred after one of the software updates and then stopped after the most recent update.


You may want to try and update your firmware to the most current version if you have not done so yet. I did notice that if I let the units charge up fully, I could then utilize the buttons and the unit would not shut off. I also have a Venture HC that I got last September or so and I have upgraded it's software and have never had a problem with it shutting down.


Good luck.

Link to comment

I have a venture hc and I had the same issue after a couple months of use. I was at home as it was raining :wub: so I just gave garmin a call. They walked me through a update (since i couldn't get the unit to stay on long enough to do a regular update) and it has worked great ever since. Garmin was great on the phone, quick, friendly and informative (I asked if this was a common issue...it was a glitch in one of the software updates).

It was kinda funny that I even called cause I was going to just go exchange it for a new one but now I am glad I didnt. :(

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...