Jump to content


Recommended Posts

My PC will not recognize the USB port every now and them. I've tried unplugging 60c and plugging in my digital camera and it still does not work.


I re-boot the Pc and keep the 60c plugged in and on and it fixes it every time. Don't know if its a Windows 98 thing or not...

Link to comment

I had trouble getting my computer to recognize the GPS and what I think I noticed is that it matters which end of the USB cable you plug in last. No joy if I plug it into the computer first then GPS, but interface happiness when GPS first then computer. Anyone else observe this?

Link to comment

I have similar problems with the Garmin cable. On my cable, the computer end isn't too tight, but the GPS end is definitely too loose- the computer and GPS will lose connection if I wiggle the cable.

I've been using the USB cable from my Canon camera and it has none of these problems.


Edited by chris f
Link to comment

After installing the software that came with my 60cs, I had to go back in later and re-install the USB driver by itself from the CD. My computer wouldn't recognise the device untill I did so. If your still having problems, try that. I noticed the date differance too on the Garmin website for their driver and that is what prompted a second look at the CD. Good luck.


Link to comment

I had problems, too, getting the gps to be USB-recognized. I think I had my computer try to install the 60cs too early, before I had updated City Select to version 5.4. Called Garmin (I had no time to trouble shoot, was leaving the next morning for a road trip) and they walked me thorugh it. They had me download some drivers from the web site (I'm not sure which ones) and then, well I'm not sure what. Suddenly win xp was asking me where the drivers were (it would not do that except for the first "bad" time) and then I pointed to where they were and all was fine.

Link to comment

I notice it's a snug fit. I thought it was in, but a little firmer push inward made it bottom out for the connection.


I notice the extennal antenna jack is recessed further than the 76s and the antennas rubber cover is in the way some for the antenna jack. With the gps's jack recessed the right angle plug on the Titan III doesn't seem to get in far enough to make an good connection.


One has to have a easy touch with this baby or big bucks to fix.

Link to comment

I too had problems with the USB port on my laptop working sometimes and other times notworking.


It was the USB port. I had it replaced and my problems dissappeared.


I am amazed at the speed. I can't wait for the USB support by my ExpertGps software. For now, I am exporting data from ExpertGps to a MapSource .mps file and then transferring Waypoints to the 60cs.



Link to comment

I am also currently having a problem with my 60c. I am running VPC on my Mac. its running XP Proffesional on VPC. Basically it wont recognize that the 60c is connected. when i click the box in the USB window, it recognizes it for a second, but then when i close the window, nothing. its as if i never clicked the box.

Link to comment

After being strictly a Mac guy for years, I gave up for reasons similar to the problems your having and gave my G3 to my brother and bought a SONY laptop. Still don't think Windoze is nearly as smooth as Mac, but sure makes life easier interfacing to things other than a digital camera. For some reason, that worked much better on my Mac. I miss the Mac alot when doing digital photography tasks but I hated trying to convert crap all the time to the Mac platform from some other file format that was obscure Windoze based. So, I gave up. Still prefer Quicktime for most stuff, but other than that, I will stick with the PC because that is what the business world uses. I tried using Softwindows on my Mac with very limited success. Holy smokes it was slow! I could get the SCSI stuff to work, (my scanner) but had a hard time with USB, or anything requiring rendering 3D in the Windows environment. ie games.

Good luck.



Link to comment

I notice now that If I'm not recognized I shut down the gps and restart it. That does it. That's when I 'm using both serial and usb cables. I've been loading from Mapsource via usb then to NGTopo via serial cable. But there are conflicts.


NGTopo won't recieve unless I disconect the usb cable. Mapsource won't recieve with the serial unless I restart it.


Is this getting good? I wish all would update to USB it's so nice.


I have no problem when just using Mapsource. The USB goes in fine and works great.

Link to comment

My USB connector broke and pulled away from whatever it is mounted to. Got an RMA# from Garmin and FEDEX it back via ground transportation. Got a whole new unit back two weeks later. BEWARE and BE WARNED! If you were a GPS V Deluxe owner and used the 2nd license of City Select for your 60, you can't load it on your "repaired" unit without getting a new unlock code from Garmin! As a result, I had to use my V on a trip and ran out of road detail. Garmin was quick to correct the problem when I emailed them about it.


The new unit and cord seem to be tight too so I'm very much concerned that this is a problem and am concerned about how Garmin will treat those of us with it once warranty is expired. I, for one, think we deserve an extended warranty for such troubles or at the least, a reduction in repair/replacement cost.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...