Jump to content
Sign in to follow this  
Followers 5
Zistrum

Cant view pictures in description?

Recommended Posts

As title states can't load pictures on the app on WiFi or mobile, while it loads on the website in the browser on?  For example the pictures in GC46WPY

 

Android Pixel 3XL

Screenshot_20190909-213452.png

Edited by Zistrum
  • Upvote 1

Share this post


Link to post
On 9/10/2019 at 12:23 AM, Zistrum said:

As title states can't load pictures on the app on WiFi or mobile, while it loads on the website in the browser on?  For example the pictures in GC46WPY

 

Android Pixel 3XL

Screenshot_20190909-213452.png

 

I'm getting a similar thing in the App on the iPhone.  The pictures are shown on iPhone, but the page is still way to big for the screen (which is actually the normal way the Official App works in most cases). As some people mentioned, that page is perfectly fine in a web browser, even a phone browser.  The actual image files are not too huge to load.  I'm guessing there's some HTML on that page that confuses the App, but I haven't tried to figure out what that might be.

Edited by kunarion

Share this post


Link to post
2 hours ago, SpiritGuide said:

Works just fine in Geooh.

Screenshot_20191121-202109.png

 

On the iPhone in Cachly, the text is as above, too wide for the screen, yet the images are squished thin to fit the screen.  Gotta be due to the way that page was set up.

 

Edited by kunarion

Share this post


Link to post
34 minutes ago, kunarion said:


Not only should pictures appear, the page should fit the screen.

 

On the iPhone in Cachly, the text is as above, too wide for the screen, yet the images are squished thin to fit the screen.  Gotta be due to the way that page was set up.

 

Not necessarily... the images can be scrolled to show the entire size. You don't want the images to squish which would make them display incorrectly and not allow viewing for the clues. So the page could be set up as intended except the CO didn't plan for viewing on smaller screens only on larger desktop browsers.

 

Geooh is displaying exactly what a desktop window would render if it was resized to a smaller viewport. 

Share this post


Link to post
On ‎9‎/‎10‎/‎2019 at 12:23 AM, Zistrum said:

As title states can't load pictures on the app on WiFi or mobile, while it loads on the website in the browser on?  For example the pictures in GC46WPY

 

Android Pixel 3XL

 

 

I get the same thing on my HTC U11, for that particular cache page.  But then it gets weird.  If instead of viewing the cache description, I scroll to that page's uploaded photos, I see all four load just fine by themselves.  And I uploaded one of those photos to one of my caches and it loads fine within the page, plus I don't have to scroll horizontally to see the cache description.  The text wraps as expected, and the images fit the screen. And I used the exact URL of one of the original uploaded images within one of my cache pages, and even then, the image appears, and shrinks to fit the App screen.

 

I thought that the "240 dpi" of the photos might throw off the App.  But I resized the photo on one of my cache descriptions, and again, there are no issues with the photos, and no extra-wide cache description.  Very strange.

 

Anyway, on the munged cache page, the images are set up within a table with a defined width.  I'm pretty sure the App is having trouble with that code, and that's what prevents the image from showing in these particular cases.

 

Edited by kunarion
  • Upvote 1

Share this post


Link to post
20 hours ago, OusKonNé & Cétyla said:

All pictures are displayed correctly here (Quebec, Canada).

 

Btw, I did 4 tests :

- Firefox on Windows 10 : OK
- Microdoft Edge on Windows 10 : OK
- Google Chrome on Windows 10 : OK
- Geocaching App on Samsung Galaxy S6 : OK

Share this post


Link to post

Since the last release note (January 14, 2020) Geocaching.com uses a proxy server to load/show images that are not hosted on geocaching.com (underlying hosted on Amazon Web Services). One of the reasons is that they want to block cookies from other domains. For certain puzzles that use the URL for solving the puzzle, this is a problem (see reactions in the release note topic).

 

I have one puzzle that uses images hosted on my personal web space because they contain EXIF info needed to solve the puzzle. I checked my puzzle and downloaded all images. The EXIF info is still available, but the filename changed. No problem to solve this puzzle.

 

This evening I tried to check this puzzle on the Geocaching app and noticed that the external hosted images were not shown in the app. They appear as a broken link to an image. The tother images in the listing that are hosted on Geocaching itself appear correctly. I was wondering if this is the bug mentioned in this thread or if this is a new bug introduced by using the proxyserver.

 

I double checked the behavior with friend's cache who is also hosting images on his own web space. His images were visible in the app.

  • Helpful 1

Share this post


Link to post

Just to note, the OP about broken images was from November 2019, and is unrelated to the proxy image rewrites happening now in January.

 

But good to mention the update in case people come to this thread now due to not being able to "view pictures in the description" per the thread title. = )

 

The linked thread in the previous comment would be where to continue the discussion about that change.

  • Helpful 1

Share this post


Link to post

Using an android app today, the images were little tiny boxes, and I didn't think I'd be able to view them, but clicking on them brought me the entire photo that I needed for the puzzle.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 5

×
×
  • Create New...