Jump to content
Sign in to follow this  
Followers 4
Heidevlinder

Links in communication email redirect to app instead of website

Recommended Posts

When I click the links in your communication email, I am redirected to the app which is useless. Somehow, the direction to the browser won't work.

 

(Same as the Open in browser link in the app, but this is already discussed in another topic)

Share this post


Link to post

It might be due to your phone settings - you may once have chosen the app to "always open" coord.info links, and it's just doing what you told it.

  • Upvote 1
  • Helpful 2

Share this post


Link to post

oh yeah i have that issue all the time.... its probably in the settings but i can just select open in new tab on my device... but i will definitely try what hzoi said!

Share this post


Link to post

Can't you long press the link to get an option to open in the app or .com?  Try going to the bottom of the cache page once the app opens from the link then click "open in browser".  Go back to the link and long press it to get the choice to open in safari (this assumes you are using an iPhone) or geocaching.com or whatever isn't the app.  This seems to have reset it for me and only opens links in Safari and not the app.  As they say in the forums, YMMV. :rolleyes:

Share this post


Link to post
Posted (edited)

Thank you for your reaction, but even when I choose Open in browser after long pressing the link, it opens the app.

And the link Open in browser in the app itself, also opens the app again. Deleting preferences in settings won't help eather. I've tried it all 

 

Finally, I deleted the app and installed it again. Now every link is working like it should. So, problem solved 👍

Edited by Heidevlinder
Added some text

Share this post


Link to post
Posted (edited)
1 hour ago, Heidevlinder said:

Finally, I deleted the app and installed it again. Now every link is working like it should. So, problem solved 👍

 

Cool!  This problem is not a website bug, nor a phone bug nor App bug.  It requires first knowing which phone you have (even down to the installed Apps).  If it's an iPhone, for example, it has set its defaults the way you told it to.  You may have set them unintentionally, but the iPhone is just doing what it does. 

 

I think I've pretty much figured it out for iPhone, without having to delete the app.  So keep this handy for the next time it comes up.

 

I've tried a few things on iPhone 8 just now. I can get either the App or Safari to open a cache link by default, and switch between the defaults as I like, although of course this may change. I have an iPhone 8 with iOS 12.4, and this process seems to have changed recently.

 

I'm using 3-D Touch, which is where you press slightly harder than an ordinary tap (you can test it on menu icons to get the hang of it). 3-D Touch should be on by default, here's how to set it up: 

https://support.apple.com/en-us/HT205056

 

Anyway, my intent is to not have URLs open in The Official Geocaching App. So I tried it with web site URLs and company mailed emailed URLs. The ones in Geocaching.com emails that I tested were “coord.info” URLs that resolve to Geocaching.com cache page web addresses.

 

Find a blue web link in an official email, a cache page link. Tap it and the App opens as always.

 

But if you use 3-D touch it's different:

Press on that same web link, a little harder than a tap, and now a white window appears on screen, and it soon has a little version of a web page in the window, for maybe half a second. As soon as the blank window pops up, drag the screen up, and a new window drags up from the bottom of the screen with several options in it. Tap “Open in Safari”. This tells links to open in Safari from now on. It's fixed! Kind of.

 

There will be a bar at the top of the cache page that says “Geocaching Open in the Geocaching app”. Tap it, and you've changed back to opening links in the Geocaching app. Or if you do the press-drag thing on an email link and select “Open in Geocaching”, you've also switched back to opening it in the App. Now select “Open in Safari” again, and you're back to opening links in Safari.  You may also be able to change the defaults in other ways unintentionally.

 

This may take some practice. There's a press-wait-drag thing going on and it seems to require careful timing.  You may have only a half-second to scroll the screen. If not doing it with care, I get thrown into the App as usual. So practice. I may be able to post some screen shots if you can't figure out the process.

 

Good luck!

 

 

Edited by kunarion

Share this post


Link to post
3 hours ago, kunarion said:

 

Cool!  This problem is not a website bug, nor a phone bug nor App bug.  It requires first knowing which phone you have (even down to the installed Apps).  If it's an iPhone, for example, it has set its defaults the way you told it to.  You may have set them unintentionally, but the iPhone is just doing what it does. 

 

I think I've pretty much figured it out for iPhone, without having to delete the app.  So keep this handy for the next time it comes up.

 

I've tried a few things on iPhone 8 just now. I can get either the App or Safari to open a cache link by default, and switch between the defaults as I like, although of course this may change. I have an iPhone 8 with iOS 12.4, and this process seems to have changed recently.

 

I'm using 3-D Touch, which is where you press slightly harder than an ordinary tap (you can test it on menu icons to get the hang of it). 3-D Touch should be on by default, here's how to set it up: 

https://support.apple.com/en-us/HT205056

 

Anyway, my intent is to not have URLs open in The Official Geocaching App. So I tried it with web site URLs and company mailed emailed URLs. The ones in Geocaching.com emails that I tested were “coord.info” URLs that resolve to Geocaching.com cache page web addresses.

 

Find a blue web link in an official email, a cache page link. Tap it and the App opens as always.

 

But if you use 3-D touch it's different:

Press on that same web link, a little harder than a tap, and now a white window appears on screen, and it soon has a little version of a web page in the window, for maybe half a second. As soon as the blank window pops up, drag the screen up, and a new window drags up from the bottom of the screen with several options in it. Tap “Open in Safari”. This tells links to open in Safari from now on. It's fixed! Kind of.

 

There will be a bar at the top of the cache page that says “Geocaching Open in the Geocaching app”. Tap it, and you've changed back to opening links in the Geocaching app. Or if you do the press-drag thing on an email link and select “Open in Geocaching”, you've also switched back to opening it in the App. Now select “Open in Safari” again, and you're back to opening links in Safari.  You may also be able to change the defaults in other ways unintentionally.

 

This may take some practice. There's a press-wait-drag thing going on and it seems to require careful timing.  You may have only a half-second to scroll the screen. If not doing it with care, I get thrown into the App as usual. So practice. I may be able to post some screen shots if you can't figure out the process.

 

Good luck!

 

 

Thanks, I will look and try. I just don't use Apple but for Android it will be somehow the same probably

Share this post


Link to post

Now iOS 13.1.3 comes along on my iPhone 7+ and the link default issue is back but worse!

 

The previous solutions, such as above, no longer set Safari as the default and only way I found to avoid kicking into the official app by default is to delete it (I only used it for messaging). Option to open in Safari did appear after some fiddling, but doesn’t stay as the default. Even clicking “open in browser” within third party apps such as Looking4Cache and Cachly now kick into the darned official app rather than a browser. Driving me nuts!!

 

Any ideas how to get round this step back?

 

Quite separate irritation of 13.1.3 is that the cache page “download gpx” link no longer gives the option to save the cache into your third party app, but saves to iCloud or phone instead. This means further steps to import into an app ... not the sort of “progress” I wanted!!

Share this post


Link to post
42 minutes ago, PlasmaWave said:

Now iOS 13.1.3 comes along on my iPhone 7+ and the link default issue is back but worse!

 

The previous solutions, such as above, no longer set Safari as the default and only way I found to avoid kicking into the official app by default is to delete it (I only used it for messaging). Option to open in Safari did appear after some fiddling, but doesn’t stay as the default. Even clicking “open in browser” within third party apps such as Looking4Cache and Cachly now kick into the darned official app rather than a browser. Driving me nuts!!

 

Any ideas how to get round this step back?

 

While browsing the Interwebs, I've seen a lot of complaints about iOS 13.  I'm hoping for better mistakes in the future. :anicute:

 

I've had some luck with a long-press on an email link, allowing me to choose App or Safari.  But it's not setting a default.

 

When using Looking4Cache to "Open in geocaching.com", I can't get any of my tricks to work.  I'm thinking that the developer should fix that so I can at least select which "Browser" to use.  It is opening in The App only.  However, from the App, after it opens, I can then switch to Safari.  Um, yeah, I'd like to save a step or two if possible.

 

Edited by kunarion

Share this post


Link to post

I’ve just found “the” solution .... hopefully!!
 

Another thread mentioned Cachly FAQ said if the usual solutions do not work, open a cache page in Safari then long press the GC code at top right of the cache page. Then from the menu choose “Open” and up to now I’m seeing Safari as the default when clicking links in emails or “open in browser” within Looking4Cache and Cachly.

 

Just hope the default to Safari is maintained over time. Looks good for now though, phew!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 4

×
×
  • Create New...