Jump to content
Sign in to follow this  
Followers 1
The Snowdog

"Corrected Coordinates" field won't parse Groundspeak coordinates!

Recommended Posts

I make a lot of use of the "corrected coordinates" field, and will often copy the coordinates from the page, paste them into that field, edit as necessary, and save 'em. I will be in South America next year so naturally I am looking at caches. Much to my surprise coordinates copied directly from the cache page won't parse in the corrected coordinates field! For example, GC6NC6V which is a challenge cache in Sao Paulo, Brazil. The coords on the page are in the local format (commas instead of decimals) which is no surprise; what is surprising is that the corrected coordinates field won't take them as is, copied straight from the page. 

Share this post


Link to post
15 minutes ago, The Snowdog said:

I make a lot of use of the "corrected coordinates" field, and will often copy the coordinates from the page, paste them into that field, edit as necessary, and save 'em. I will be in South America next year so naturally I am looking at caches. Much to my surprise coordinates copied directly from the cache page won't parse in the corrected coordinates field! For example, GC6NC6V which is a challenge cache in Sao Paulo, Brazil. The coords on the page are in the local format (commas instead of decimals) which is no surprise; what is surprising is that the corrected coordinates field won't take them as is, copied straight from the page. 

It's possibly the degree symbol (circle) after S 23° & W 046°

Leave it out. It will be put back in by the site.

Edited by Goldenwattle

Share this post


Link to post

I can see only normal coordinates on the page - no commas.

S 23° 27.568 W 046° 38.856

 

 

Share this post


Link to post
23 minutes ago, arisoft said:

I can see only normal coordinates on the page - no commas.

S 23° 27.568 W 046° 38.856

 

 

Same here. Normal looking coordinates.  I copied the coords, clicked on the pencil/edit icon, pasted the coords, then saved them. I tried a second time, edited them, and still had no problem.

Share this post


Link to post
4 minutes ago, Max and 99 said:

Same here. Normal looking coordinates.  I copied the coords, clicked on the pencil/edit icon, pasted the coords, then saved them. I tried a second time, edited them, and still had no problem.

Me too, I tried both copying fromt he cache page listing, and also copying from the co-ord edit box which pops up after clicking the pencil, both worked.

 

I wonder if your locale settings in your profile change the way co-ordinates are presented to use the comma and that's where the problem lies?

Share this post


Link to post
1 hour ago, MartyBartfast said:

 

I wonder if your locale settings in your profile change the way co-ordinates are presented to use the comma and that's where the problem lies?

 

My locales have always used a comma as a decimal separator and no such problem ever.

Share this post


Link to post

There's definitely a bug in the parsing.

 

This (using a dot) is accepted:

S 23° 27.568' W 046° 38.856'

 

This, using a comma in place of the dot is NOT accepted
S 23° 27,568' W 046° 38,856'


But this, using the comma in place of the dot but removing all other symbols is accepted
S23 27,568 W046 38,856

Share this post


Link to post
31 minutes ago, MartyBartfast said:

But this, using the comma in place of the dot but removing all other symbols is accepted

S23 27,568 W046 38,856

 

If you check the result you will see that this gives S 23° 36.467′ W 46° 52.267′  not what you are trying to enter!

Even it is accepted it is interpreted totally wrong way.

Share this post


Link to post
2 hours ago, MartyBartfast said:

But this, using the comma in place of the dot but removing all other symbols is accepted
S23 27,568 W046 38,856

 

It probably should not be accepted.  The minutes portion of each coordinates is supposed to be a value expressed as a decimal number.   There's a big difference between 27,568 (which, expressed as a decimal would be 27,568.00 minutes) and 27.568 minutes.  A comma could be used to separate the lat and long values.  It *should* ignore the degree  symbol as it's implied when using Degrees Decimal Minutes format.  I can also ignore the hemisphere characters as S and W are always negative degrees.   -23 27.568 -046 38.856 is the same as S23 27.568 W046 38.856

Share this post


Link to post

As some countries use the comma as a decimal separator where others user the dot; if the dialog for the co-ords is going to accept the comma in the input then it should correctly treat it as a decimal separator.

 

I suspect the display features correctly output the comma if your locale specifies it, in which case the input features should similarly accept it.

 

It doesn't bother me and I would be quite happy if they didn't accept the comma in the input, but some countries might be annoyed by it if they're used to using the comma in maths.

 

  • Helpful 1

Share this post


Link to post
32 minutes ago, MartyBartfast said:

I suspect the display features correctly output the comma if your locale specifies it, in which case the input features should similarly accept it.

 

Locale does not have any effect. I have never seen a comma here but I have to change commas to dots before entering them. Now it handles the comma some crazy way.

Share this post


Link to post
1 minute ago, arisoft said:

 

Locale does not have any effect. I have never seen a comma here but I have to change commas to dots before entering them. Now it handles the comma some crazy way.

 

Eh? earlier you said:

 

3 hours ago, arisoft said:

My locales have always used a comma as a decimal separator and no such problem ever.


So does your locale setting show commas or not?

And if the locale doesn't have any effect,  what do you think  might be causing  the OP to  see the commas displayed on the cache page that they're subsequently copying into the corrected co-ords box?

Share this post


Link to post
3 hours ago, MartyBartfast said:

So does your locale setting show commas or not?

 

Yes and no. Yes when I am using Excel and no when geocaching.

 

3 hours ago, MartyBartfast said:

And if the locale doesn't have any effect,  what do you think  might be causing  the OP to  see the commas displayed on the cache page that they're subsequently copying into the corrected co-ords box?

 

This is a very intrigue question. We don't know why the OP tried to correct coordinates which are already correct. Maybe just to mark the cache as "solved". For the OP it seems obvious that there is a comma instead of a dot.  Maybe the source of coordinates was not on the original cache page. One screenshot could answer to many questions.

Edited by arisoft
  • Upvote 1

Share this post


Link to post
48 minutes ago, arisoft said:

We don't know why the OP tried to correct coordinates which are already correct. Maybe just to mark the cache as "solved". For the OP it seems obvious that there is a comma instead of a dot.  Maybe the source of coordinates was not on the original cache page. One screenshot could answer to many questions.

 

I usually  correct the co-ords of challenges which I've qualified for, it then makes them easy to identify on the map and on various searches.

As for where did the comma come from, I  guess we need to wait for the OP to come back and tell us 🙂

 

 

Edited by MartyBartfast
  • Upvote 1

Share this post


Link to post

I even changed my home locatiom to the cache's country but no commas appeared. Just cuz I was curious.

Share this post


Link to post

Mystery solved; coordinates with the odd degree symbol and commas rather than dots are produced when using the browser's "translate this page" option.

 

And, to answer a comment above, I do use corrected coordinates on challenge caches (and others) that I want to find, so that I can search for them that way.

Edited by The Snowdog
  • Upvote 1

Share this post


Link to post
32 minutes ago, The Snowdog said:

 

And, to answer a comment above, I do use corrected coordinates on challenge caches (and others) that I want to find, so that I can search for them that way.

That's a great idea.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 1

×
×
  • Create New...