Jump to content

Authorization error with multiple Android apps

Followers 3

Recommended Posts

Since Saturday evening I am unable to authorize any of various Android apps to log in with my (premium) geocaching.com account.


Several just give an error, while some say that the website https://www.geocaching.com/OAuth/mobileoauth.ashx?oauth_token=XYZ&force_login=true cannot be reached (of course replace XYZ).  I have tried several, both official API and non-official apps for testing purposes, all updated or newly installed.


Saturday afternoon it was working fine, and I have not changed anything on the device or with the account. 


Same problems occur with a different (basic) account.  Geocaching.com can be accessed without problem from the mobile browser and the internet connection is otherwise working fine.  I unfortunately cannot try the official Groundspeak app, since the device OS is too old and updates are no longer supported, and I do not have access to another Android device to check.


What is causing this problem and what can I do to fix it?

Link to comment

I had login issues for a while yesterday.  Geocaching4Locus didn't work, nor did the second half of the logoff/login mantra.


I wish the API had better uptime.  (Even though I mostly cache offline via PQs, there are times when a quick update is useful. If it works.)


Edited by Viajero Perdido
Link to comment

GDAK is (still) not working for me:




Website still working fine:




I usually use a GPS device and pocket queries anyway, but an Android app is useful for logging on the go, or to be able to see spoiler photos and images and read the most recent logs.  This might just be a case of the device finally being too old to be useful, unfortunately.  If that is the case, I will buy a new one.  But I want to make sure the new device will actually work beforehand!


Edited by miaux
Link to comment

Good question.  I was in a city park and spontaneously searched for and found a few caches as usual, and saved drafts of logs.  A few hours later in the train, wanted to log them and could not connect.  Figured it was a temporary problem and tried the next day (and the next and the next), but it has not worked since.  Did something at Groundspeak change between afternoon and evening (UTC+2 time zone)?


Just tried with another Android device and got the same problem, however the device is the same model and age as the original, so not a very useful test case.


Glad (?) to know I am not the only one with this problem, will keep an eye on the GAPP forum too.


Link to comment

I have a similar problem with the Locus App. Whenever I try to do something which needs API access (like loading or updating geocaches), I get an unspecified error message about missing network connection. Since the network connection works fine for everything else on the phone, this is somehow connected to the API access. I tried locus forum, but got no answer so far.

Link to comment

Been watching this and the other threads mentioned above.  In the meantime, I can no longer use geocaching.com from the device either.  Seems to be related to TLS 1.2, which means that all Android devices with versions lower than 4.1 can no longer be used.  What a bummer. :(

Link to comment
On ‎7‎/‎2‎/‎2018 at 5:25 PM, on4bam said:

Just tested with GDAK (Android). No problem refreshing caches using the API.



That may apply to certain phones.  For this discussion, it would be good to post the device and droid version, whether or not it works.


I tried a few things with my Acer A500, Android version 4.0.3. 

Firefox can't connect to Geocaching.com. 

Cache Sense opens to its menu, and even "downloads" caches.  It showed a little counter and "downloaded" about 50 caches.  That is, the counter counted.  Several times, a  "Crash Data" window popped up, asking if I wanted to report it.  No actual caches appeared.  The map is an empty blue space with a pointer in the center.

I installed GDAK.  It opened to a weird cache page screen.  I tried to "authenticate" (user name and password), and that failed, it can't connect.


There may be an older App that allows uploading Pocket Query file or a GPX file that was generated on a PC, uploading the file via USB.  That would provide a database, maybe even a map.  But it would function only offline.  I had something similar with a Palm PDA, but no map overlays.


Here is what GDAK showed me when I first started it:




Edited by kunarion
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 3
  • Create New...