Jump to content

Really need help-Colorado300

Recommended Posts

:unsure: When going to a waypoint or a geocache the gpsr works fine in the truck. When I stop and get out the screen freezes up, north pointer, direction to cache, compass, everything. If I stand there for 2-4 m, inutes it will finally sort itself out and everything works fine. I have done resets, have 2.9 software, tried compass on and off, calibrated compass and altimeter. I am in geocache profile and have lock on road turned off. this is my third unit, one new, one refurb, and one new all with the same problem. I have talked and talked to Garmin and while they are polite and try to help they don't have a clue.


Anyone have any ideas? I'm desperate


Link to comment

I like to try things; the point is, is it the voltage switch, or usb pole short?


Kill the motor and take the key out, is the gps still working ok?


With the key in, take the lighterplug out, keep the usb in the gps, gps still working ok ?


Pull the Usb STRAIGHT out the Gps, gps ok?


Power down the gps disconnect power on.

Link to comment

I have the same problem with mine. I have the latest software. I think one version of the software did make it better, but it isn't fixed. If I am in a situation I need it faster, I will just power cycle it and it seems to work. But definitely not the way it should be.

Link to comment

Thanks Red90,

I have 2.9 installed and I have done a hard reset with no improvement


No, not 2.9, that is the unit firmware. I'm talking about the GPS firmware. It is different.


Do this:

To determine your current installed Software and GPS Software Versions go to Setup>System>Options>Software Version. You should see a screen that looks like the image below which will display both your Software and GPS Software version number.


Edited by Red90
Link to comment

There aren't too many people out there using a 300 with just the basemap -- have you tried with maps? I wonder if it has something do with that? Seems unlikely to me. BTW, your other settings look fine.


Does the issue manifest itself with every cache/waypoint you navigate to?


Does it only happen when you navigate in your car and transition to walking?


Do you change profiles when exiting the car or are you in Geocaching profile the entire time?

Link to comment

I have a Colorado 300 bought in early feb 2008. Never had to send it in for anything.


I use the Ibycus USA maps on it but have never seen what you are describing. I usually just leave it Geocaching profile. Seems unlikely you would see the same issue on 3 different units. Walk us through how you load caches and go about caching - maybe somebody will spot something.

Link to comment

First of all I want to thank everyone for their help. This happen with geocaches, waypoints or just traveling in map mode and happens every time I transition from car to walking.

Now for the good news. We went out caching this morning and I became increasingly frustrated by the way my unit was acting so called Garmin for the 3rd time in two days. As usual the rep was courteous and after listening to my problems talked to his supervisor. The supervisor said that they are aware of this problem and while it is not very common their engineers are looking for a fix. They are trying to bring in units with this problem to work with so they are taking mine back and will be giving me a new Oregon 300 so at this moment I'm a happy camper.

Once again thanks to everyone for the help, I sure appreciate it.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...