Jump to content

Are There Any Problems With My New 60cs?


primwolf
Followers 0

Recommended Posts

I’m a newbie of gps, and got garmin gpsmap 60cs yesterday, but I found many problems. For example, I turn on the gps then change to map page, the screen shows “drawing” and stopped, not shut down (happened about 3 times). No button press or release is valid except turn it off. Also, when I doing some operation, the screen shows “load loading” and stopped. So I had to turn it off again (happened for two times). At last, it stopped at random (especially when drawing); the only way is turn it off…

Anyone met the same problems with me? Or I did invalid operation? My software version is 3.80.

Link to comment

You should have read the manual and did a complete prefernce set-up inside out of Sat range before initializing for the 1st time (like WAAS, battery type, battery mode, units of measure, date and time, etc.). The 1st initialization should have been letting the unit sit outside in a clear area for about 30 minutes for a full almanac load. The GPS has to learn where it is located.

 

Never-the -less ..... When you turn it on you should wait until the Sats get a lock (wait for the 3-D logo is what I do) before you go paging around. This can take 2 - 10 minutes depending on area and Sat reception. This is not an instant on device. You have a really powerful device with lots of bells and whistles. Let it initialize and see if the problems you indicated still occur. We will be glad to help you with any problems. :laughing: ImpalaBob

 

http://forums.Groundspeak.com/GC/index.php...ic=72160&st=850

ia a good link to look through

Edited by ImpalaBob
Link to comment

Your maps should draw very quickly. Doesn't sound normal. As Impala Bob said, let it initialize. Bring it to a spot with a clear view of the sky (a local ballfield is often a good spot), turn it on and let it sit about 5-10 minutes.

 

If you are still encountering the problem you may have a defective unit. Take it back and exchange it.

Link to comment

Never-the -less ..... When you turn it on you should wait until the Sats get a lock (wait for the 3-D logo is what I do) before you go paging around.  This can take 2 - 10 minutes depending on area and Sat reception.  This is not an instant on device.

You allways wait untill it gets lock ?

I never wait and never had a problem and shouldn't be any.

 

I think it is defective unit.

Edited by vr12
Link to comment

I believe that most new units out of the box last had a satellite lock at Garmin's QC lab somewhere in Taiwan or Korea or something like that. When fired up for the first time it thinks it is still there so it has to determine its location somehow in order to figure out what sats to look for. The 60 gives you a choice of letting it do that automatically or by you pointing out on the map where you are approximately. I would bet that manually is a lot faster then the automatic.

 

Olar

Link to comment

Regardless of whether or not the GPSr is initialized properly, the screen shouldn't freeze during map drawing. It sounds like a problem to me.

 

Try doing a Master Reset of the unit. Press and continue to hold down the [ENTER] and [PAGE] buttons while turning the unit on.

 

If you continue to have problems after doing a Master Reset, I'd take it back and exchange it for another one.

Link to comment

Never-the -less ..... When you turn it on you should wait until the Sats get a lock (wait for the 3-D logo is what I do) before you go paging around.  This can take 2 - 10 minutes depending on area and Sat reception.  This is not an instant on device.

You allways wait untill it gets lock ?

I never wait and never had a problem and shouldn't be any.

 

I think it is defective unit.

I agree ... but how can it draw a map until it knows where it is at. I was only refering to the initial initialization of the unit ...i.e. New Location.

 

In order to determine if his unit is defective .... we need to start setup over again.

 

Please let us know how you are making out!

 

:lol: ImpalaBob

Link to comment

Never-the -less ..... When you turn it on you should wait until the Sats get a lock (wait for the 3-D logo is what I do) before you go paging around.  This can take 2 - 10 minutes depending on area and Sat reception.  This is not an instant on device.

You allways wait untill it gets lock ?

I never wait and never had a problem and shouldn't be any.

 

I think it is defective unit.

I agree ... but how can it draw a map until it knows where it is at. I was only refering to the initial initialization of the unit ...i.e. New Location.

It uses last known location.

In case of first turn on it is Garmin office :lol:

 

I got impression that you turn unit on and then wait for the lock before doing anything.

Link to comment

As neo-geo said .... before sending it back I think he should update his firmware to the latest version 3.9, do a full system reset, set it up inside to use WAAS, etc., and then re-initialize outside in a clear area for 20 to 30 minutes. If he has ANY issue after that he definitly has a reason to go through the hassle of shipping the unit back or returning it to place of purchase for a new unit. It would be great if he posted his whereabouts so someone could hook up with him and give him a hand. I'll help any geocacher if I can. :ph34r: ImpalaBob S.E.PA

Edited by ImpalaBob
Link to comment

Thank you all for your warmly help. I have done all the steps you suggested except upload to firmware 3.90 (I'm not sure if I update the firmware, the warranty is still valid and seller are willing to replace a new one). Now I can see about 6-7 stars on gps and 3D mark on screen. But the problems are still exist: automatically power off, drawing and freezes, showing "loader loading" and freezes. Every time I switched to "map page", the above problems appeared. I have send mail to Garmin and now waiting. Any good way to make process faster? Call them directly (I'm a foreign visitor to U.S, my English is not as good as can talking with U.S citizen fluently :D )? Thank you for all of your suggestion and help. I'll let you know the result :o .

Link to comment
As neo-geo said .... before sending it back I think he should update his firmware to the latest version 3.9, do a full system reset, set it up inside to use WAAS, etc., and then re-initialize outside in a clear area for 20 to 30 minutes.  If he has ANY issue after that he definitly has a reason to go through the hassle of shipping the unit back or returning it to place of purchase for a new unit.  It would be great if he posted his whereabouts so someone could hook up with him and give him a hand.  I'll help any geocacher if I can.  :D ImpalaBob S.E.PA

Impala (and everyone): I wonder if the order of things should be changed a bit? If Primwolf first upgraded the firmware, then did a hard reset, would the firmware upgrade still be there, or would the GPSr revert to the original factory setup (i.e., the older firmware version)? I'm thinking that perhaps he/she should 1st do the hard reset, then do the firmware upgrade.

 

By the way, Primwolf....what country are you from? Your English is good here.

Edited by jacques0
Link to comment

Sounds likely that the unit is definitly defective. If you bought by credit card, and have not registered the unit with Garmin you should contact the credit card company and let them know the seller sent you a defective unit and ask to have it replaced by the seller. If you registered it with Garmin you have to deal with them. :P ImpalaBob

Link to comment

Hi, all. I have got a new one to replace the defective one from seller. Now it seems good. I never meet the same problem again. During the process of replacement, I contacted Garmin supports, they responsed very quickly. Also, the seller is willing to replace a new one and say sorry to me. Thank you for all of your help :ph34r: .

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 0
×
×
  • Create New...