Jump to content
Sign in to follow this  
Followers 3
jimlarkey

Garmin MapInstall v4.2.0 cripples 3rd-party maps?

Recommended Posts

Anyone else have a problem with the latest version of Garmin's MapInstall, crippling and corrupting the compiled img file on the target device (uSD card)?

 

I installed some OSM topo routable maps, and deleted some existing 3rd party maps from GPSFileDepot in the process.  Tried to reinstall the 3rd-party GPSFileDepot maps with Mapinstall, and the compiled maps lacked detail, and were very crude....no topo line, missing highways, crude shaped reservoirs, etc.  The compiling time was very short, and the resulting map img files seemed about a 1/3 size of what they were. 

 

3rd party maps were:

  • cotopo11
  • My Trails (layer)
  • us_p_nw (planimetric NW) 

Even Garmin's (legacy) TOPO US 2008 and Metroguide v8 were crippled and lacked/missing detail.

 

Solution: used compiler/installer in last version of Mapsource, v6.16.2.  All the maps above installed including the OSMs, as separate compiled img files....and they all have the full detail levels.

 

Thanks be to Mapsource again, but I wonder if Garmin changed the code in the MapInstall proggie to cripple the detail level of the compiled img file of the target 3rd-party maps?  Has this been discussed previously?  Anyone else encounter this?

 

On my end I'm running the latest version of Win 10 (10.0.17763), installing on a Garmin OR-700 SW v4.40, using latest Mapinstall v4.2.0, last Mapsource v6.16.2

  • Helpful 1

Share this post


Link to post

Garmin disabled the transfer of register based maps in the latest version of MapInstall. This also includes their own older maps.

 

Other solutions are:

1. Download and install the .gmap versions most OSM providers offer.

2. Download the direct-to-mSD .img files most OSM providers offer. Rename them and copy them to your device.

3. Go back to v4.6.2 of BaseCamp.

Share this post


Link to post

Thanks StefandD.  I heard reports that Garmin disabled, didn't know that they crippled.

Yep, have no problem with OSMs, but it's the 3rd party maps on GPSFileDepot. Can find cotopo11 under Colorado.

 

I did roll back to v4.6.2, and I did rollback Mapinstall to 4.0.4....image of compiled map comparison below.

Compiled file sizes tell the story:

  • cotopo11_Mapinstall 185 MB (194,883,584 bytes)
  • cotopo11_Mapsource 784 KB (802,816 bytes)

Thanks again, and all praise be to Mapsource.

Compare.jpg

Share this post


Link to post

I knew there was a reason I hadn't updated to the latest version yet.

Share this post


Link to post

You can simply install the older version of Mapinstall, if you really like using it.  I've always used Mapsource.

Share this post


Link to post

Yeah, Mapsource is the way to go.

The above poor-detail image was installed with a rolled-back version of Mapinstall: v4.0.4 (4.2.0 is current), as well as rolled back version of Basecamp: 4.6.2 (4.7 is current)

 

The problem is which if any of the versions below did Garmin change their policy of crippling the detail?

MapInstall 395.exe

MapInstall 400.exe

MapInstall 401.exe

MapInstall 403.exe

MapInstall 404.exe (not)

MapInstall 420.exe (not)

MapInstall 3101.exe

MapInstall 3102.exe

MapInstall 3103.exe

MapInstall 3111.exe

MapInstall 3114.exe

MapInstall 3115.exe

MapInstall 3116.exe

MapInstall 3121.exe

MapInstall 3132.exe

MapInstall 3135.exe

MapInstall 3142.exe

MapInstall 3144.exe

MapInstall 3150.exe

Share this post


Link to post

Only the latest version.  If you had a problem with the older version, you have some other issue.

Share this post


Link to post

 

1 hour ago, Red90 said:

Only the latest version.  If you had a problem with the older version, you have some other issue.

 

See orig post:

" On my end I'm running the latest version of Win 10 (10.0.17763), installing on a Garmin OR-700 SW v4.40, using latest Mapinstall v4.2.0, last Mapsource v6.16.2"

Problems.

Share this post


Link to post
2 hours ago, jimlarkey said:

Yeah, Mapsource is the way to go.

The above poor-detail image was installed with a rolled-back version of Mapinstall: v4.0.4 (4.2.0 is current), as well as rolled back version of Basecamp: 4.6.2 (4.7 is current)

 

You stated that you rolled back to 4.0.4 and still had the issue.  The issue is ONLY with 4.2.0.  If you still have the issue after changing back, there is another problem or you did not successfully roll back.

Share this post


Link to post
Posted (edited)
32 minutes ago, Red90 said:

 

You stated that you rolled back to 4.0.4 and still had the issue.  The issue is ONLY with 4.2.0.  If you still have the issue after changing back, there is another problem or you did not successfully roll back.

 

Also, it was indicated in the post below that MapInstall 4.0.4 had the same issue as MapInstall 4.2.0 (which confused me as well):

 

3 hours ago, jimlarkey said:

Yeah, Mapsource is the way to go.

The above poor-detail image was installed with a rolled-back version of Mapinstall: v4.0.4 (4.2.0 is current), as well as rolled back version of Basecamp: 4.6.2 (4.7 is current)

 

The problem is which if any of the versions below did Garmin change their policy of crippling the detail?

 

MapInstall 395.exe

MapInstall 400.exe

MapInstall 401.exe

MapInstall 403.exe

MapInstall 404.exe (not)

MapInstall 420.exe (not)

MapInstall 3101.exe

MapInstall 3102.exe

MapInstall 3103.exe

MapInstall 3111.exe

MapInstall 3114.exe

MapInstall 3115.exe

MapInstall 3116.exe

MapInstall 3121.exe

MapInstall 3132.exe

MapInstall 3135.exe

MapInstall 3142.exe

MapInstall 3144.exe

MapInstall 3150.exe

 

Edited by Atlas Cached

Share this post


Link to post

Yes, had the problem with Mapinstaller 4.2 (latest), rolled back to 4.0.4 same problem.  At some point Garmin changed their policy on supporting 3rd-party maps.  I don't know what version of Mapinstall that occurred. Not gonna spend the time rolling back again and again until I find it.

No problem with OSMs....only GPSFileDepot maps.

 

Mapsource install works on GPSFileDepot.

 

Share this post


Link to post
5 hours ago, jimlarkey said:

Yes, had the problem with Mapinstaller 4.2 (latest), rolled back to 4.0.4 same problem.  At some point Garmin changed their policy on supporting 3rd-party maps.  I don't know what version of Mapinstall that occurred. Not gonna spend the time rolling back again and again until I find it.

No problem with OSMs....only GPSFileDepot maps.

 

Mapsource install works on GPSFileDepot.

 

 

We have explained...a few times....  The loss of 3rd party maps is ONLY IN VERSION 4.2  You have either not properly changed back to the older version or you have another issue.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 3

×
×
  • Create New...