Jump to content

Error Parsing File


msoregon91
Followers 1

Recommended Posts

Starting on 2/16, I've had problems with a pocket query syncing to GeoHunter on my phone (Android smartphone).

 

After I unzip the file using Androzip and then try to sync it in GeoHunter, I get the following message...

 

"Error parsing file 'File 8222559_Travelers.gpx PI must not start with xml (position: unknown @1:5 in java.io.InputStreamReader@45b7dcd0)'.

 

The PQ has not been changed in any way (by me) since the last time it ran. This morning, I tried building upon another existing PQ, and it also returned the same error message.

 

Does anyone have any ideas what's causing this, & how to fix it?

 

Thanks much!

Link to comment

Starting on 2/16, I've had problems with a pocket query syncing to GeoHunter on my phone (Android smartphone).

 

After I unzip the file using Androzip and then try to sync it in GeoHunter, I get the following message...

 

"Error parsing file 'File 8222559_Travelers.gpx PI must not start with xml (position: unknown @1:5 in java.io.InputStreamReader@45b7dcd0)'.

 

The PQ has not been changed in any way (by me) since the last time it ran. This morning, I tried building upon another existing PQ, and it also returned the same error message.

 

Does anyone have any ideas what's causing this, & how to fix it?

 

Thanks much!

I'm not sure, but it could be related to this. The cache GPX file now contains an additional character at the start of the file.

Link to comment

With the recent gpx files received, I've not been able to get them to sync into GeoHunter on my Android phone. This started with the file I received on 2/16/12. Older files are working but of course, they're getting out of date.

 

What steps will reproduce the problem?

1.Open new gpx file with AndroZip

2.Sync /sdcard/download in GeoHunter

3.

 

What is the expected output? What do you see instead? I expect the files to sync/update, but with the newest gpx files sent from geocaching.com this week, I get the following message...

"Error parsing file 'File 8222559_Travelers.gpx PI must not start with xml (position: unknown @1:5 in java.io.InputStreamReader@45b7dcd0)'.

 

What version of the product are you using? On what operating system? GeoHunter 1.9, AndroZip 2.1, on Android OptimusV 2.2.1

 

Please provide any additional information below. On Geocaching.com forum, it was suggested that the problem might be due to an extra character that's now at the front of the files, but that doesn't help me fix the problem....

Link to comment

With the recent gpx files received, I've not been able to get them to sync into GeoHunter on my Android phone. This started with the file I received on 2/16/12. Older files are working but of course, they're getting out of date.

 

What steps will reproduce the problem?

1.Open new gpx file with AndroZip

2.Sync /sdcard/download in GeoHunter

3.

 

What is the expected output? What do you see instead? I expect the files to sync/update, but with the newest gpx files sent from geocaching.com this week, I get the following message...

"Error parsing file 'File 8222559_Travelers.gpx PI must not start with xml (position: unknown @1:5 in java.io.InputStreamReader@45b7dcd0)'.

 

What version of the product are you using? On what operating system? GeoHunter 1.9, AndroZip 2.1, on Android OptimusV 2.2.1

 

Please provide any additional information below. On Geocaching.com forum, it was suggested that the problem might be due to an extra character that's now at the front of the files, but that doesn't help me fix the problem....

As of the last update of the geocaching Web site, Groundspeak is apparently now adding BOM (byte-order-mark) characters at the beginning of their GPX files, and it's causing lots of software to choke on the files. There's a discussion of the issue on the GSAK forums. The change was made to accommodate Unicode characters, or so I've read.

 

Clyde (the genius behind GSAK) has just made available a stand-alone utility program that will strip those characters from the beginning of a file. Click here for more information.

 

Alternatively, you can open the GPX file in a text editor and delete the first three characters in the file. That has apparently solved the problem for some users.

 

--Larry

Edited by larryc43230
Link to comment

As of the last update of the geocaching Web site, Groundspeak is apparently now adding BOM (byte-order-mark) characters at the beginning of their GPX files, and it's causing lots of software to choke on the files. There's a discussion of the issue on the GSAK forums. The change was made to accommodate Unicode characters, or so I've read.

 

Clyde (the genius behind GSAK) has just made available a stand-alone utility program that will strip those characters from the beginning of a file. Click here for more information.

 

Alternatively, you can open the GPX file in a text editor and delete the first three characters in the file. That has apparently solved the problem for some users.

 

--Larry

 

Thank you Larry & Clyde. That does work, but this is a cumbersome solution to have to


  1.  
  2. unzip the PQ
  3. run the strip program
  4. rezip the files
  5. email the files back to myself

 

All so that I can use the PQ on my phone.

 

In a pinch, it'll work, but it certainly won't allow me to update in the field. I'm going to have to do all this work on the home PC before I can head out caching :(

 

A resolution to the new gpx files is needed. GeoHunter isn't supported any longer so I guess I'll be looking for another app to use. Suggestions are welcome (but GeoBeagle isn't an option as it's having the same problems with the new files). I really don't want to pay +$9 for Geocaching's app...as a premium user, I balk at having to pay even more to use their software...

Link to comment

I’m still having the problem.

It was stated by larryc43230

“Alternatively, you can open the GPX file in a text editor and delete the first three characters in the file. That has apparently solved the problem for some users.”

 

This is what mine says.

<?xml version="1.0" encoding="utf-8"?>

 

So get rid of ?

“<?x”

Or get rid of?

“xml”

 

Thank you all for your help.

John

Link to comment

I'm still having the problem.

It was stated by larryc43230

"Alternatively, you can open the GPX file in a text editor and delete the first three characters in the file. That has apparently solved the problem for some users."

 

This is what mine says.

<?xml version="1.0" encoding="utf-8"?>

 

So get rid of ?

"<?x"

Or get rid of?

"xml"

 

Thank you all for your help.

John

As I believe you've found out, as of the latest site update there's no need to remove any characters at the beginning of pocket query GPX files. In fact, if you do, I don't think any program will be able to read the file.

 

--Larry

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 1
×
×
  • Create New...