Jump to content

COMPLETED (32004) - [BUG] Small TB Image only General TB image after 11/08/2011 update


Dr.MORO
Followers 3

Recommended Posts

Domo!!! (= Howdy in Japanese)

 

Seems like the 'Feedback' site is gone now, and the Forum has been 'resurrected' after all. Whatever...

 

Anyways, first jump to My Profile page here (Dr.MORO), and go way down past all the Stats, and to the banner section.

You should see right under the weather widget, two Travel Bug boxed images, that if clicked will take you the the TB's page.

The Image here is generated by the Groudspeak server, and I just paste a HTML code inside my profile page, as shown here in the "Knowledge Books" since a long time ago, and usually used for conveniently display several TB at once, like in a TB race.

 

The strange thing is, these Small images used to display the 'default' picture of the TB within, just as in the "Knowledge Books" page.

Since the update today, the picture within this Image, has been replaced by a 'general' TB image.

Very weird...

 

Something has broke during today's update, obviously.

 

Please fix this!

Link to comment

For your information:

http://forums.Groundspeak.com/GC/index.php?showtopic=285002&view=findpost&p=4889390

 

I use the TB banners on my profile page. It seems the TB images with a width of 600 pixels are replaced by the TB logo.

Example: http://www.geocachin...6b-c5c7a7b9b975 should contain the image: http://img.geocachin...c71d94238b4.jpg but it doesn't. This banner http://img.geocachin...32-c92628314772 does contain the photo of the coin.

Link to comment

For your information:

http://forums.Groundspeak.com/GC/index.php?showtopic=285002&view=findpost&p=4889390

 

I use the TB banners on my profile page. It seems the TB images with a width of 600 pixels are replaced by the TB logo.

Example: http://www.geocachin...6b-c5c7a7b9b975 should contain the image: http://img.geocachin...c71d94238b4.jpg but it doesn't. This banner http://img.geocachin...32-c92628314772 does contain the photo of the coin.

 

So how does this get fixed? Is it something GS can/will fix? Or do we have to fix our own--if so, HOW?

Link to comment

Is it something GS can/will fix?

 

Can? Yes!

 

Will? If the way Groundspeak inc. has "fixed" the width of my cache pages, the margin of the images and tables on those pages. The significant walk attribute (that was changed to 1-10 km, on my 20+ km cache route) The size of the labels on the trackable maps is any sign. The images on the TB images are likely the Feature-U-Cannot-Keep of this update.

 

Tc

Link to comment

Could this be the final phase of correcting this bug?

Server Error in '/stats' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

Parser Error Message: Could not load file or assembly 'Tucson.WebApp.ImageHandler' or one of its dependencies. The system cannot find the file specified.

Source Error: 


Line 32:     <compilation debug="true" targetFramework="4.0" />
Line 33:     <httpHandlers>
Line 34:       <add verb="*" path="*" type="Tucson.WebApp.ImageHandler.ImageHandler, Tucson.WebApp.ImageHandler" />
Line 35:     </httpHandlers>
Line 36:     <pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID" />

Source File: C:\inetpub\LiveImageHandlerGC\web.config    Line: 34 

Assembly Load Trace: The following information can be helpful to determine why the assembly 'Tucson.WebApp.ImageHandler' could not be loaded.


WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1

Link to comment

For your information:

http://forums.Groundspeak.com/GC/index.php?showtopic=285002&view=findpost&p=4889390

 

I use the TB banners on my profile page. It seems the TB images with a width of 600 pixels are replaced by the TB logo.Example: http://www.geocachin...6b-c5c7a7b9b975 should contain the image: http://img.geocachin...c71d94238b4.jpg but it doesn't. This banner http://img.geocachin...32-c92628314772 does contain the photo of the coin.

If I reduce the pixles in my image, will that work?

Edit: This can't be true. I have one that is 312x160 that doesn't work. I even changed the picture for one and that didn't fix it. It must be related to the actual bug page id number or somehting.

Edited by Andronicus
Link to comment

For your information:

http://forums.Groundspeak.com/GC/index.php?showtopic=285002&view=findpost&p=4889390

 

I use the TB banners on my profile page. It seems the TB images with a width of 600 pixels are replaced by the TB logo.Example: http://www.geocachin...6b-c5c7a7b9b975 should contain the image: http://img.geocachin...c71d94238b4.jpg but it doesn't. This banner http://img.geocachin...32-c92628314772 does contain the photo of the coin.

If I reduce the pixles in my image, will that work?

Edit: This can't be true. I have one that is 312x160 that doesn't work. I even changed the picture for one and that didn't fix it. It must be related to the actual bug page id number or somehting.

 

Yeah, this doesn't seem to be related to size at all. The 9 of mine that are still working have bytes ranging from 16373 to 31150 and pixels ranging from 56x128 to 300x299.

A sampling of 9 of mine that are not working have pixels ranging from 7457 to 53996 and pixels ranging from 105x66 to 300x200.

Link to comment

Yeah, this doesn't seem to be related to size at all.

Aspect ratio?

This one with aspect ratio 2:3 doesn't work: http://img.geocaching.com/track/5ec68553-39c1-4db6-8333-4536a4ee6879.jpg

This one (bigger!) with aspect ratio 1:1,3 does work: http://img.geocaching.com/track/ab522990-0df4-4fa1-a1c8-5f1a00b1e112.jpg

 

Hoping Groundpeak Inc. does now have enough information to fix this bug.

 

Tc

Link to comment

The issue is not due to any particular size or aspect ratio in the images, but instead due to changes in our image handler and saving of images. The thumbnail image that the TB badge uses is no longer being created by the new image handler, so more recent TB images do not have the needed image size available and thus do not display on the badge. Our developers have made some changes to correct this and those changes are in testing right now. We are going to try for a hotfix after testing is complete, but it might have to wait until the next full site release in mid-January.

Link to comment

How do I determine aspect ratio?

Divide the hight of the image by the width of it.

 

so more recent TB images do not have the needed image size available and thus do not display on the badge.

 

At my profile http://www.geocaching.com/profile/?guid=e5f367d0-e705-44b0-926b-c5c7a7b9b975 , there is no indication that more recent images show the logo, older once the image. In this limited subset. Apect ratio (1:1.3 or squarer: Image, rectangular: Logo) is the factor that determines whether or not the image is shown.

 

Our developers have made some changes to correct this and those changes are in testing right now.

I experienced some (AR=1:1.3) to be shown, others (AR=1:1.5) not. Are you really serious your developers are testing on the live server? My boss would fire me for that!

 

Tc

Link to comment

Domo!!!

 

 

Bug Fixes:

 

• Fixed bug in Trackable stats panel which caused a generic TB icon to be displayed in place of the Trackable's default image. Domo!

 

 

Reloaded the webpage several times, and FINALLY!

All fixed!

 

Great Job, Lackeys!

 

And thanks for the quoting, Moun10Bike!

Honored!

 

~ Dr.MORO

Link to comment

Fantastic! (Almost) 23 of my 29 are fixed; what do I need to do to the other 6?

 

In addition to the images on my Profile page, all 6 of the unfixed ones have links to the other five on their pages, and in the links all are still just the general image although the default image is shown correctly.

 

http://www.geocaching.com/track/details.aspx?guid=4617ac62-2d64-4a41-a04b-8bd5dbd206f7

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 3
×
×
  • Create New...