Jump to content

GSAK POI Loader error messages


Recommended Posts

Equipment: Garmin Nuvi205 and Desktop PC

SW loaded is GSAK and POI Loader


After creating a Pocket Query and opening GSAK I see the caches as expected.

I then use a macro found on the site to set up data for my Nuvi.

When the macro is complete, POI Loader is opened automatically (as expected) but as I step through the scripts i get error messages:

The file C:\Program Files\gsak/locations/country.csv is invalid.

I get the same message for ctyabr.cvs, etc...


Any ideas on what might be wrong.


I have ensured that my location is properly set on GSAK and in my geocache.com profile as well as my garmin.


Thanks for the help[

Link to comment


The file C:\Program Files\gsak/locations/country.csv is invalid.

Notice the difference^

C:\Program Files\gsak\locations\country.csv

All slashes should be back slashes.


I am getting the same error message as 24Play. I have tried uninstalling GSAK and the macro thinking I had a program issue, but I still get this error.

BTW, I'm using windows 7 with 64bit. Trying to send to my Nuvi 255W.

Link to comment

Can you provide a link to the macro? Is that the jjred advanced macro?


I noticed that even though some apps report folder path with forward slash, it actually uses the correct backward slash. That could be the problem, but don't be surprised if it is not.


On Windows 64 bit, GSAK (and country.csv) is located under "Program Files (x86)" and not "Program Files". I'm not sure if that's significant, since I don't use the jjred macro. If this is the case, two ways around it : track down where the path is and change it, or create a folder "c:\program files\gsak\locations" and copy the file country.csv into it.

Edited by Chrysalides
Link to comment
Did anyone ever figure this out? I'm using the old Pilotsnipes macro to send to my 255W. It works fine on my desktop with XP, but I can't get it to work on my netbook with Win 7. I tried installing jjred's macro too, with no success.

It is almost always related to the path when this happens.


The macro writes the GPX to a location, but POI Loader is looking for it in a different location.


If you know your way around the computer, check that first. Where GSAK writes to is in the dialog box that pops up when you run the macro. Make sure it is really writing there. Feel free to PM me if you'd like some help.

Link to comment

I get the same error message when running a GSAK macro that loads POI using the Garmin POI Loader.


My work around has been to run the macro, then do not run the POI loader. Close POI Loader.

Run the macro again and then run the POI Loader.


Don't know why, but works for me every time on the second attempt.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...