Jump to content

Ifinder Go2 Undocumented Feature

Followers 8

Recommended Posts

Found on another forum...

The iFinder GO/2 will accept the WPL NMEA sentence. With that sentence you can give it Lat, Lon and a waypoint name. The WPL sentence looks like this:






Latitude = 41-47.078 N

Longitude = 112-01.768 W

Name = NAME (any name can be used like GC9JOY)


The 5D after the asterisk is the checksum and must be calculated correctly.

No idea from the original post in Yahoo's iFinder group if this user tried sending RTE sentences also.


It's a bummer that the serial cable isn't included, it's an extra cost item - and getting the right part number info from Lowrance is like pulling teeth. With proper bundling and documentation, this would really increase the value of the Go/Go2 packages.


Maybe they don't want to cannibalize higher-end model's sales.

Edited by lee_rimar
Link to comment
...does the ifindergo have the proper hookups for the cable? ...

Yes, there is a cable available, but direct from Lowrance it's $40. GPSCity has it for $30, but it still seems a costly accessory for a <$100 GPS. I believe this is the correct item - but check with the vendor first (and don't blame me if it's wrong):



Edited by lee_rimar
Link to comment

Well that would be AWESOME if the little iFinder GO/GO2 were able to receive waypoint uploads, this would be a feature that Lowrance doesn't "officially recognize" but if someone were to figure out a way to do it, that'd be great!


But, "a friend of a buddy heard a rumor from a neigbor that this is possible",, I've been hearing that sort of thing a LOT :) If someone/anyone were able to actually DO IT then please post here! lol The same holds true for the mythical "data transfer is possible to an Explorist 100-200-300" rumour.


About the cable,,I'm not surprised at all that a $68 entry level GPSr doesn't automatically come with one. That would be a waste, because probably 90% of people who buy such an entry level unit would chuck a cable like that into their junk drawer & never use it. but on the other hand it's sad how much the cable cost to buy.


I'm going to remain the doubting Thomas on this data-feed-to-a-GO issue until someone can physically verify such a thing is possible. Personally I feel the little iFinder GO is an amazing bargain for $68 even if it doesn't accept a data feed :)

Link to comment

Hi There!


Yes the ifinder go2 is capable to receive waypoints from nmea sentance, you can create a route via map source,then save it in gpx format and then open gpsutility(freeware) and upload it to the ifinder go2 all the waypoints will appear to the unit but you will still have to remake the trail between the uploaded waypoints,allsow you will have to take out the (*) that appears before eatch waypoint before loading it to the gps.


You can build a cable for it with cheap parts here is the pinout, http://www.gpsnuts.com/Lowrance/iFinder_comm.jpg


more detail http://www.stud.ntnu.no/~gronslet/blog/200...as-gps-pinouts/


This little unit is capable to drive any palm or pc laptop with nmea routing program to.


finaly it is performing quite good for a budget gps but dont count on lowrance to get the information on this, they simply say that they dont carry any software for it. ???


Sorry for my writing y am french canadian!

Edited by daytrek
Link to comment

Does anyone with one of these units have experience with the Garmin Etrex line?

Replacing the serial end of a $8 Garmin cable would be much more tempting.


Even if it's not the same connector, perhaps the same "homebrew" technique of pins through a credit card will work if they're mechanically similar.

Link to comment
ok, im going to try making one of these.  anyone have anyidea on how to make a good connection to the go2?  i don't really want to solder the wire connections to the device, but i guess i could if i had to.  i cant think of any other way of doing it though...any ideas?

Try some thing like this but get the right pinout from my previous post and dont consider

soldering to your ifinder go2 or you will probably end up melting the case around these contact!


here a link for credit card type connector: http://www.jens-seiler.de/etrex/datacable.html


and the program i use to transfer waypoint: http://www.gpsu.co.uk/

Edited by daytrek
Link to comment
ok, im going to try making one of these.  anyone have anyidea on how to make a good connection to the go2?  i don't really want to solder the wire connections to the device, but i guess i could if i had to.  i cant think of any other way of doing it though...any ideas?

Try some thing like this but get the right pinout from my previous post and dont consider

soldering to your ifinder go2 or you will probably end up melting the case around these contact!


here a link for credit card type connector: http://www.jens-seiler.de/etrex/datacable.html


and the program i use to transfer waypoint: http://www.gpsu.co.uk/

ahhh...i see :ph34r: glad i asked B) thanks, ill be trying that tomorrow!

Link to comment

Discovering the information in here I tried that with my own GO.

For a first checkout I just pressed the two connectors for GND and TX against the contacts.



File->Export->Custom Export

"F:\Program Files\GSAK\GPSBabel.exe" -N -i gpx -o nmea -f "F:\Program Files\GSAK\temp\babel.gpx" -F "F:\Program Files\GSAK\temp\ifgo.txt"



This loaded well into the GPSr by just pasting it into the Hyperterm.


The only future enhancement I ought to have is more than 6-chars waypoint names, this is the only thing GPSBabel sends.

The GO supports them and I love to have something like

%drop2 %typ1%dif1%ter1%con1%bug

which should in future result in something similar to


Link to comment

You should be able to send that output right to the serial port. You may have to set the serial parma with a 'mode' command first. Then use gpsbabel ... -F com3: (or whatever)


GPSBabel sends 6 chars max in the name in WPL sentences becuase I understand the NMEA specs says the max shall be 6. Are you sure your GO will receive > 6 characters there?


(Hint: the checksum is specified as optional, so just whack the trailing asterisk and two digits and edit away...)

Link to comment
(Hint: the checksum is specified as optional, so just whack the trailing asterisk and two digits and edit away...)

Spent a few seconds to build a professional credit card plug with sewing needles.


Observation #1: If you rip off the 3 checksum related bytes, your waypoint will not be honoured.


Observation #2: The waypoints are silently swallowed. And if you blow 5000 points at 9600 you will see 20 of them.


Tears of joy thinking of ancient times with Telix, KEA, etc. able to insert an arbitrary delay after each line sent. So I dont even expect them to accept 'incorrect' NMEA sentences with more than 6 waypoint bytes. We shall have to wait for an interface specification or a reverse engineer...

Edited by Eliveras
Link to comment

Given that Lowrance is denying these units have this feature, makes it difficult to actually get the cable, and has it priced at 50% of the cost of the GPS if you can find it, I'm not holding my breath for that "interface specification".


Your observations tell me they weren't really planning for this feature to be used.


Most implementations of NMEA don't allow waypoint writes at all. There isn't a handshake/acknowledge in pure NMEA. An 8 bit character at 9600bps takes 104.2 microseconds to transfer (there's a reason why I know these things, but it's not pertinent here...) some quick napkin scratching for typical WPL sentences shows they average around 35 bytes including the CR/NL. So if you're suggesting the unit simply can't digest the 27 (ish) of these per second that you can spray at it, there are two easy ways to throttle it in the absence of a "thank you, sir, may I have another" packet.


1) Run the bit rate down. At 4800bps, you can obviously send fewer a second, so that will give it more time to "digest" the data.


2) insert a delay after each line uploaded by your communication program. Yes, that precludes sending straight from an unmodified GPSBabel, but should be easy in your hyperterm example above.


If, OTOH, you're suggesting it really isn't a matter of the unit not being ablt to keep up and it just won't take more than 20 waypoints, well, now you know why they're $70 and this is an unsupported feature. :-)


In case it helps your studies, here are some precomputed checksum values:













Edited by robertlipe
Link to comment
Here's the right cable, for $29:

So for a mere 42% of the purchase price (ok, a pittance of 33% for the go2) you can get a cable to maybe use an unsupported feature?


You do make a good point, Lee_rimar, in that some of the problems reported above could be an artifact of safety pins stuck through a credit card. I won't mentally write this off until some brave soul has invested another $30 in one of these (or testified to his or her credit card/cable making prowess) and reported how well it does or doesn't work.


I've tried to offer debugging tips for the adventerous, but I'm wondering if this really is kind of a curiosity. Show me a $115 unit (go2 + cable) that supports base mapping _and_ data xfer and these units get more interesting.


Better yet, show me this is actually feasable to support and a truckload of users of these units willing to share the development costs, and I'll consider "real" support for them in GPSBabel.

Link to comment

I know you guys eagerly awaiting the outcome of my last experiments:



I cannot think of any feature the official cable should offer, which my professional homebrew one does not have, there is simply no spare signal for a hardware handshake. Both directions are working, this is something you can easily test by turning on per second NMEA output.

The only thing which I did not consider is that the box might be sending an unseen XOFF/XON, perhaps something worth looking at.

They might also have had something different in mind, some kind of proprietary NMEA handshake, e.g. doing a query after sending a sentence.

We would not be able to figure out this one.



This has been a partial success!

The unit is accepting NMEA records with more than 6 characters given that the checksum is supplied properly. I tried all the ones you supplied successfully.

The unit offers 20 characters for waypoint names (they seem to specifically target the German market because the only non-ASCII graphics available are the ones needed for the German language "ßÄÖÜ").


Bulk uploads dont work even at 1200 bps. I still have not found a terminal program with per line delay capability. Perhaps I shall have to be getting into some VC++ and WinSDK programming next weekend.

Link to comment

If it pretends to be NMEA, there won't be a handshake - hardware or inline to the data - as the standard just plain doesn't have one. Ther emay be a proprietary sentence (Magellan used $PMGN, HANDON) to enable such a thing.


If you want to go for broke confirming waypoint length:










That's interesting on the German stuff since NMEA explictly calls out ASCII which would preclude those characters. What character set it used to xfer those? UTF-8 or one of the 8859 brothers?


At 1200bps, though, these would be Really Leisurely. 120 cps with an average sentence size of 35 characters is about 4 waypoints a second. If the unit really can't accept 4 characters a second, there must be something else going on. If you try 100 one at a time, will it take all 100?


Various web sites such as http://www.link-comm.com/faq/hyperterm.txt sure seem to imply that hyperterm can do inter-line delays, but I really don't do Windows at that kind of level.


If you're going to whack at this with Visual C, do it in GPSBabel and solve it for the GPSBabel/GSAK user base. If you're comfortable with that kind of thing, I can probably talk you through the process. Followup to gpsbabel-code mailing list.


Is that a Snorlax, the pokemon that eats 900 pounds of thorns and sleeps more than a cat?



Father of a Ten Year Old.

Link to comment
So for a mere 42% of the purchase price (ok, a pittance of 33% for the go2) you can get a cable to maybe use an unsupported feature? 

No, you get the supported feature of feeding NMEA data to your computer, for use with other software. Any other capability is a bonus.


...show me this is actually feasable to support and a truckload of users of these units willing to share the development costs, and I'll consider "real" support for them in GPSBabel.

No offense meant here - because GPSBabel is a terrific toolset - but there are already GPS utilities that support sending data to units with the WPL statement. I don't think you're going to find a truckload of users willing to share development costs.


Show me a $115 unit (go2 + cable) that supports base mapping _and_  data xfer and these units get more interesting.

As an aside, have you seen what's happened to the street price of the iFinder H2O since they announced the color version? About $130, delivered.




Of course, you'd still need an SD card and reader. Or the mapping package. But THAT'S a bargain unit, far more so than the Go/Go2 series.

Edited by lee_rimar
Link to comment
Bulk uploads dont work even at 1200 bps. I still have not found a terminal program with per line delay capability.

Huh? I can't think of a terminal program that DOESN'T offer intercharacter & interline delays. How about the cheapest/free HyperTerminal that comes with Windows?


File menu

- Properties

-- Settings tab

--- ASCII Setup button

---- ASCII Sending panel


Lets you set Line delay and Character delay in milliseconds.


Try throttling back to 4800 bps, and give 500 or 1000 millisecond delay between lines.

Link to comment

Thank you both for getting me into the hidden depth of the Hyperterm.

I just transmitted my 585 ToDo caches!


I also found an OS partition where Gpsbabel compiles cleanly. No chance on Solaris or Win VC, but worked fine on Slackware.


Read a bit through the code, figured out where the NMEA sentences are printed. I am heading towards something like "-o nmea,nt" (no truncate, shall copy the full original wp name). Would you please give me a hint where the 6 chars truncation takes place?

Link to comment

Should work on Solaris. You'll probably have to use the 'usbfree' target, but it can't be far from working other than that. I don't know what a WinVC partition would be, so I won't guess there.


I just checked in a change to nmea.c that extends the waypoint output length in a way consistent with the other modules and adds smartname.


$ ./gpsbabel -s -i geo -f geocaching.loc -o nmea,snlen=20 -F -

$GPWPL,3558.322,N,08708.082,W,Montn Bk Hvn by 1313*68

$GPWPL,3605.441,N,08640.773,W,Trll by a182plt & Fm*53

$GPWPL,3559.776,N,08637.207,W,Div Bmbr by JGPS & f*4B

$GPWPL,3602.309,N,08638.917,W,FOSTR by JGPS & Fmly*0F

$GPWPL,3606.731,N,08644.506,W,Logn Lghths by JGps *41

Link to comment

WOWEEE!! You guys ROCK!!


Geez you actually physically really transmitted 100's of waypoints into a lowly iFinder GO!! Oh MAN that is soo awesome! Now we have a unit that:


-Cost as low as $69 GPSr + $29 cable That's UNDER $100 folks!

-Has builtin basemaps!

-Normal AA batteries last (seemingly) forever!

-Excellent deep woods reception with 16 channels + WAAS!


That has to make it the primo entry level GPSr. Thanks Lowrance! You brought out a stompin good entry level GPSr as well as (finally lol) added COLOR to a few models too, all at prices that are the best in the business!


I'll enjoy reading the next few "Garmin vs Magellan" wars :D

Link to comment

Hey, why are you folks messing around with COM port software when Lowrance has the FREE GPS Datamanager software available?


For the iFinders there, read about the GPS Data Manager V.6 here first.


This package is however 'useless' for you GO2 users because it will only READ / WRITE lowrance USR and GDM files. I gave it a quick run to see if it knows about COM ports. It doesn't do serial ports, so I wouldn't bother with it.


Download GPS Data Manager Version 6 Here


But, more interesting for you GO2 users, read about GPS Data Manager V.3.1 here which is used for connecting to lowrance GPS's over a serial port.


The GO2 is not listed as being compatible, but if I were you folks, I'd give it a try anyway and see if it works! If it does work fully, you'll be able to make your own maps, and DL it into the GO2.


99 tracks * 9,999 points for each track is one HECK OF A PILE OF DATA!


Please let us know here if these packages work for the GO2, and to what level. Are you able to read/write TRACKS, routes, waypoints, and Icons?



----- MegaMapper -------

Link to comment

It worked! :D


I didn't have a serial mouse to cannabilize for the cable so I made one. Used a Radio Shack connector and hood (Part numbers 2761538 and 2761539, $1.59 ea), 18 gauge speaker wire with the ends downsized and an old ATM card.


Be careful soldering the socket, the connectors are super small.


After soldering check with a multitester just to be sure there is no short between the connectors.


The GPS Utility software works great! In the GPS setup menu select NEMA and 1200 baud. Oddly enough, selecting Lowrance as a type of GPS didn't work. I also went into the setup on the GPS, comm ports and told the Lowrance 1200 baud, although it probably would be fine without changing the default setting.


Then to enter waypoints from geocaching.com I do the following.


#1. Download the waypoint file from the log at geocaching.com.


#2. Merge the waypoint file into a file in GPS Utility.


#3. Repeat steps 1&2 for each waypoint you want to save. The downloaded file from geocaching.com will have the same name each time, just write over the previous file. When you merge it will add each one to a single file in GPS utility.


#4. Assuming the Lowrance is hooked to the computer, select Upload all and let er rip.


Thanks to everyone who posted information on how to do this. :D


I have really enjoyed my Lowrance Ifinder go. In Colorado we spend lots of time geocaching in canyons and the Ifinder has performed excellent in these conditions, rarely loosing its bearings. Battery life is phenomenal. I have paid more for calculators than I dropped on this nifty little GPS.


The only issue I had with it was all the time spent hand keying the coordinates into the unit. Problem solved! :P

Link to comment

That's great news Krazy Kat :lol:


Pretty amazing what a $68 GPSr is capable of eh? :)


Now that I see how "easy" it is to rig an iFinder GO/GO2 to accept a data stream, it does make me wonder why Lowrance didn't just offer this ability automatically. I guess they assume the majority of entry level GPSr shoppers wouldn't be worried about PC linkability, so not offering it avoids needing to support the feature.


Have fun Geocaching with it!

Link to comment

You may have noticed that Robert published the new beta of Gpsbabel with the "Lowrance enhancements" included.


You can now create 20 character waypoint names and download them to your GO. Just equip your GSAK with the new gpsbabel.exe, then do a File->Export->Custom Export.

%code %typ1%dif1%ter1%con1%bug
"F:\Program Files\GSAK\GPSBabel.exe" -N -i gpx -o nmea,snlen=12 -f "F:\Program Files\GSAK\temp\babel.gpx" -F "F:\Program Files\GSAK\temp\nmea.txt"

which will come up with something like:

$GPWPL,5011.799,N,00830.017,E,GCGRMY T32RN*28
$GPWPL,5011.639,N,00829.933,E,GCEA46 M34RN*3C
$GPWPL,5014.300,N,00837.300,E,GCM6KM Y82SY*47
$GPWPL,5007.228,N,00834.219,E,GCN9JJ M21SN*44

Which you can download to your GO using the terminal program of your choice.

Edited by Eliveras
Link to comment
...I wonder if setting the serial port params with the mode command and letting GPSBabel squirt that right into the serial port would work...
I kinda doubt it. See post 22 in this thread. Users sending data through the terminal program needed intercharacter and interline delays or the Go/Go2 wouldn't keep up.
That'd let you sidestep the terminal program and have something more automatable...
Why doesn't GPSBabel doesn't support serial output directly in its "everything including the kitchen sink" theory of output options? Edited by lee_rimar
Link to comment

Aaaah, yes. I see I had mentioned this before.


GPSBabel does support writing to serial ports using the technique described above. It does not do the newline pause thing. Of course, since it's open source, anyone with access to the equipment that wanted to add it is free to do so.

Edited by robertlipe
Link to comment

Sorry, I started another post on this topic before I stumbled across this one...


I recently purchased the adapter cable that Lowrance sells for the iFinder Go and Pro models (PC-DI5, $34.95 at Lowrance but cheaper at TigerGPS and GPS City). One end connects to the Tx, Rx and ground pins on on the bottom of the unit and the other end is wired to a standard female DB-9 clamshell-style connector. Opening the DB-9 connector with a screwdriver reveals that only pins 2, 3, and 5 (Rx/Tx/Gd) are used (no handshake looping).


I've used HyperTerminal to copy a block of 32 sentences (comprised of every sentence previously listed in this post) directly to the iFinder, by pasting the block into the HyperTerminal console (via right-click > Paste to Host). I had no problems whatsoever using HT's default settings of 0 (zero) milliseconds line delay and 0 (zero) milliseconds character delay.


I suspect that any problems using HyperTerminal with iFinder are due to the fact that HT defaults to settings (2400 baud, hardware handshaking) that are incompatible with the iFinder and the NMEA 0183 v2.0 protocol. To change these settings in HyperTerminal, select Call > Disconnect, then select File > Properties > Connect To > Configure, and make the settings match the protocol (4800 baud, 8-N-1, no flow control).


You should also make sure that the iFinder is using the default 4800 baud rate via Menu > System Setup > Com Port (in Advanced Mode). NMEA Input must also be enabled here, but NMEA Output does not appear to be necessary unless you want the iFinder to act as a simple GPS sensor (e.g. connected to a laptop with suitable software). The Configure NMEA button allows you to select which sentence identifiers are broadcast when NMEA Output is enabled.


BTW, I've studied the product manuals for all of the iFinder models (Go, Go2, Pro, H2O, Hunt, M&M, and PhD) and it appears that they all implement the same NMEA 0183 v2.0 interface (a few also include DGPS settings). So it looks like this port really does offer a universal method of uploading waypoints to all of the iFinder models, without having to swap out memory cards on those models that support them.




"This is getting curiouser and curiouser..."

Edited by PeterGo2
Link to comment

My own testing of my iFinder Go2 shows that it supports a maximum of 20 characters for both waypoint and route names, when waypoints are entered manually via the user interface. However, this sentence (provided by robertlipe earlier in this post):




uploaded via HyperTerminal "as is" into my Go2. In other words, I now have a waypoint with the 22 character name "xxxxxxxxxxxxxxxxxxxx22" in My Waypoints. So the Go2 user interface does not fully exploit the capabilities of the unit.





Link to comment

Eliveras stated earlier in this post :


The unit offers 20 characters for waypoint names (they seem to specifically target the German market because the only non-ASCII graphics available are the ones needed for the German language "ßÄÖÜ").

robertlipe replied:


That's interesting on the German stuff since NMEA explictly calls out ASCII which would preclude those characters. What character set it used to xfer those? UTF-8 or one of the 8859 brothers?

From the iFINDER Go Advanced Users Guide:


This unit's menus are available in 10 languages: English, French, German, Spanish, Italian, Danish, Swedish, Russian, Dutch and Finnish.

To select a different language:


2. Press ↓ to SET LANGUAGE...|ENT.

3. Use ↓ or ↑ to select a different language and press ENT. All menus now appear in the language you selected.

My Go2 has the default English language selected. The user interface allows me to input the following characters manually for both waypoint and route names:




However, the sentence:




uploaded via HyperTerminal produced a waypoint with the name "ßÄÖÜ" in My Waypoints. So it appears that character set limitations are only in the manual input interface, based on the language selected.


This is just too cool!!! :lol:

Edited by PeterGo2
Link to comment

So you say that no delay between sentences works and Eliveras says it doesn't. Hmmm.


PeterGo2, did your sample upload contain 8859-1 or UTF-8 encodings of those characters? The languages you list all have similar-ish character sets, but they're not all 8859-1 (Western)


Still, advanced character set manipulation (which GPSBabel knows how to do) is kind of a bonus round until this combination hits a critical mass....

Link to comment

Eliveras' posts didn't clearly state whether he had tweaked the default HyperTerm settings to match the protocol/iFinder defaults. I would expect that HT's default hardware handshaking would not play well with the lack of actual hardware support for this. I'm guessing that was the real problem in his case. But my test with the default 0 ms delay used an admittedly small block of 32 sentences. If you can send me a larger block to test with (use the forum e-mail system) I'd be happy to do so (I don't have any software to quickly generate checksums en masse).

Edited by PeterGo2
Link to comment

My sample upload for the character set test:




used a simple copy and paste of the "ßÄÖÜ" string from Eliveras' post. So I don't know the actual encoding for the characters. But I'll bet you know more about this than I do. :lol:

Edited by PeterGo2
Link to comment

I won't speculate which window manager operating system you're using, so I won't guess what your "copy and paste" generation actually generated.


Generating waypoints en mass is trivial. From the 'teach a man to fish' department.


[robertl@rjloud geo]$ i=0

[robertl@rjloud geo]$ while ((i < 250)); do echo 0.$i, 0.$i, $i; ((i++)) ; done | gpsbabel -i csv -f - -o nmea -F -



























































































































































































































































[robertl@rjloud geo]$


You can use that set of waypoints to determine if the GO's actually do need a delay since they can't generate a handshake.

Link to comment

I was/am using Windows XP, and I haven't yet installed or fiddled with GPSBabel, so thanks for the test block.


I just made up a larger block of test sentences by taking the 32 sentences that I collected from this post and copying them 20 times into a Notepad document. This created a 640 sentence block of repeating waypoint names with a total byte count of < 32 KB. My objective was to see if I could jam up the Go2 input buffer using the default 0 ms delay in HyperTerminal.


After uploading this block via HyperTerminal I tried to open My Waypoints and the Go2 just froze up. I couldn't even power off the unit. I had to remove the batteries for a few minutes and reinstall them to restart the unit. I then tried to open up My Waypoints again and it stalled a bit but soon displayed a list of repeated waypoint names. Nearly every waypoint name in the test block had ~16 (not 20) repeated entries in the list, and at least one name in the block didn't show up at all.


I tried another test block created with only a 10x copy of the 32 sentence block, for 320 total sentences with a total byte count of < 16 KB. Strangely enough, this upload fared much worse than the larger test, with most waypoint names only being repeated a few times each (if at all).


So at this point it seems that there really is an issue with the Go2 COM port and HyperTerminal's default 0 ms delay. Unfortunately the behavior is inconsistent, and any missing waypoints may go unnoticed by someone who is not aware of this problem. Perhaps implementing handshake looping on the DB-9 connector might resolve the problem?


As a side note:


The Go2 allows duplicate waypoint names to be entered manually, and these tests proved that duplicate names can also be uploaded via the COM port. This means that there is no way to overwrite current waypoint entries via the COM port (unless perhaps the maximum waypoint limit is reached).


I'm going to give your test block a spin now...

Edited by PeterGo2
Link to comment

OK, your test block with unique waypoint names uploaded "almost" perfectly via HyperTerminal using the default 0 ms delay. The only missing entry was the first one named "0" (zero). I tried uploading just that first sentence by itself and the result is the same. I'm guessing that the NMEA input interprets zero as an empty string and as a result refuses to save the waypoint. I can enter a waypoint name of "0" (zero) manually, so this appears to be just a bug with the NMEA input.


I'm not sure why my cobbled test blocks wouldn't work correctly, but these blocks did have duplicate waypoint names and some longer than 20 characters...


At this point I'm back to my original belief that there's no need for line delay - provided you don't have duplicate waypoint names (which probably aren't allowed by most mapping software anyway), and you don't have names that exceed the 20 character limit of the user interface.


I may try to experiment with handshake looping on the DB-9 connector later when I get some time. I need to get some sleep now...

Link to comment

Just had a look at the GPS Utility program recommended earlier in this post by daytrek. The Help file for the program includes these entries applicable to the NMEA Send options:


"time interval between NMEA sentences (default is 100 milliseconds)"


"The Time value is the minimum time at which NMEA sentences are transmitted. Some GPS receivers cannot accept sentences at a fast rate. The default is 100mSecs - this is the time interval between each sentence. Note: Raytheon users should set this value to at least 300mSecs."


So there may be something to this line delay issue after all... :lol:


Good night!

Link to comment

OK, I tried setting a 100 ms line delay in HyperTerminal and then uploading my 320 sentence test block (with duplicate waypoint names, some > 20 chars). At first this didn't seem to solve the problem, as the upload was still incomplete. Then I enabled command echo in the HT console (in File > Properties > Settings > ASCII Setup > Echo typed characters locally) and noticed that it was (naturally) taking a lot longer to finish the upload, and I apparently hadn't waited long enough. After giving it a second (longer) try I found that the 100 ms delay did indeed seem to solve the problem.


But then I noticed that the commands were all being echoed on the first line of the console. Doh! HyperTerminal was not sending the <CR><LF> at the end of each sentence as required by the protocol. When I copied my test block from Notepad and pasted it into the HyperTerminal terminal window, HT was sending the line endings as simple carriage returns.


After changing HyperTerminal's default behavior to send the correct line endings (in File > Properties > Settings > ASCII Setup > Send line ends with line feeds), and resetting the line delay to the default 0 milliseconds, I had no problem uploading my ugly test block.


[Edited to correct my description of HyperTerminal's default behavior with regards to handling line endings. And HT's label for the option to fix this, "Send line ends with line feeds", is misleading: enabling the option actually forces HT to send a line feed with each line ending (not the other way around)].


So, once again, I don't think the iFinder NMEA input needs a line delay; but other GPS models may require it, and it still might be a worthwhile option to incorporate into GPSBabel. Thanks for your time...


(I think I've finally got this out of my system and can go to sleep now. Hopefully when I awake someone will have figured out how to upload routes via RTE...)

Edited by PeterGo2
Link to comment

This still sounds too flaky for me to spend the time to support it in GPSBabel. If the manufacturer itself doesn't support this with their own software - and your observations of various weirdities may explain why - there's probably a reason for that.


I'm glad that a low number of users have found a nifty little bonus in these models. If GPSBabel helps you out, that's even better. But your posts over the last few days really makes this combination sound too expensive to support officially for the masses.

Link to comment



As long as GPSBabel implements NMEA 0183 v2.0 correctly by sending <CR><LF> at the end of each sentence, then your program already supports the iFinder. My suggestion about adding line delay for other GPS models was based on what I saw in the GPS Utility program interface, not personal experience - please take it for what it's worth. ($0.02)


BTW, the combination of iFinder Go plus the Lowrance cable is right around $100, which doesn't sound too expensive to me. And even though Lowrance doesn't really explain how to use the NMEA Input feature in their iFinder documentation, this doesn't change the fact that the feature is included in the product line, available in the user interface, and mentioned in the documentation. So I wouldn't call this feature unsupported -- just poorly documented.




P.S. This Windows XP command will set COM1 to the parameters expected by NMEA 0183 v2.0:


mode com1 baud=4800 parity=n data=8 stop=1 xon=off odsr=off octs=off

And this WinXP version of your command will indeed create and upload a bulk test block via GPSBabel with no problems:


for /l %i in (1,1,250) do echo 0.%i, 0.%i, %i| gpsbabel -i csv -f - -o nmea -F com1

Thanks for teaching me how to fish... :)

Edited by PeterGo2
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 8
  • Create New...