Jump to content

Maintenance log posted on wrong date


Recommended Posts

Just noticed a small bug:

 

When I post a log for a cache and the log date is some days ago and, while composing it, also select "Report a problem" my log is posted with the desired date but the maintenance log is posted on the current date.

In my case it was a "Note" with reported problem "Container might be missing" for the March, 10th.

My note showed up on March, 10th but the maintenance log on March, 14th (today).

 

It's reproducible (tested on an owned caches).

  • Funny 1
Link to post

That is actually by design. The maintenance log is essentially recording the moment when the issue is reported to the cache owner. It is supposed to report when the issue was raised, not when the user reporting it encountered it.

  • Helpful 3
Link to post

When it happened to me, I understood the logic as soon as I saw it, but it was still confusing to me, and I assume to people reading the log. When I notice it, I go  back to edit the log text to add the date there in order to give people a fighting chance of understanding when I was there to observe the problem and help them correlate the maintenance log with my DNF or found log associated with it. As it happens, the first time I noticed this, the date was particularly important: the cache had fallen, out of reach, into a drain. I reported the problem in an NM saying that I could see the cache but the CO would have to come back with tools to retrieve it. Unfortunately, I didn't have time to post the log until the next day...after a heavy rain. Dollars to donuts the cache had been washed away overnight. I had to add text to my misdated log to explain the forced log date and make it clear that my observations were made the day before the date the system had forced onto the log.

 

In the new logging page, I suppose one can't complain when the secret, behind the back log has a different date, but I use the old logging page where it's just a bug that it lets me change the date when I'm posting the NM, but then ignores the date I set and posts it with today's date. I'm OK with the logic of the forced date, just not with the system pretending it's not forced when I'm setting it.

Link to post
On 3/14/2021 at 10:45 PM, Moun10Bike said:

That is actually by design. The maintenance log is essentially recording the moment when the issue is reported to the cache owner. It is supposed to report when the issue was raised, not when the user reporting it encountered it.

I get this as well. But could you (GS) somehow secure that these two logs (the NM and its accompanying WN) don't get divided by other logs?

Link to post
On 3/16/2021 at 5:30 PM, Pontiac_CZ said:

I get this as well. But could you (GS) somehow secure that these two logs (the NM and its accompanying WN) don't get divided by other logs?

 

This seems impossible to do as the logs are sorted by date and log-code.

There is a better way - post only an NM / NA log instead of WN + NM or WN + NA. I know, I know, this is the result of the new design functionality, but (thank god!) you can still "Opt out" and use the old editor to post the logs - there you can select the appropriate report log without having to worry about the logs being separated.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...