Jump to content
Sign in to follow this  
Followers 3
wwjd7

Incorrect roundabout exit counts on Oregon 700

Recommended Posts

When I transverse a roundabout, it'll frequently indicate the wrong exit count (eg. Take the 3rd exit when in reality it should be the 1st exit). The images below show the problem.
 
By the way, it's not this particular roundabout, it occurs at other roundabouts as well. Doesn't always happen, just depends on my entry and exit points, but I see no pattern why it miscounts the exits sometimes.
 
Is this a problem with the maps or, dare I say, a bug in the routing engine? Anyone else notice this?

roundabout exit 1.png

roundabout exit 2.png

Share this post


Link to post

It's the 3rd exit if you drive on the left, but then the route is not drawn correctly.

 

Share this post


Link to post

I thought maybe it would be a strange way that someone had mapped the roundabout and its entrances and exits in OSM, but I took a look and couldn't see any issues.

Out of curiosity, what happens if you try to route to the section of Erb Street on the left? Does it still say to take the 3rd exit (which would be correct in this case), or does it say something like the 6th exit? If you have the map installed in Mapsource or Basecamp, try the routing there and see if it suffers from the same problem. If it does, then the problem is probably with the map and not your device.

Share this post


Link to post
Did more tests. Below is the worst case example I saw, to take the 7th exit on a 4 exit roundabout. Other entry and exit points sometimes showed no exit counts at all, just simply to turn L or R at such-and-such a street as if the roundabout didn't exist.
 
Basecamp does the same thing. However, since Garmin is the source of the routing software in both the GPS and Basecamp, this is inconclusive where the problem actually resides, the maps or the routing algorithm? I have no other maps to try. Wanted to hear if others have noticed this.

roundabout exit 3.png

Share this post


Link to post
52 minutes ago, MartyBartfast said:

I just tried doing those routes on https://www.openstreetmap.org and it gives the correct number of turns, so that suggests that the OSM map routing data  is correct and the problem's on the Garmin routing algorythm.

 

 

Capture2.PNG

Capture1.PNG

 

So, it would appear the bug is in the routing algorithm and not the OSM maps being at fault. Thanks for verifying that MartyBartfast. (Learned something new... wasn't aware you could draw routes on the OSM site, good to know. Thanks.)

Share this post


Link to post

The bug could also be in the OSM to IMG conversion.  It is counting each intersection as an exit.

  • Upvote 1

Share this post


Link to post
3 hours ago, Red90 said:

The bug could also be in the OSM to IMG conversion.  It is counting each intersection as an exit.

I don't think so, as this also occurs (for me) when using City Navigator Maps from Garmin.

I had completely forgotten about this bug until this post popped up. I will be submitting data to Garmin later today.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 3

×