Jump to content
Sign in to follow this  
Followers 3
bitmapped

API Access Slow / Down?

Recommended Posts

I've noticed for the last day or two that API access seems extremely slow. Accessing lists of Pocket Queries in GSAK v8 and searching for nearby caches on my phone with Geocaching Android app take a long time. I logged out in Android app and tried to log back in. I get a date/time error. I tried logging in via the API on GDAK on Android and get an error.

Share this post


Link to post

Same here and lots of folks on the GSAK forums are reporting similar issues with API access :(

Share this post


Link to post

I'm not able to search for caches with my iPod app.

I tried:

- closing the app and then restarting it,

- changing the settings to include all finds

- shutting down the iPod and restarting it

- deleting the program (and unfortunately all saved data, notes, etc.) and then reinstalling it

- now I can't even log on to geocaching.com with the app. I just get a blank screen

- tried deleting the program and reinstalling it again still without luck

Edited by Pomwoof

Share this post


Link to post

Yep, trying several different macros from GSAK and getting errors saying "Service not available"

Share this post


Link to post

Same here. can't do anything with GSAK because of API problems. :(

I hope it will be fixed soon.

Share this post


Link to post

Our database server started experiencing performance issues yesterday, with the CPU spiked at 100% at staying there. This led to numerous observations of site slowdowns and broken functionality.

 

Engineering has been working on this issue through the weekend and this morning was forced to turn off the API in order to isolate the issues taking place with the database server. Investigation is still underway and we hope to be able to turn the API back on once the issues have been identified and corrected.

 

Thank you for your patience; we know that this is a major impact on everyone and are hard at work to get things back to normal.

Share this post


Link to post

I don't know if it helps but I am having issues logging in (I get the time-zone error) and connecting to geocaching.com via the app (doing "Find nearby caches").

 

Hope it is fixed soon, Sundays are the only days my wife and I can geocache.

 

Lndcrsn

Edited by Lndcrsn

Share this post


Link to post
Engineering has been working on this issue through the weekend

That didn't use to happen back in the good old days. We'd have to wait for someone to notice on Monday morning. :)

Share this post


Link to post

The problem is solved!!! :laughing:

 

:sad:

I´m sorry, but api dosn´t work with GSAK at the moment.

But I´m sure the Lackeys will do their best... :anicute:

See you at the blockparty in Seattle,

 

greetings from Cologne/Germany,

Thomas

 

www.projecta3xx.de

Edited by E-Fuzzy

Share this post


Link to post

We have had problems all day--and they continue! My phone says to log in but it cannot get to the page. One time it actually allowed me to type my login but then said it was denied. My husband's phone says "session has expired -- please log in" and he IS logged in.

Share this post


Link to post

Went out caching and things are working fine for me now. Thanks for working weekends -- I work in I.T. and I know what a pain that is. Much appreciated, everyone! :D

Share this post


Link to post

Is the API still turned off?

 

I can use the API in GSAK to download all recent logs of a single cache.

When downloading all recent logs of more than +- 100 caches, i get a "Not authorized" error message.

Edited by DanPan

Share this post


Link to post

Is the API still turned off?

I can use the API in GSAK but sometimes i get a "Not authorized" error message when downloading recent logs.

 

Everything runs fine here. :anibad:

Share this post


Link to post

Is the API still turned off?

I can use the API in GSAK but sometimes i get a "Not authorized" error message when downloading ALL recent logs.

 

The API is operational, but we have had to impose some emergency restrictions on calls involving log download via the API. These changes may be permanent or may be relaxed in the future depending on how things go. Log downloads via the API were a large component of the performance issues we had over the weekend. Simply put, calls for logs via GSAK were alone equal to half of all of the API calls made (all kinds) by the iPhone app.

 

Right now, the new restriction is 200 log calls per hour, with each call containing up to 30 logs.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 3

×
×
  • Create New...