Jump to content

Colorado bad unit after bad unit.


Pictugator
Followers 0

Recommended Posts

HI!

 

First unit had battery problem. When using the unit for 3 to 5 hours and then turning it off, sometime it

wasn't able to boot up has i tried to turn it back on. I saw Garmin screen then it fade away.

Serial :169000xxx

 

98000 units later...

 

Second unit date & time stop when unit turned off. I have to see the sky to have accurate date and time.

If i turn it off at 2h00 pm for an hour then it show 2h00pm after I turn it back on. So the alarm screen is useless.

Serial:169098xxx

 

Am I the only one out there with so much problem with this Colorado Serie.

:lol:

Edited by Pictugator
Link to comment

These are both problems that have been addressed by firmware. Have you been using up to date firmware?

 

What type of batteries are you using? The meter does not work properly with Alkalines. Lithium and Ni-MH should work fine. I run at least 14 hours on Ni-MH.

Link to comment

These are both problems that have been addressed by firmware. Have you been using up to date firmware?

 

What type of batteries are you using? The meter does not work properly with Alkalines. Lithium and Ni-MH should work fine. I run at least 14 hours on Ni-MH.

 

I always check for new firmware. My first unit was at 2.6 before a sent it for repair.

Problem confirm by Garmin technicien.

Battery used: Maha Powerex 2700 NIMH with Maha charger 900. Unit set to Ni-MH battery type.

 

Second Unit firmware 2.7 and returning as we speak to Garmin.

Link to comment

Well....I suspect that your batteries are not properly charged. It is very easy to do and I've seen it all the time.

 

The current firmware is 2.70/2.80 I have not heard of anyone having the clock problem with 2.70 as it was fixed in 2.60. As explained here: http://garmincolorado.wikispaces.com/Issues+List it is important that the new unit have adequate time to establish a full GPS almanac.

Link to comment

Well....I suspect that your batteries are not properly charged. It is very easy to do and I've seen it all the time.

 

The current firmware is 2.70/2.80 I have not heard of anyone having the clock problem with 2.70 as it was fixed in 2.60. As explained here: http://garmincolorado.wikispaces.com/Issues+List it is important that the new unit have adequate time to establish a full GPS almanac.

 

I tested my batteries and they show 2540 mAH after I discharged it with my charger.

 

I know the issue with the full GPS almanac. The first day of the GPS was outside and ON for the night.

SO I was sure that the Almanac was properly downloaded into the GPS.

 

thank's for pointing it out.

Link to comment

I had two of the 169000xxx CO's and they were both uncategorically JUNK!!!!!!

 

The batteries ran dead on the second unit and it would not restart. Came up System Software Missing. Garmin had to replace it because it could not be fixed. All because of batteries running out????????????

 

After 3 bad ones, Garmin gave me an Oregon.

 

I strongly recommend you cut your losses and see if they will give you an OR. Day and night difference.

Link to comment

I had two of the 169000xxx CO's and they were both uncategorically JUNK!!!!!!

 

The batteries ran dead on the second unit and it would not restart. Came up System Software Missing. Garmin had to replace it because it could not be fixed. All because of batteries running out????????????

 

After 3 bad ones, Garmin gave me an Oregon.

 

I strongly recommend you cut your losses and see if they will give you an OR. Day and night difference.

 

So I am not alone!!!

This is exactly what i asked them ( an Oregon instead).

Waiting there answer....

Link to comment

I have a 400t that I bought in April and the gasket on the battery compartment is screwed up. I bought from REI and not sure to return it or send it back. Mine works. The # 18z003xxx.

Any thoughts?

 

If it is only the gasket ask garmin for a gasket replacement, since your unit is working.

I will pay a gasket replacement if I were you. Because if you replace the entire unit it will cost you

shipping to send them the unit. I think paying the gasket and shipping will be cheaper.

 

My advice. :lol:

Link to comment

Sorry to hear about the lemons. I got a bad 400T from REI and returned it and bought one online from Walmart as they had a special price. It's worked excellent since day one.

 

Best of luck!

 

It is still under warranty & I have a RA # from Garmin but it will be gone for 7 - 10 days. It would be easier to return it to REI for a new one. I just don't want to get a lemon.

Link to comment

I have a 400t that I bought in April and the gasket on the battery compartment is screwed up. I bought from REI and not sure to return it or send it back. Mine works. The # 18z003xxx.

Any thoughts?

 

Return it to REI. That's why you paid a premium. Get a brand new unit and you don't have to wait at all.

 

REI rocks.

Link to comment

I have a 400t that I bought in April and the gasket on the battery compartment is screwed up. I bought from REI and not sure to return it or send it back. Mine works. The # 18z003xxx.

Any thoughts?

 

Return it to REI. That's why you paid a premium. Get a brand new unit and you don't have to wait at all.

 

REI rocks.

 

Well........took it back to REI today. Walked in and she gave me credit for my unit of 599. Then charged me 439 for the new one & I got a 172 bucks back on my credit card. Almost like hitting lotto today!

 

REI does ROCK!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 0
×
×
  • Create New...