Jump to content

Colorado 400t won't advance past 'loading maps' page

Recommended Posts

Thanks for the reply.


I am currently not using a SD card.


I have been trying to fix this for a while, and have stumbled across a solution. I'm not sure what worked, since I tried it all.


I am hoping this doesn't happen again.


I was worried since I wasn't using an SD card, that the entire unit was corrupted. This happened after I tried to send a couple of new caches to the unit.


I am concerned that perhaps a glitched happened along the way between the new geocaching pages and the colorado.




ps: before today, I have had a few times where this happened. When I turned the power on, the gps would get stuck before it was entirely loaded. I would wait, and nothing would happened. Just the "Garmin" on the screen and "Loading Maps". It wouldn't advance, AND, I couldn't turn the unit off. I would remove the batteries (which is a fun process to do when driving) and that would fix the problem.


This happened about 4 times before today. I have had the unit for about a month.


No amount of removing the batteries today fixed the problem.


So, do you think there's some sort of corruption? (remember, I'm not using an SD card)


Pull your SD card and then try to start up the colorado. If it boots then your card is corrupted.

Link to comment

When I have seen this it is because of a corrupted gpx or img file. If you've just recently downloaded new files (either gpx or img) and this happens the easiest way to fix it is go through the recovery procedure here:




This forces the CO to boot into mass storage mode where you can delete the offending file(s) and then reboot normally. No need to master reset, no settings or data lost.



Link to comment

Trying this now.


My software version is 3.40 and GPS versiom 290. Is that old?


Although firmware 3.40 is not listed here, I do believe that was the last version Garmin released for those units.




The Garmin beta page shows a beta firmware 3.52, so I suspect you may need to connect your Colorado and run WebUpdater to get a newer version firmware!

Edited by Atlas Cached
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...