Jump to content
Sign in to follow this  
Followers 3
Spunkmeyer

HTC 6800 / Sprint Mogul

Recommended Posts

The player takes about 5 minutes on the "GPS Device Detection in Progress" screen. Then, I am presented with my loaded carts (just the tutorial right now). I select the tutorial, see my "satellite indicator" mostly green but often flickering to red. I get "my spacesuit on" and begin the 50 foot walk. I eventually get another screen, presumably with the 3 objects in my inventory before the screen blanks and the program totally locks up.

 

I've tried this a number of times and get the same result.

 

Using the integrated GPS which works fine for GoogleMaps and iGuidance.

 

As another user already described, it is annoying that even though I told the player to install on my memory card, it installed in main memory.

Share this post


Link to post

Oh, and the QVGA screen resolution does not appear to be well supported - you need to scroll slightly on most of the screens I saw in the tutorial.

 

Aren't most WM phones 240x320 or 240x240? Seems like there would be a nice market of users that already have this hardware.

Share this post


Link to post

I finally got it to work by using an external BT GPS and unchecking "Manage GPS automatically" (in Windows Mobile settings) - although I still got "bad GPS signal" messages in the player even though I had a green indicator with two (of four) bars...

 

This will be fun once some more carts get built. Right now, 13 in the US and 4 locationless "demos". I'm kinda psyched to be one of the first 124 to log completing the demo. Hehe... it's a start!

Share this post


Link to post

Has anyone had any Success with the mogul after the firmware upgrade? It seems to lock my devise up every time I run Wherigo and I have to do a soft reset.

 

However I did make some small progress when I un-checked manage GPS automatically the mogul then does not freeze up and it will then let me go to the screen where I can mess with the GPS settings but I can not get it to connect to anything, I have changed all the com ports etc and tried and tried.

 

I also notice that no other GPS enabled program works when I do this i.e. Google earth or cache mate.

Share this post


Link to post

A small update I tried again with my Bluetooth GPS and I got Wherigo to work and I played the tutorial again,

 

This leads me to believe that Wherigo may not be able to find the internal GPS on the mogul or when it does it can not figure out how to make it work and it just freezes the phone.

Share this post


Link to post

Pretty much what I have determined - Wherigo doesn't initialize the internal GPS or can't read it or something. The developers need to take a look at why this seems to be the only GPS app that doesn't work with internal GPS.

 

I haven't written software in a looong time, but there are tons of GPS apps (some even free) that work great so the methods to make it work are definitely out there. So what are they doing differently?

Share this post


Link to post
I haven't written software in a looong time, but there are tons of GPS apps (some even free) that work great so the methods to make it work are definitely out there. So what are they doing differently?

My guess is there isn't one "killer library" that will do everything and interface with anything. If you use one library, you're missing out on the functionality another provides. Mixing certain ones isn't that viable as well because, at the higher level where your program is executing, you don't have access to the nitty-gritty and can't determine why something didn't connect, much less switch to a more appropriate library.

 

Well, anyway, Groundspeak will continue to improve what they have. Like with all software development, it'll slowly improve.

Share this post


Link to post

True. Maybe have the app configurable by the user to select whether they are using BT or not. Then load the appropriate library. They'll get it working eventually - especially since many of the 'new' cell phones are including GPS now as well.

Share this post


Link to post

WAHOOO SUCCESS with the internal GPS!! It took A LOT of tweaking but here is what I did :D

 

1 Go to Settings, System, External GPS

 

2 Go to access and uncheck manage GPS automatically and click ok

 

3 Run Wherigo and let it fail to communicate to the GPS this will allow you to change the settings manually instead of it locking up.

 

4 In Wherigo uncheck the box Auto Detect GPS and set com port to “COM4” and Speed to 4800 then close Wherigo

 

5 go back into your External GPS settings and re check the box Manage GPS automatically and click ok

 

6 Do a soft reset

 

7 Run Google maps and make sure that your GPS is operating.

 

8 Open Wherigo and it should work. :)

 

I think problems like this could be prevented if they would let us manage our settings on the initial setup instead of letting the program auto detect the GPS. However it could just be our phones :o:)

Share this post


Link to post

No go for me after following the above steps.

 

Oh well - there is only 1 Wherigo cache in my whole state so it's not like I am missing anything. I'll wait until the developers have figured it all out.

Share this post


Link to post

What Com port is the internal GPS defaulted on? Make sure they match I also noticed if you change the internal com port from its default number it will not work. Mine was set on 4. So make Wherigo match the internal GPS settings. I just checked with a friend of mine and he has the mogul as well, he did everything I said with one exception, he used 9600 baud and it works for him.

Share this post


Link to post

I've got an HTC 6800 from Verizon, and have the same issues - the Wherigo app locks up after a few minutes, but more importantly, the GPS functionality on the phone doesn't really work through a COM port interface. While I can run various apps that access the GPS on COM4, there's no location. It bounces me literally all over the world. Loading my local catridge puts be from 100 to 5000 miles away.

 

As also mentioned here, Google Maps and Microsoft Live search use the GPS Intermediate driver, and GPS locations are spot on.

 

Is it possible to get this app to use the Intermediate Driver? I'm guessing that this would help the lockup issue as well.

 

Thanks!

 

Steve

Share this post


Link to post

I've got an HTC 6800 from Verizon, and have the same issues - the Wherigo app locks up after a few minutes, but more importantly, the GPS functionality on the phone doesn't really work through a COM port interface. While I can run various apps that access the GPS on COM4, there's no location. It bounces me literally all over the world. Loading my local catridge puts be from 100 to 5000 miles away.

 

As also mentioned here, Google Maps and Microsoft Live search use the GPS Intermediate driver, and GPS locations are spot on.

 

Is it possible to get this app to use the Intermediate Driver? I'm guessing that this would help the lockup issue as well.

 

Thanks!

 

Steve

 

Follow the above instructions to disable the Intermediate Driver, then manually select the port (usually COM4:) in the Wherigo player (turn off auto-detect GPS). Once you've done this, re-enable the Intermediate driver and restart the Wherigo player.

 

I've run the Intermediate GPS on several HTC devices using the method described above... whippintegra describes the process nicely.

Share this post


Link to post

OK, this gave me a little trouble, but I worked it through!

 

First I went to settings, GPS, and shut down the auto detect.

 

Next I started the Wherigo program.

 

I let it fail, and did the auto detect shut down, set com 4, and 4800 just like above.

 

Next I left Wherigo running, and hit my windows button, brought back up the phone's settings, and restarted the auto detect function. I then closed the settings, and went back to the still running Wherigo program.

 

I then was able to click on OK, and it detected the GPS! I then closed everything, did a soft reset, and now it works.

 

Thanks for getting this going for me.

Share this post


Link to post

OK, this gave me a little trouble, but I worked it through!

 

First I went to settings, GPS, and shut down the auto detect.

 

Next I started the Wherigo program.

 

I let it fail, and did the auto detect shut down, set com 4, and 4800 just like above.

 

Next I left Wherigo running, and hit my windows button, brought back up the phone's settings, and restarted the auto detect function. I then closed the settings, and went back to the still running Wherigo program.

 

I then was able to click on OK, and it detected the GPS! I then closed everything, did a soft reset, and now it works.

 

Thanks for getting this going for me.

 

I did this and it works great. My gps is a little buggy in that it sees it and then it doesn't but that's the phone, not the app. I dont' even think it's going off, just that it doesn't have a very large library of icons and it's doing something other than on or off so it flashes the antenna icon.

Share this post


Link to post

WAHOOO SUCCESS with the internal GPS!! It took A LOT of tweaking but here is what I did B)

 

1 Go to Settings, System, External GPS

 

2 Go to access and uncheck manage GPS automatically and click ok

 

3 Run Wherigo and let it fail to communicate to the GPS this will allow you to change the settings manually instead of it locking up.

 

4 In Wherigo uncheck the box Auto Detect GPS and set com port to “COM4” and Speed to 4800 then close Wherigo

 

5 go back into your External GPS settings and re check the box Manage GPS automatically and click ok

 

6 Do a soft reset

 

7 Run Google maps and make sure that your GPS is operating.

 

8 Open Wherigo and it should work. ;)

 

I think problems like this could be prevented if they would let us manage our settings on the initial setup instead of letting the program auto detect the GPS. However it could just be our phones :D:P

 

This worked for me on a HTC Touch Diamond. :D

On step 4, I cannot close because Wherigo cannot test the GPS. Bij enabeling Com4 at this point again Wherigo accepted the GPS and I can start cartridges.

(did not check if my other GPS-enabled apps still work, but I assume so as these also use Com4)

 

Thanks for this workaround.

 

BigBird

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 3

×