Jump to content

Geocaching Kml: New Google Earth Plus Question


BlackHelicoptersInc
Followers 5

Recommended Posts

We just downloaded the new Google Earth Plus and its really nice. (we note that its in Beta).

 

But we noticed that the groovy little icons that mark caches in the Geocaching kml overlay thingy (sorry, I'm slipping into non techy jargon) doesn't work. They're just push pin icons. Has anybody else noticed this, tried it:?

 

We kept the previous version of Google Earth, and all our stuff transferred to the new one. It still picks up the caches, but we really liked the Geocaching icons that differentiated between types of caches. Are we doing something wrong, or is this just what you get when you go Beta?

Link to comment

But we noticed that the groovy little icons that mark caches in the Geocaching kml overlay thingy (sorry, I'm slipping into non techy jargon) doesn't work. They're just push pin icons. Has anybody else noticed this, tried it:?

 

Raine can jump in on this later but it is a known issue with the latest upgrade to Google Earth. Maybe we were one of the only people using that feature. Try and post the issue in their support forums and see if they are already addressing it.

 

Google KML format isn't very well documented.

Link to comment

We just downloaded the new Google Earth Plus and its really nice. (we note that its in Beta).

 

But we noticed that the groovy little icons that mark caches in the Geocaching kml overlay thingy (sorry, I'm slipping into non techy jargon) doesn't work. They're just push pin icons. Has anybody else noticed this, tried it:?

 

We kept the previous version of Google Earth, and all our stuff transferred to the new one. It still picks up the caches, but we really liked the Geocaching icons that differentiated between types of caches. Are we doing something wrong, or is this just what you get when you go Beta?

What version are you running? I am not experiencing any problems?

Link to comment
Raine can jump in on this later but it is a known issue with the latest upgrade to Google Earth. Maybe we were one of the only people using that feature. Try and post the issue in their support forums and see if they are already addressing it.

 

Google KML format isn't very well documented.

I've tried... there was a bit of banter back and forth for a while, but now it seems the power that be are ignoring the thread.

 

What I learned while examining it is that the icons _can_ still show up if they are referenced in a static KML file, but the KML folder/links that are returned to GE 4.X don't include the STYLE tags, which is where the icon images are referenced.

 

Here's basically how it looks in GE 3.X::

<styleUrl>#defaultStyle</styleUrl>
<Style id="31861c80-c044-48d0-b9bb-6e819fe854b8">
 <IconStyle>
<Icon>
  <href>http://www.geocaching.com/images/kml/8.png</href>
</Icon>
 </IconStyle>
</Style>
<Point>
 <coordinates>-122.2216,47.5421,0</coordinates>
</Point>

And in GE 4.X::

<styleUrl>#defaultStyle_copy1</styleUrl>
<Point>
 <coordinates>-122.2192,47.54200000000001,0</coordinates>
</Point>

the '_copy1' tag at the end of the Styleurl seems odd too... I've also noticed '_copy0' and I think '_copy2'.

Link to comment

Hi there!

I had the same problem and created a work-around (by implementing a small proxy which resolves the issue).

 

If you go to the preferences of the KML link in Google Earth, just change the URL from "http://api.Groundspeak.com/networkkml/geocache.aspx" to "http://www.jensscheffler.de/share/geocaching.php" at the beginning. This PHP page will forward the call and return a fixed result from the geocaching page.

 

Hope this helps you?

Link to comment

Reading the GE forums about this issue, it seems that a fix has been found. However, it won't show until the next release. So, next time an update for GE 4.0 beta is available, hopefully this issue will be resolved.

 

Anyone else who knows more, please correct me if I have misunderstood the cause and solution.

Link to comment

Thanks so much for the update. I will be looking forward to the next release.

 

Thanks again,

Sharnie

 

Reading the GE forums about this issue, it seems that a fix has been found. However, it won't show until the next release. So, next time an update for GE 4.0 beta is available, hopefully this issue will be resolved.

 

Anyone else who knows more, please correct me if I have misunderstood the cause and solution.

Link to comment

It looks like is caused by slightly invalid kml, luckily its easy to fix (as demonstrated by the proxy above), AFAIK Groundspeak are aware and have a fix ready for the site sometime soon. As it was the KML (probably my fault ;)) that was invalid I doubt Google will fix it their end.

 

Where did you update the link with the proxy? I clicked on "edit" for the "Geocaching Network KML" and it looked like this: http://api.Groundspeak.com/networkkml/geoc...JvUg%3d%3d&. When I changed it to the proxy, I got a network error and I had to reinstall the original link.

 

I am trying this on GE v3, just to make sure it works before I make the leap to Beta 4. Hopefully, that isn't the problem.

Link to comment

Right -- that's a more accurate description. It's not reliably one or the other, and I can't quite pinpoint why it changes.

 

--

Oh, is it actually every other one? I'm going to have to go look. As far as I could tell it was sporadic, but I wasn't really paying attention.

Edited by teich
Link to comment

Irritatingly it now says that I have exceeded the number of allowed views, which is garbage (isn't it somewhere around 100?)

 

Anyway, I assume everyone else also has the yellow thumbtack problem. Does anyone know more about the problem or who to talk to about it?

Link to comment
Guest
This topic is now closed to further replies.
Followers 5
×
×
  • Create New...