Jump to content

Wireless Insta-notify Link -> No Coords


martinp13
Followers 1

Recommended Posts

I get my insta-notifications sent to my Treo. I read the mail, and click the link to go to the cache. When the browser comes up, I get the page but the coordinates are censored because I'm not logged in. So I have to login on the Treo every time, which is a pain.

 

Is there some way to save off my login info, maybe encrypted in a cookie, and send it with the link request? I don't know what the best solution is, but the situation stinks. :D

Link to comment

still... even on desktop machines... if there is a way to configure a url (bookmark) something like

http: //www.geocaching.com/login/default.aspx?username=hynr&password=NoneOfYourBiz

then I would use it. Is there a syntax that works? On many servers something like that works.

Link to comment
still... even on desktop machines... if there is a way to configure a url (bookmark) something like

http: //www.geocaching.com/login/default.aspx?username=hynr&password=NoneOfYourBiz

then I would use it. Is there a syntax that works? On many servers something like that works.

From a security standpoint, passwords in a URL are a Bad Idea. When a password is in a URL, it gets stored in (potentially) all kinds of places, like your browser history, any web proxies that you might be using, and in server logs. It could even get sent to third-party sites as an HTTP-REFERER header if the website you're going to doesn't redirect you after logging you in (similar to using google and clicking on a search result--the website you clicked on knows what search terms you used to find them).

 

By putting the password in a POST form, it stays out of the URL and doesn't get logged in all of the above places. This is much more secure. Now, I realize that GC.com doesn't use encryption for login, so talking security is a little moot here, but I think it's always a good idea to be thinking about security in whatever environment you have.

Link to comment
How about checking the box that says "Remember me (requires cookies)" when you login. And make sure cookies are enabled in the browser. I haven't had to log in on my Treo for weeks, and I use it almost every day.

Every time you "Remember Me", it seems to un-remember you from every other computer you use to access that account. Somehow I think that's tied to IP or something like that. I even have the problem between work and home computers, then add a third one (Treo) to the mix? Bleah.

 

DPR: Those security concerns are appropriate. I don't care HOW they do it, but I sure would like to be able to log in via a link.

Link to comment
Every time you "Remember Me", it seems to un-remember you from every other computer you use to access that account.

Close, but not quite right.

 

Actually, when you "log out" on any one computer, all other computers logged into the same user will also be logged out. If you never logout from any of them, you won't have a problem. If there is one you must logout from, it may be better to not use the "remember me" checkbox on that computer. Just close the browser to logout instead.

Link to comment

I have to agree with Martinp on this one. I realize Jeremy runs the site, so the way he explains it should be the way it works. But in reality, I experience exactly what Martinp described.

 

For the most part, I log into GC.com from my laptop. I never log out. However, occasionally I login from the office computer. If I set the "Remember Me" box in the office, I then have to log back in the next time I go to GC.com from the laptop. If I just log in, but don't check "Remember Me" in the office, then I don't have to login again on the laptop.

 

I just chaulked it up to being something I could live with since I don't go back and forth that much. However, I could see it being a pain if someone switches often.

 

I do know it's not an IP issue as I have static IP at home where my office computer is located and when I take my laptop on the road, it doesn't "forget" me.

 

I am editing this post to retract all the above I put in grey. It seems something has changed since the last time I saved my login in the office. I just tried it again tonight, and both logins were saved. That is how it was doing a couple of months ago, however.

Edited by GeoBain
Link to comment
Guest
This topic is now closed to further replies.
Followers 1
×
×
  • Create New...