Jump to content

App not updating solved co-ordinates


Recommended Posts

Hi, having a bit of trouble with the app and it's workings once a puzzle cache has been solved and it's co-ords updated - here's what normally happens...


New cache gets published -  I solve that on a PC using geocaching.com, get through the checker correctly - edit the co-ords - refresh map view - map now shows jigsaw piece icon in correct spot on map. Works as expected.


Go mobile to physically find the cache - android app shows jigsaw piece in correct solved spot at newly updated co-ords as expected.

Here's where things get sketchy - asking mobile app to either navigate or give driving directions to this newly solved cache will direct me to the original unsolved co-ords. Checking in the app shows the correctly updated co-ords are shown, the map shows the correct updated co-ords yet asking it to do anything useful with them directs me back to the original co-ords. Have seen this an hour after solving on PC.

Looks to me like some kind of syncing issue (also have problems on some caches once logged as found with them still showing with an unfound icon and not updating for anything from a few minutes to hours). Have tried restarting app, switching from map view to messages and back to reload map, scrolling map to another area and back to reload caches but can't seem to hit on a working solution other than waiting and hoping or messing about manually pasting solved co-ords into google maps and using that to find which is far from ideal.

Anyone got any solutions please?

Edited by AplusBminusC
Link to comment
6 minutes ago, RuideAlmeida said:


Just create a new Waypoint with the solved coordinates, by instance. Then navigate to this new Waypoint.

A few years ago the app was having an issue with this and navigating to the posted coordinates instead of the solved coordinates. 

I now do what you suggested: add an additional waypoint, which only takes a couple seconds.

Edited by Max and 99
Link to comment

Good suggestions, thanks!


Didn't check waypoints to see if the actual waypoint got updated - maybe it only updates on the cache front page and doesn't push out the original to solved waypoint update till later. Will solve a few puzzles and check just for the sake of curiosity.

Link to comment

There seems to be an issue with 2 different sets of data - "map data" and "cache data".


Logged a find today, cache data showed as found, map didn't show a smiley. Went back into cache details, defo showing me in the list of logs, back to map, still showing not found icon.


Went back into cache, swiped down to refresh as BFJ above suggested, back to map view and icon was updated. Not an exhaustive debugging but it worked that time.

Haven't had a waypoint problem again yet but will be interesting to see if a refresh sorts this too.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...