Jump to content

Queries and Gmail


Recommended Posts

I'm going to guess that the link is not secure (http://) and thus Chrome blocks the download attempt.


Obviously the solution is for the engineers at HQ to update the e-mail template to use a secure link, because Geocaching.com can definitely talk https://.


For now the easiest way to get your results is going to be to download through the Pocket Queries page. Namely:

  1. Open https://www.geocaching.com/pocket/default.aspx.
  2. Click "Pocket Queries Ready for Download"
  3. Download the appropriate query.

Alternatively, you can:

  1. Right-click "Download now" in the e-mail.
  2. Click on "Copy Link URL"
  3. Open a new tab, and paste the URL.
  4. Before you hit enter, make sure that the URL that you pasted begins "https://" (note the "s").
Edited by Hügh
Link to comment

Google doesn't like URLs that are http rather than https, and probably assumes all zip files are evil.


Go to the website, click on Play and select Pocket Queries:




From there, click on the Pocket Queries Ready for Download tab and you'll be able to download it from there.


Link to comment
46 minutes ago, patsu said:

image.thumb.png.e8f941338041ae986e060c1fc3972f25.pngMy queries sent to Gmail are sent this way. Any help?



I tried a few ideas based on your question, and cannot cause that warning.  My PQs download with no issue.  I have Chrome at default security settings.  I've seen Chrome misbehave like that, but not lately.


Are you opening the email links in Chrome?  Or another browser or App?  You may need to be specific about operating system, software, and versions, where you see the problem happening.

Link to comment
12 hours ago, patsu said:

Using Windows 11 and Edge browser 


I also have Windows 11 and Edge.  I can't get the problem to occur, yet.  But I've set up a PQ to test some more things.


If I could get it to show the error, I'd try granting permission, per the info here (the 2nd from the last post has simple steps):

Edge: Can't Download File Securely, I WANT THIS OFF> - Microsoft Community



I got the error!

Duplicate this by running Gmail in the Microsoft Edge browser, opening the "Your Pocket Query Is Available" email and clicking the download link.  The error "[*.zip] can't be downloaded securely" occurs as shown in the OP.  At that point, you can allow an individual download with a few more clicks.  But read on to stop the error entirely.


Note that I pretty much cannot get the OP's error by doing things any other way.  I don't use Edge except to point and laugh at people who use Edge test something.  I run Brave with all the default shields up.  I don't use Gmail except for things that require Gmail.  And I don't download PQs from a mail link, I go to the web site and download PQs there.  The download is available long before I get an email notice.



But at the point where you see the error, you may change the settings that cause it.





Here's how to do that.  When the error pops up, you're still in Gmail (mail.google.com), and running it in Edge.  Stay there.

First, click the padlock next to the Gmail URL.






Next, in the box that drops down, click "Permissions for this site".






Last, scroll down the permissions page to "Insecure Content", and select "Allow".






Now try to download any PQ from an email.  It worked for me.


Some security issues are created when you do this (you have now shut off such warnings for any links from Gmail), but if you're downloading from Gmail anyway, this saves at least a few clicks.



Edited by kunarion
Link to comment
4 minutes ago, patsu said:

Installed Chrome, clicked on the download in gmail  got a log in box for Geocaching. After that all went, we[[.

Thank for help


I'm glad it worked!  Switching to Chrome (or changing any other part of the process) seems to be all it takes.  Which is weird, because when I've had "security warnings" while trying to use The Internet, it's been Chrome that has done that to me.


I also don't know what exactly the "mixed content, unsecured connection" is in the OP.  The Geocaching.com site and the Google.mail.com are both HTTPS, so is Geocaching.com, and so is the link to the PQ download.  It seems like Edge is misidentifying a download link.  Either that, or it's too hyper about flagging these things.  Seems like something that may automagically be fixed in a future version of Edge.

  • Helpful 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...