Jump to content

Garmin GPSMAP 66 and Multicache child waypoints

Followers 3

Recommended Posts

I have just bought a GPSMap66ST and it is a massive improvement on my previous GPS.  I really like the ability to be able to tether to my Android phone and download caches.  The problem is that if it is a multi cache I can't see the child waypoints and that is really frustrating.  Can anyone please advise me what I am doing wrong?  Thanks

Link to comment

You are not doing anything wrong.


I suspect this is a similar issue to when users were reporting that GCLive geocaches with corrected coordinates were being transferred with original coordinates, which turned out to be a Groundspeak issue, and was corrected without any updates to the Garmin GPSr.


It is currently unclear (to me) if this is a Garmin issue or Groundspeak issue.....


But, it is an Issue!

Link to comment

I may have solved my own problem as just found this on 

55. GC Live function fails to download any additional waypoints (Parking, Multi-cache stages, etc.) when available, effectively rendering the GC Live 'feature' useless for a large percentage of available geocaches. (825) [210] [250] [280] [290] [300] [310]
Link to comment

Any suggestions please? Having the same problem mentioned above == no additional (child) waypoints are downloading.  I have tried downloading via cable and gclive  None of the above suggestions help. Have checked for updates to device. 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 3
  • Create New...