Jump to content
Sign in to follow this  
Followers 2

Basecamp unable to open Google Earth Pro

Recommended Posts

Was working yesterday, today it doesn't.
From BaseCamp, I used to be able to select View/Google Earth/Selected Items. Google Earth would open and zero in on the selected item. Today, Basecamp displays the popup "This feature requires Google Earth to be installed and running. Please launch Google Earth, then try again."
It doesn't matter if Google Earth is running or not, Basecamp no longer communicates with Google Earth.
I suspect it's the new Google Earth Pro that is causing the problem, the old Google Earth worked beautifully. I searched my hard drive and the old Google Earth in no longer there, but I have the new 64 bit version Google Earth Pro. Must have updated itself automatically.
I tried this from the CMD line with no luck: "C:\Program Files\Google\Google Earth Pro\client\googleearth.exe" /RegServer. There were no errors or anything, it simply did not make any difference.
I'm running Windows 10.
Any ideas how to fix this?

Share this post

Link to post

The problem is that Basecamp is looking for the basic version of Google Earth (from a time when GE Pro was a paid product). You need to install GE Pro in the same directory path that the basic GE program would have been installed. On a Mac that was easy - just rename  the app 'Google Earth Pro' to 'Google Earth'. But since Windows will put program files into various locations in the OS, moving the install folder could break links between important files. But I suspect that the Google Earth Pro folder in Program Files needs to be named Google Earth.

Share this post

Link to post
I visited the link that alandb suggested. And thanks for that, the info provided there fixed the issue.
The 'fix' is to uninstall Google Earth Pro, then download and install the Google Earth Pro 32-bit version, NOT the 64-bit version. Seems that Basecamp doesn't like the 64-bit version of Google Earth Pro, but works great with the 32-bit version. Basecamp now opens Google Earth again! Didn't have to use the /regserver command line switch at all.
Thanks again alandb. B)

Share this post

Link to post

A new version for Google Earth pro is released, which addresses the issue (see last line):



What's New In Google Earth Pro 7.3.2


Here are highlights of the fixes, changes and improvements we've made for this release of Google Earth Pro.

  • Places panel: multiple-item selection, moving, deletion; performance improvements.

  • Network security updates and fixes; improved certificate support.

  • CSV import improvements: support older Mac file formats, multi-line text fields.

  • Ground overlay editor: fix glitchy rotation, rotation handle positioning.

  • Print preview: fixed mouse-wheel zooming, display refresh problems.

  • International languages: fix missing translations, keyboard shortcuts, UI elements.

  • Tables tool: improved stability, layout, data synchronization.

  • Tour Guide is hidden by default, reflecting Earth Pro use case.

  • Windows: allow Earth to run concurrently in multiple user sessions.

  • Windows: improved appearance on high-resolution monitors.

  • Windows 64-bit fixes: joystick support; crash when hiding 3D buildings; COM application (e.g. Garmin BaseCamp) interface.


Edited by StefandD

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
Followers 2

  • Create New...