Jump to content

62s now go to otherside of world when moving slowly


simplyred
Followers 1

Recommended Posts

I loaded it last week or so with new firmware, did a bunch of caches, and now today it shows me on the otherside of the world when, well sometimes when I'm moving and then it's sometimes when I'm stopped. As soon as I do the opposite, it puts me back in actual location, and then will go back to otherside of world. Anyone else experiencing these problems. I reloaded firmware and same problem. When I reloaded firmware i noticed it said "fixed issue when moving slowly in Canada"I think they created an issue. Any thoughts.

Link to comment

I did have it updated to 3.90. Worked for 2 days of caching then acted up. Had to go back to 3.71 cause that's all that was showing on Garmin's site. Worked good with previous firmware, can't remember what version it was, but the latest update is where the problem started. Will watch to see if anyone else has issues in the next couple of weeks, cause it was just out last week or so.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 1
×
×
  • Create New...