Jump to content
Sign in to follow this  
Followers 0

MobiPocket Killed my Visor!

Recommended Posts

Hello all.


I love the idea of using the eBook format to keep caches on my Handspring Visor. I've been using the Pathetique/AvantGo solution for quite some time, but it takes too long to synch so when I saw this new feature I decided to give it a try.


I installed the MobiPocket stuff on my Palm and tested it out using the sample file (Aesop's Fables) provided by the MobiPeople. Everything seemed fine.


I created a new query on the geocaching.com web site and waited patiently for it to arrive in my IN BOX. When it did, I transferred the .prc file and opened up the MobiPocket reader. Everything looked fine at the beginning including the disclaimer and the table of contents, but when I tapped a cache to view it, things went downhill fast. Instead of viewing the individual cache, I got a screen full of garbage text and my Visor froze.


I did a soft reset and (stupidly) tried again. Another soft reset.


I deleted the .prc file and created a new query. I synched this one to my visor with even worse results. This time I had to do a HARD RESET thereby deleting everything from my Visor.


Today I restored my Visor from backups and (ahem) tried again. I re-installed the MobiStuff from a freshly downloaded version and synched a BRAND NEW query file. Same awful results.


Is anyone else having these problems? I am using a Visor Prism with PalmOS 3.5.2H1.5. I have 904K free memory. I am using the 'reader only' version of MobiPocket because I am on a Mac. My MobiPocket is version 4.4 Build 376.


HELP! icon_redface.gif

Share this post

Link to post

I'm sorry to hear of your problems. I'll see if I can help.


How big was the file you were trying to read from? 500 caches? Have you tried lower results to see if the same problem happened?


Also try posting in the Mobipocket forums. The odd thing is the software is the same as the palm we have in the office, which seems to be running fine.


Jeremy Irish

Groundspeak - The Language of Location

Share this post

Link to post



Thanks for your reply. I actually tried 2 different queries, one containing 100 caches, the other containing 50 caches. Identically tragic results from each.


I sent an e-mail to MobiPocket support and I'm waiting for an answer. Chance are, however, they may blame your code.


I'd offer to e-mail you the files I am using, but I'd rather not crash your Palm. I wonder if it could have anything to do with the special Handspring version of the PalmOS?

Share this post

Link to post

A system I had to interface to, the other way around, involved uploading data from a Visor to a website. This website already accepted data directly from users, my visor app just submitted the same sort of data to the site, via a special ASP script provided by the site maintainers.


Their site performed some math on the data and presented a score for each submitted bundle.


One day, the scores started to be waaaaay off. I was immediatly blamed, even though the same problem would occur if you manually entered the data through their pre-existing user interface.


Ten hours of bickering later, after delivering a sniffed copy of the exact HTTP session to prove that I wasn't doing anything wrong, they finally fixed THEIR bug. The next week, they promptly billed the intermediate party for the hours. icon_eek.gif


Just thought I'd share icon_biggrin.gif



Share this post

Link to post

Funny. My Visor has no problem with the Mobipocket. I'm running OS version 3.5.2H3.0 and Mobipocket v. 4.4.375.


My first querry was 100 records and I can view it just fine.


smile02.gif If ignorance is bliss, why aren't there more happy people??

Share this post

Link to post
This topic is now closed to further replies.
Sign in to follow this  
Followers 0