Jump to content

Unit Crash


michiganman3
Followers 1

Recommended Posts

I have had my Venture HC for about a yr and half. Today as we approached our first cache of the day the screen went blank. The rechargeable batteries were fully charged, no trauma to the device, I don't think I have ever dropped it. So..... we switched out batteries, the screen 'flashed' like it always did when it was turned on, then nothing. Blank screen, no sounds.....nothing. Tried a few battery changes, again nothing. When we got home I hooked it up to the PC.....nothing......tried to load a cache.......computer says no device connected.

 

Anybody know what happened? Has this happened to anyone else. I am unhappily surprised. :o

Link to comment

When I plugged the GPSr in the computer with the USB cable I was able to power up the device. I backed up the data in Mapsource, then deleted all the info before doing a Hard Reset. I put the batteries back in and was able to use the device. I transfered all the data back to the device and it still works.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 1
×
×
  • Create New...