Jump to content

60cs Serial Connect For Topo! ?


Recommended Posts

I've been successfully using 60cs with MapSource connecting via USB.


Recently I purchased NG Topo! and a Garmin PC Interface Cable (#010-10141-00) which has the 9 pin serial port.


Problem: The 60CS is never found when connected with serial cable.


I figured I was missing a driver so I used my computer's XPsp2 Hardware Device Manager to attempt to load the 'missing' driver. I searched on the MapSource Trip & Waypont Manager installation CD, but drivers were not found. I tried the same using the NG Topo! install CD with same result.


Question(s): Do I have the wrong serial cable (got the part # from Garmin)? Is it a possible issue with my machine serial ports? Is there an alternative to importing into NG Topo such as ASCII or text file? Most importantly, am I stupid? I'm feeling like it...





Link to comment

I know nothing about the Garmon connector cable, but if it follows the Serial protocol, you might have to have the GPS powered up and running while you cold reboot your computer in order for it to initialize the serial port correctly and begin talking with it.


Try powering off the computer system completely. Power up the Gps. Then power back on the computer and see if the operating system sees the port. If it does not see the port, then you may have to go even deeper into your computer set-up to configure the port to the correct settings. (ie 8,n,1,p, xon-xoff or hardware flow control etc...)


I once found something fluky in the usb drivers that were written by Palm that might apply here as well. The computer in question had a usb palm cradle for one user and then my serial based cradle for my palm. The computer would not recognize the serial cradle when the usb cradle was plugged in and visa versa. It was wierd, but that situation might apply with you as well.



Link to comment

I also have a garmin map60cs and I use NG Topo, however both the serial cord I got from garmin and my gpsr only have 4 pins not 9.I do not know the sku# of my cord.


Make sure when downloading waypoints fron NG Topo that you click on the correct icon and that it opens a screen which should tell you that you have a garmin gpsr hooked up on a serial cord - not a usb cord and that the baud rate is 9600.

Link to comment
Also make sure the GPS is set to NEMA instead of Garmin for the interface.

Am I missing something here, or shouldn't it be the other way around, with the proper setting being "Garmin?"


Also, you don't need a serial cable. If you've got one of the State series NG TOPO! packs, you can get this $20 upgrade which supports the USB interface.


Rich Owings




"We were desert mystics, my friends and I, poring over our maps as others do their holy books." - Edward Abbey

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...