Jump to content

Need Help With Maccmconvert

Recommended Posts

I recently downloaded MacCMConvert/Cachemate to upload waypoints from my Palm Tungsten to my eTrex. When I try to convert the .loc files using MacCMConvert on my desktop, it gives me an error that CMConvert could not convert the file. Am I doing something wrong or am I missing a piece of the puzzle?

Link to comment

These are straight from GC.com. I tried .loc before I had a premium membership, and now I've tried GPX, but I get the same error for both. From what I've read, CMConvert works internally of MacCMConvert, and the error says "sorry, there was an error running CMConvert, your file was not converted", and then I get an applescript error. I tried re-downloading the ap, but I am still getting the same error. Plus I didn't think EadyGPS ran on Macintosh.

Link to comment

Ah... mind must have hiccuped when I mentioned EasyGPS there. That's the typical problem under Windows, though, in cases like this.


As author of CacheMate/CMConvert, I could help you if I had the exact error message from CMConvert, but it seems like the MacCMConvert wrapper is hiding that. Send the file to support (at) smittyware (dot) com and I can probably tell you what's going on.

Link to comment

I mean the .loc file ;)


You might want to check with the maintainer of MacCMConvert as well (JeremyA... there may be an email address in the package or on the web page for it). That error sounds familiar... there was a problem before with loading files with spaces in the file or directory names.

Link to comment



This sounds like a problem with my wrapper - scriptOut is the variable that is used to hold the text output from CMConvert, if all goes well this just tells you how many waypoints were successfully converted. That scriptOut is not defined means that CMConvert has not run properly which is probably due to something wrong in my applescript. Contact me (jeremy at jfatherton dot co dot uk) and I'll try to work through it with you to find where the problem is.



Link to comment


Where is the GPX file located that you are trying to convert?


I found that if it was located on my desktop or in a folder that had spaces in the name, it would spit back errors.


If I put in the same folder as MacCMC Convert, or made a special folder for it, it would work fine.




Currently I had to redo my Mac, and now Mac CMC Convert won't run, it spits back that I don't have administrative access :-(

Link to comment

I take that last post back. I just didn't try enough locations. Turns out the gpx file needed to be in the documents folder. So problem #1 solved!


Now, how do I transfer the waypoints from my Tungsten to my Legend? I must be missing the obvious. And, do I need to change any settings on my Legend to make it work correctly?

Link to comment



The 'spaces in the name' bug was a problem with my applescript in older versions of MacCMConvert. I have since fixed it, and in all my tests with the latest version (1.3.1) it does not cause any problems.


mtnmunch - could you email me as I'd like to try to get to the source of your problem too.





Link to comment

I think that I have worked out what has been going wrong here:


In the current version of MacCMConvert it is possible to manually enter a file name into the file name field. If you do this then, unless you include the full directory path (in POSIX format), cmconvert does not know the directory that the file is in and so uses the default directory. If the file is not there cmconvert will not see it and cannot perform the conversion.


This is not what I intended.


What I meant to happen is that you would select a file by clicking on the 'Add File' button to the right of the file name field. This way you can select a file in any folder and cmconvert will know where the file is.


The next release of MacCMConvert will have the UI updated to make this more obvious.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...