Jump to content

Geocaching not showing up on app


Recommended Posts

My geocache that I listed three days ago has just been published around 30 minutes ago. I got the confirmation email. However, it does not show up on the website app or on the IOS app, nor does it come up when I search for the geocache number. I’ve tried signing in and out, I’ve tried refreshing the app but it still isn’t showing up. 

Has this happened to you?



Link to comment

I encountered the same problem Saturday with the app.  I don't think it is a simple "delay".  There may be a larger problem.


As background, I attended an event, the first geocaching event for the host.  He was excited about it and had 4 new geocaches that were to come out at the end of the event, with pieces of a puzzle that could be turned in for a special prize (one for each player) once all the caches had been found.  All caches were published at about 11 AM, as evidenced by emails received by the CO and players who had their notifications set for the area around the event.  However, the new caches did not show up on the app.  I tried all the usual tricks on my iPhone 12:


  • Move the map to a new area and then back to the cache area so the screen would refresh.  Still not showing.
  • Close the app and then reopen it.  Still not showing.
  • Turn off the phone, restart it, then open the app.  Still not showing.


Finally, I suggested the CO provide the GC codes for the new caches to event attendees and they could then search in their app for the caches.  That worked, even though the caches still did not show up in the app's map.


Over an hour later, the caches were still not showing on the app's map.  It should be noted that this problem occurred on both iOS and Android versions of the app, so perhaps it was a server issue?


Another strange thing happened with the app, at least for one player.  This player has a basic membership.  When she loaded the GC codes into the app and tried to open the caches up, she received an error message that each of the caches was a Premium Member Only cache.  The CO was surprised by this because NONE of the new caches were PMO caches!   The CO opened up the cache pages on his laptop to confirm this.  He also checked the Edit page and the PMO box was not checked.  Finally, I just let the player use my phone to search for one of the caches while I tagged along to find the cache myself.


I have reported both problems to HQ and suggested the CO to do the same.


  • Surprised 2
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...