Jump to content

BUG?: Alt Text for Cache Image Changes When Saved


VAVAPAM
Followers 3

Recommended Posts

Attempting to insert the html text recommended for "decorative images" ( alt="" )  however, when I save it, it's stripped down to just alt .

 

For example, in GC7D1C7

<p style="text-align:center;"><img src="https://s3.amazonaws.com/gs-geo-images/4108883e-86e6-4db9-b6ab-659c81148883.jpg" alt="" /><br /></p>

Becomes, upon saving,

<p style="text-align:center;"><img src="https://s3.amazonaws.com/gs-geo-images/4108883e-86e6-4db9-b6ab-659c81148883.jpg" alt /><br /></p>

 

This stripping occurs upon saving with all the caches I've edited for decorative images. It DOES NOT occur if there is actual text entered between the quotation marks. 

  • Funny 2
Link to comment

Interesting inconsistencies...

 

WYSIWYG: Empty attributes (all) are left as attribute="" when switching to visual and back to source.

On saving: Empty attributes (all) are stripped to just attribute in the source.

 

WYSIWYG: Valueless attributes (all) are converted from attribute to attribute="" when switching to visual and back to source.

On saving: Valueless attributes (all) are left as just attribute in the source.

 

It seems the server end save sanitization differs from the wysiwyg editor sanitization on whether to force attribute="" or just attribute.  :lol:

  • Surprised 2
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 3
×
×
  • Create New...