Jump to content

Garmin Express Problem

Recommended Posts

I have been using Garmin Express to D/L caches to my two GPS's.  Yesterday it wouldn't work... got this error message. "Request error. Problem with content being sent, Try later." I haven't done anything different.. Anyone have a fix for this?  Thanks..

Link to comment

I have been having the same "problem with content" for the last 12-15 hours. None of my lists could be uploaded in that time. I tried making a different list - same result. Express says that I am up to date - before popping up the message about a problem with content.  This has happened before - getting to be a real pain!!

Link to comment

Same issue. New version (6.0.0+) of Express did finally solve the issue. However, had to uninstall the previous version of Garmin Express, restart, then re-install the new version - after first install of Express 6+ the Express software wouldn't start even after restarting the machine. I think my song, with regards to Garmin, is "Some day my code will come..."


Running Win10 Pro 64 

Version    10.0.17134 Build 17134

i5 7600

GigaByte B250MDS3H


256GB NVME M2.2280 main drive

2TB Seagate secondary drive

Intel HD 630 Graphics

Edited by Jimrky
Link to comment

Same problem, but upgrading to the latest version of Garmin Express fixed it.  Now, as to what happened... since we were all running the same version of GE that worked previously, one must assume that Groundspeak changed the way their API works, and that broke GE.  Of course it could also be that GE made changes that required the API modifications.  Either way, there was no notification to the users other than the error message when we tried to use it.  This has happened before and will likely happen again.  I wish that GE would notify me when they have an update, especially if it is critical to its continued use.  I would also appreciate knowing of API changes that may impact GE and other applications.

Link to comment
6 minutes ago, Marius900ie said:

Same issue here (not able to upload lists to my Garmin GPS),

solution: uninstall Garmin Express, restart computer, install garmin express. Fixed.


I had to do it in a similar way.  The "update" of Garmin Express didn't work for me.  I was able to do it without restarting the computer, but it didn't work until I uninstalled the old version and installed the new.

Link to comment

Same problem here today when trying to copy some new lists of caches to my eTrex.  Garmin does not even give a pointer as to the issue - just that stupid message that says "Request error. Problem with content being sent, Try later."   Tried 2 different gps units so realised it must be a problem at "their end".


So kicked the PC, swore at the dog, uninstalled Garmin Express.  Reinstalled (obviously a new version) & everything is hunky dory.  Gee thanks Garmin!  Why not give us a clue?  I had it set for automatic updates so you would think a message would have appeared

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...