Jump to content
Sign in to follow this  
Followers 1
Wæki3_KL6

Wherigo on iPhone

Recommended Posts

Created my first cartridge and came up with a few questions after testing. I tested in the official Wherigo player (v341)

  1. I set many Zones to have a Distance Range in ft (not to -1). No matter the distance, all Zones that were Visible and Active were seen in locations--even when home ~2 miles away (Distance Range were set to 500ft for example, I used ft.).
  2. Text shows description for .3 sec and quickly jumps to message when clicking on item with message text in onclick event. When testing on computer, you never see the text description.
  3. Play Alert Sounds seemed to only work when phone was locked--not while looking at open app.

Any idea or recommendations based on this? I'd like to fix 1 & 2. I plan to add sound, so 3 isn't a big deal, just observation--unless sound only plays when locked also. I think sounds are a nice queue to tell someone to look at device, so it would be nice if all players/device had some sound.

Share this post


Link to post

I'd have to play around with #1.  Try switching to meters and see if that fixes things.  I'm wondering if the app didn't interpret the units correctly.  That's a worrisome issue, though.

For #2, if you assigned an event, Wherigo won't wait for someone to click a button before processing the next event.  (This is intentional and a good thing, actually.)  I'm trying to understand what you have that triggers the event, but I can provide a different example, anyway.  Let's say you want to show two message boxes.  If you put them one after the other, the Wherigo Player will show the first message, then go immediately into showing the next message.  To space them apart, whichever builder you have, you'll need to search for the first message's button click event and show the next message on that event.  So, for your case, if you wired a message to show when someone clicks on an item, it makes sense the user won't be able to see the item's description because the event will cause the message box to show.

For #3, I'm not sure how the app has implemented that command.  You could add an mp3 with a small alert sound to the cartridge and play that sound every time you need the sound.

Share this post


Link to post
1 hour ago, Ranger Fox said:

For #2, if you assigned an event, Wherigo won't wait for someone to click a button before processing the next event.  (This is intentional and a good thing, actually.)  I'm trying to understand what you have that triggers the event, but I can provide a different example, anyway.  Let's say you want to show two message boxes.  If you put them one after the other, the Wherigo Player will show the first message, then go immediately into showing the next message.  To space them apart, whichever builder you have, you'll need to search for the first message's button click event and show the next message on that event.  So, for your case, if you wired a message to show when someone clicks on an item, it makes sense the user won't be able to see the item's description because the event will cause the message box to show.

Thanks Ranger Fox, yeah I understand your comment--I watched your youtube presentation the other day--twice--to learn some things. This isn't the issue I'm having.

The issue is:

  • I've an item with a description
  • This item has has a click event that > Shows message to player
  • In testing, the pocketPC VM has zero delay and goes straight to the message, skipping the description altogether
  • On the official iPhone Wherigo app, you see the description for .2-.5 seconds until the message slides into view.
    • This behavior is a bit undesirable, because I imagine a user may get frustrated thinking they need to read the initial text--not knowing it's not really necessary
    • I like to have a tiny description because the items show a brief sub text on pocketPC and perhaps Garmin

Hopefully this makes sense. Let me know if I need to elaborate. 

Edited by Wæki3_KL6

Share this post


Link to post
1 hour ago, Ranger Fox said:

I'd have to play around with #1.  Try switching to meters and see if that fixes things.  I'm wondering if the app didn't interpret the units correctly.  That's a worrisome issue, though.

In 4 Zones, I've tried a Distance Range of meters, kilometers, feet, and miles. All zones are set to low distance (less than 1 mile) and I'm 1.8 miles away. All zones show on my iPhone. Seems like if a Zone is Visible and Active, is shows regardless of setting. Non visible Zones do not show (as expected), non-active Zones do not show (as expected).

I'm using the Wherigo Builder.

Share this post


Link to post
52 minutes ago, Wæki3_KL6 said:

Thanks Ranger Fox, yeah I understand your comment--I watched your youtube presentation the other day--twice--to learn some things. This isn't the issue I'm having.

The issue is:

  • I've an item with a description
  • This item has has a click event that > Shows message to player
  • In testing, the pocketPC VM has zero delay and goes straight to the message, skipping the description altogether
  • On the official iPhone Wherigo app, you see the description for .2-.5 seconds until the message slides into view.
    • This behavior is a bit undesirable, because I imagine a user may get frustrated thinking they need to read the initial text--not knowing it's not really necessary
    • I like to have a tiny description because the items show a brief sub text on pocketPC and perhaps Garmin

Hopefully this makes sense. Let me know if I need to elaborate. 

Here's the examples. 5 files (1 iPhone, 4 Wherigo Builder Zone properties):

  • Screenshot of iPhone (Locations screen, over Range Distances)
  • Zone Meters
  • Zone Kilometes
  • Zone Fett
  • Zone Miles

iphone Screenshot.jpg

Zone Feet.png

Zone KM.png

Zone Meters.png

Zone Miles.png

Share this post


Link to post
On 1/9/2018 at 6:10 PM, Wæki3_KL6 said:

Created my first cartridge and came up with a few questions after testing. I tested in the official Wherigo player (v341)

  1. I set many Zones to have a Distance Range in ft (not to -1). No matter the distance, all Zones that were Visible and Active were seen in locations--even when home ~2 miles away (Distance Range were set to 500ft for example, I used ft.).
  2. Text shows description for .3 sec and quickly jumps to message when clicking on item with message text in onclick event. When testing on computer, you never see the text description.
  3. Play Alert Sounds seemed to only work when phone was locked--not while looking at open app.

Any idea or recommendations based on this? I'd like to fix 1 & 2. I plan to add sound, so 3 isn't a big deal, just observation--unless sound only plays when locked also. I think sounds are a nice queue to tell someone to look at device, so it would be nice if all players/device had some sound.

Learned something from the Earwigo wiki. Do not use onclick events. Not only do they bug in iPhone, but they don't work on some other players.

Also, play sounds do not work on all players.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 1

×