Jump to content

Compass will not work inside app

Followers 2

Recommended Posts


I new to geocaching and have a problem with the compass. Once I start a cache search and choose the Compass icon in the upper right corner, the compass appears, but doesn't function properly. It will accurately count down my distance to the cache and the orange arrow points in the proper direction, but the compas does not auto rotate/spin. North never moves as I turn the the phone. If I know where north is and manually always orient the phone that direction we can find the xache. If Ian not holding the phone with the Nkrth arrow acurally north or do not know which way is north we will not be on the right track.


I have both a free and premium login and it doesn't work in either. My iPhone settings are set for location services on when using geocaching app and the compass app that comes with the iPhone works. Is there an internal setting either in the app or my phone I need to change?

Thank you

Link to comment

For the compass, you may try calibrating it. A quick flick of the wrist is usually all it takes, while the compass is in view. If the "Compass Calibration" red ball game isn't in view, the iPhone is happy with its calibration. But I'm able to force a Compass Calibration screen to pop up, by using a magnet. I'm also able to get the compass to freeze with some small magnets. Run the App outside away from ferrous metal, and outside of a car, and see if that helps.


I can't get the orange arrow to move independently of the compass, and can't figure out how the compass could be pointing North Up, with any setting. My iPhone definitely doesn't do that. Are you using the Official Geocaching App from Geocaching.com? Have you tried deleting/reinstalling the App?


There are other Geocaching Apps, and some may have a North Up selection that I'm not finding in the Geocaching.com App. Do you have any other Apps to compare? You might as well try another App, and see what happens.


Some of this might help, although some seems to be for an obsolete version of the OS:



I can't find a lot of "stuck compass" info, but check this out:




For the map, if the App is set to North Up, you can set Track Up instead.


In the Official Free Geocaching App, tap this icon til it changes to this:



Edited by kunarion
Link to comment

Thank you so much for your reply.


Yes, I am using the official geocaching app and tried uninstalling it and reinstalling. I could not get any options to let me calibrate within the app, but I am trying. Nothing has changed. I did use the feature you described in your screen shot and the compass does work in that mode. It rotates about and continuously has North pointing the right direction no matter what way the phone is orientated. Once I move to the larger compass (green full screen) it does not work.


Where in the app do you set North up?


It always has North at the top of the phone, no matter where North is, an also does not rotate as I rotate. This feature works on my friends phones I was geocahing with. However, it will countdown as I get closer and beep within 30 feet, so I know knows where I am somehow.


Thanks for your help, I hope I am explaining it right. As long as I know which way is North I can work around, but it would be nice to know what I am doing wrong.

Edited by Turtlefly459
Link to comment
Where in the app do you set North up?

The map is at North Up by default, and has other modes. I've never seen the compass stuck at "North Up", and it's especially strange if "Track Up" works in map mode but the compass fails. From what you describe, the compass screen is behaving as if there was a setting for "North Up", with the compass frozen and the orange pointer following the cache. There's a compass tape at the bottom of the map. Is that frozen as well?


Do you have the latest iOS Version, 9.3.5?


You may opt to use a different App such as Cachly, but that won't help if it's something weird on the iPhone itself, not the Apps.



I found a thread that's kinda-sorta like your issue. In that case, "Compass Calibration" was off. I tried that selection, and the compass then remains pointed north. The orange arrow doesn't move either, but who knows. Worth checking?


Try this. Go to Settings, scroll to Privacy and tap that. Tap the icon for "Location Services" (also, that should be switched on). Scroll all the way to the bottom of the "Location Services" list to "System Services" and tap that. Usually, everything in System Services is selected "on". If "Compass Calibration" is off, turn that on. If it's on, turn it off, then back on.


If that didn't help, turn the iPhone off, then back on.

Edited by kunarion
Link to comment

Similar hopefully related problem? On my iPhone 6+ the compass function in the geocaching app, the GPS and distance displays lock when the compass function is activated. The directional arrow points in the right direction and rotates fine. If I switch back to map and then back to compass, the GPS and distance are updated but again locked. I have turned location services on/off/on, compass calibration on,off,on, rebooted the iPhone several times and uninstalled/re-installed the app. My wife's iPhone 6+ behaves in the same manner.

iPhone 6+, IOS 10.2.1, Groundspeak app 5.0

The compass function was working fine in Roatan Honduras last week and fine here in Ohio in January

Link to comment
This topic is now closed to further replies.
Followers 2
  • Create New...