Jump to content
Sign in to follow this  
Followers 1
NorStar

Profile Oriented Photos not Rotated Correctly

Recommended Posts

In the last few days, I have loaded profile-oriented images (images that are taller than wider) for waymarks that, after uploading, display in landscape mode. If I click on the gallery and view the image, it is oriented in the right direction. Has anyone else seen this behavior, lately? I want to know if this is a site specific issue or if it somehow is a result of my creating the photos. I haven't changed how I make my pictures and I'm using the same camera.

Share this post


Link to post

In the last few days, I have loaded profile-oriented images (images that are taller than wider) for waymarks that, after uploading, display in landscape mode. If I click on the gallery and view the image, it is oriented in the right direction. Has anyone else seen this behavior, lately? I want to know if this is a site specific issue or if it somehow is a result of my creating the photos. I haven't changed how I make my pictures and I'm using the same camera.

 

Yes, I have noticed this too. It only happens to photos that are taller than wider. In the gallery, you'll see black lines on either side to fill in the gaps. This is very anoying since if you look at the waymark by searching for it, you'll notice a new issue as well. The photo is not centerd in the main photo. It's on the left side of the photo frame, leaving a white space with a line where the photo should have filled in. I've noticed this with my iPhone photos and have not tried it with photos from my other cameras. I've only noticed this in the passed week.

 

Also prior to this if you are uploading a photo from a phone, like I do most of the time through safari instead of downloading it to the computer, that the photo will not be cropped correctly. For example, it would be leaning on its side. The only way to fix it is to change the orientation of the photo, save it in a different orientation (180 degrees for example) and then re-save it in its original orientation. I've been doing that on my phone and on my computer, both of which are a pain in the butt especially if you have hundreds of photos in this orientation.

 

To answer your question, I believe this is a site wide issue and not any specific server or computer issue. Let's just hope this isn't going to turn into what happened last year :laughing:

Share this post


Link to post

In the last few days, I have loaded profile-oriented images (images that are taller than wider) for waymarks that, after uploading, display in landscape mode. If I click on the gallery and view the image, it is oriented in the right direction. Has anyone else seen this behavior, lately? I want to know if this is a site specific issue or if it somehow is a result of my creating the photos. I haven't changed how I make my pictures and I'm using the same camera.

 

The Waymarking site doesn't seem to like portrait mode photos with EXIF data, no matter how set. There are more convoluted ways to strip the orientation data but the easiest way I've found to address it is to (in Windows) right click the photo, Send To an email recipient, save the resulting attachment and cancel the mail send. Upload that pic and the orientation will stick. I imagine there's a similar procedure for use with a Mac.

 

Hope this helps.

Share this post


Link to post

It is not the EXIF data in gereral, it is only one special orientation flag that was introduced with the dawn of smartphones. Most current operating systems and browsers are aware of this flag and display the pictures correctly.

 

When you upload a picture to the Waymarking site, the server creates three smaller copies of this picture. These are the ones you mostly see on the pages, the thumbnails and small pictures. The original one is only shown when you go to the gallery select a picture and then click again on this picture, this one is also always displayed correctly. But all the smaller scale versions are created by a piece of software that was installed before this flag was known, so it has no chance but to ignore it.

 

On the other hand, it always pays to touch your pictures before you upload them. First, current cameras and smartphone create too large pictures for a web site like Waymarking.com. There is absolutely no need for an over 5000 pixel wide picture on a web site. I reduce them to 1280 pixels the wider side, this is enough a saves a lot of upload time. Then, there is always something you can improve just by rotating a cropping. I tend to have an inclination of 3 to 6 degrees in my pictures. The pictures look so much better when this small thing is corrected. And there is always a viewport inside the picture that is superior to the original view. You don't need the parked car in the bottom foreground and the monument looks much better without this public waste bin on the left side and so on.

 

Correct the verticals, crop, rescale, then save and upload. This enhances always the quality of your waymarks. And as a side effect, you will never have to deal with the orientation problem. There are many (also free) programs that can do this in seconds. I personally use Irfan View for this tasks but there are others that are just as good.

Edited by fi67

Share this post


Link to post

I have not uploaded a photo to Waymarking, but I often have a similar problem on gc.com. Photos uploaded in portrait mode show correctly after uploading, in edit mode, or when viewing the full picture, but are distorted to landscape when clicking from the cache page for a pop-up view. Reducing the size of the photos to under 1000 pixels or slightly larger solves the problem. Perhaps the same thing would help on Waymarking.

Edited by geodarts

Share this post


Link to post

So, after reading these replies and remaking the images, I'm no wiser as to what is going on. It could be the camera; it could be the software; it could be the web site. The other entries tell similar observations, yet it's still different. Another forum entry about Windows 10 may be related to the same issue.

 

My previous camera developed an orientation problem when I dropped it 3 ft onto pavement. Pictures from the camera had both orientations oriented wrong, and I learned how to reorient the pictures by using lossless rotation twice in Irfanview - my editor of choice.

 

This is different than that, but I was still forced to use the old technique to reorient the pictures. I also found that cropping the picture oriented as a portrait picture into a smaller one in landscape mode DID NOT solve the orientation issue.

 

I don't know what happened in the last week, but something did. I'm not sure what the source of the issue is. I don't recall any differences with my software - Irfanview, though there are updates to Windows all the time (version 7.1). I now see wrongly oriented pictures in thumbnails in the Windows File Explorer. I don't know - it just adds to frustration and needing to recreate pictures instead of adding new waymarks.

 

It would be nice to have a feature that rotates pictures after uploading. In the meantime, I guess that I'll just take less pictures with Portrait orientation, even if it ends up cropping features.

Share this post


Link to post

So, after reading these replies and remaking the images, I'm no wiser as to what is going on. It could be the camera; it could be the software; it could be the web site. The other entries tell similar observations, yet it's still different. Another forum entry about Windows 10 may be related to the same issue.

 

I hadn't had much trouble in this vein until a couple of days ago. Though I know that the EXIF orientation tag was a poorly thought out addition to jpegs, my loathing for all the "features" of Windoze 10 allows me to blame it for most of the trouble. Two days ago I put a portrait oriented photo on the page of a waymark and the only way to get it oriented properly was to upload a landscape oriented version of the photo to the gallery. Given that this wasn't completely satisfactory, I just deleted the EXIF info and uploaded again. As expected, they both stand upright now.

 

The moral - for now, if you're having trouble with portrait oriented pix, just delete the EXIF info.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 1

×