Jump to content
Sign in to follow this  
Followers 0
gameoftheirlives

Etrex 20 not displaying maps in Calgary, Alberta

Recommended Posts

I just arrived in Calgary for a holiday, turned on my Etrex 20 and saw that no map was displayed. I recently had trouble loading caches on it after switching my computer system to Windows 10. I solved that problem by downloading and using the Firefox browser.

 

Is it possible that something happened to it while going through the airport security x-ray? I would appreciate any help - I really want to get out there and geocache. (I was able to find a cache in the city of Calgary but it would be a lot easier with a map)Thanks!

Share this post


Link to post

Do you have a map of Calgary installed on the GPS?

No, I didn't download a Calgary map but I was here last year and I don't remember not having a map. I was also in California recently and had a map there and didn't download one. Could you tell me how I would download a map? Thank you for your reply.

Share this post


Link to post

The GPS does not come with any maps. At some point you must have installed a map, which you must have. You need to figure out what map you have and if it covers Canada.

 

If you want free maps, you can get some here: http://garmin.openstreetmap.nl/

Share this post


Link to post

The GPS does not come with any maps. At some point you must have installed a map, which you must have. You need to figure out what map you have and if it covers Canada.

 

If you want free maps, you can get some here: http://garmin.openstreetmap.nl/

Thanks for the link. I'm going to try it. When I plugged my garmin into my computer about 30 minutes ago, I got an error message from Garmin and a link to fix it which I clicked. After a couple of minutes I was told that it was fixed. I thought that this was the answer to my map problem but it wasn't. I'm going to try the link you sent me as well.

 

One other thing, I went to set up in my gps, clicked map, clicked select map and saw that Topo Ontario V3 was enabled. I changed this to Worldwide DEM Basemap, NR and thought that that may solve my problem. It did not.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 0

×
×
  • Create New...