Jump to content

etrex 20 SD card


Recommended Posts

I have bought a SD card loaded with Topo maps Australia and NZ. It loads in Basecamp but won't appear on the etrex. I have gone in to settings and changed it to USB storage and then to maps- but there are only 2 choices for maps that were already there when I bought the unit. I tried disabling them both, but I can't get topo to appear. I have even tried leaving it as Garmin in the settings but no joy!


It is stored under Garmin on the SD card. I am at a loss to work out how to get it to work! I am running Mac OS 10.6.8. I can't believe how hard it is to work with!

Hopefully someone can help me as the loaded maps are pitiful! Starting to think I should have just stuck with the iphone!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...