Jump to content

Garmin e trex h frozen problem

Recommended Posts

I have bought a secondhand Garmin e trex h for my nephews but it seems to be frozen. I have tried the hard reset as advised on the Garmin site. Although the handheld says 'are you sure you want to reset' I cannot make any of the buttons work to change no to yes. The only way to switch off the unit is by removing the batteries. Is anyone out there able to help?

Thanks - Kath :rolleyes:

Link to comment

FWIW, my eTrex Legend has had controls that got dodgy. The toggle that allows you to scroll around is the usual culprit -- sometimes it refuses to let me move the scroll bar or pan. My guess is it is an electrical connection that is weak -- these units will take a good drop or two (unlike an iPhone) but that doesn't mean the shock helps matters. A few gentle taps usually clears things up (emphasis on gentle!)

Link to comment

The eTrex H doesn't have the dpad joystick like the Legend. I also had the issues with the Legend dpad, but resolved them by opening the uint and cleaning around the contacts.


With the H if you aren't getting any response from any of the buttons on the left it could be a similar issue, or something larger.


Have you tried taking the batteries out, and giving the buttons on the unit a good work out. Press the buttons numerous times (dozens and dozens) firmly with the batteries out. This might help make the contacts work on the buttons.


You should feel a very soft (and quiet) click giving feedback on the button presses.

Link to comment

Although the handheld says 'are you sure you want to reset' I cannot make any of the buttons work to change no to yes.

I haven't tried it with my Etrex but you are suppose to be able to avoid this message by using the sequence "Page" plus "Enter" plus "Up" at the same time and then while holding them down press the "on/off" button. Hold the keys down for 5 seconds to perform the reset.

Link to comment

Thanks for the advice. The buttons do click and they work to switch on and also to do a hard reset but then everything freezes and fails to work. :rolleyes: It's good to know that people are out there and willing to help. Thanks

Try to run the wepupdater and install the newest firmware or re-install the current one.


Doing this once reanimated one you my Garmins.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...