Jump to content

Lowrance XOG vs Garmin Nuvi

Followers 2

Recommended Posts

I currently have the XOG and love it. I have never tried any other unit but have seen some fellow cachers Garmins. I would honestly recommend the XOG and would have a very hard time caching without it.


The turn by turn voice directions along with the ability to cross over to the "trail mode" helps me so much. Great for caching, biking, hiking, fishing, and driving.



Link to comment

I just picked up a Lowrance XOG a week ago and, WOW the thing is awesome! $149(CDN) for an all-weather voice navigating touchscreen GPSr, I found 7-out-of-7 caches with it TODAY! Dead-on accurate an really easy to use.


I read other reviews before buying it. The biggest complaint I've found was that the built-in battery is only good for about 2 hours. But in-between drives to different cache sites as long as you plug it into your car then that is no problem at all.


All in all a SWEET unit! My girlfriend has a Vista HCx and we compared accuracy all day,, and both perfectly matched all day long :laughing:

Link to comment

I bought my XOG today!

But I'm confused.

I've never done geocaching before - I entered the coordinates into the XOG and it is showing me where to go - but how do you switch from road mode to "trail" mode?

I drove home from the store using the turn by turn navigation and it is great - if I start driving with the coordinates entered, will it automatically direct me?

any way to help make it paperless?

Link to comment

I bought my XOG today!

But I'm confused.

I've never done geocaching before - I entered the coordinates into the XOG and it is showing me where to go - but how do you switch from road mode to "trail" mode?

I drove home from the store using the turn by turn navigation and it is great - if I start driving with the coordinates entered, will it automatically direct me?

any way to help make it paperless?


Click "menu => Options => Navigation Mode"


In that screen the top option is for turn-by-turn navigation. The bottom choice is for point-to-point navigation.


Use turn-by-turn to get you as close as possible driving, then switch to point-to-point, and the XOG will guide you right to ground zero :unsure:


"any way to make it paperless"


You're a premium member. Take your .GPX file and convert it to .USR using the Lowrance Geocaching software




It'll transfer your pocket queries to the XOG and will include the Name, owner, difficulty/terrain rating, and the hint!

Link to comment

hi, I too have a xog and really like it. I have been using easy

gps to load waypoints to it, but I haven't figured out how to have it add size and owner, just the name. How do I figure out how to make it do all that? There is still alot I just don't know. But I know that the xog is very good for a cross over. Thanks, Mike

Link to comment

Thanks, nordicman! I'll probably go buy a card reader today so I can get started!


Highlander - are you doing pocket queries yet? I downloaded GSAK yesterday and I'm figuring it out -

I'm assuming that the link nordicman posted has the capability of taking the GPX file from the pocket query and putting it on the XOG.


So far I'm just carrying my laptop with me in the car and entering the coordinates of the caches I want to find manually.

Link to comment

Hi celerystalker, yes I have been doing PQ's for a while. I have found that it will double up the names and icons. I have had to go in and delete a bunch of the doubles. I just upgraded to the 1.8.0 version. so everything went back to the defaults, and I did another PQ and then transfered it over and it just wrote over all the old ones. I figured it would recognize the old ones and not load on top of them.. It may get to the point that I may want to delete all of it and just start over so I can have the hints and size and difficulty and terrian on each one. I don't know how to do that yet but I am guessing it must have to do with when I am setting it up at GSAK. But mean while I keep finding them with this nice little unit. I am glad to learn about the off road part, I didn,t think about using that when getting close, I always just used the coods. Well everyday I learn more, life is good. Thanks for all the info.

Link to comment

You're welcome CeleryStalker :) and hey you don't need to buy a card reader. Stick the SD card into the XOG and plug the USB cable to your computer, the SD card gets mounted as a removable drive! You can transfer your files directly to the XOG using the mounted drive, and charge up the XOG at the same time.


GSAK and EasyGPS are both great tools, but personally I just use the Lowrance software I provided the link to. It will take the .GPS file and create the cache locations directly to the XOG and will include all the info I described. Be sure and check off the "use Geocaching specific icons" and check off all the info boxes you want see, I check them ALL off :)


Remember the SD card can hold tens of thousands of cache locations, but you can only "load" no more than 1000 into the internal memory. Try to load more & you'll get a "device is full" error. No big deal, just an FYI

Link to comment

Hi Nordicman

Ok I know this may sound like a dumb question, but what do I do after I downloaded lowrance program.

I 'm sorry but I just dont know how to get it to the xog. any help would be great. thanks, Mike


Ok I'm at work right now but will try to remember the loading sequence. Have you installed the lowrance program already? Have you downloaded and saved some .GPX pocket queries and do you know the file folder location they are stored in? Have you inserted a proper SD memory card into the XOG? Ok then, here we go :)


- Connect the XOG to your computer with the USB cable. Does the computer auto-detect the XOG? If it did then you should see a new removable drive listed. Make a note of what letter is used. Oh, I am assuming you are using a Windows computer(?)


- Start the Lowrance GPXtoUSR program. For the input file find the location of your .GPX file and enter it there.


- For the output file find the drive letter of the XOG removable drive. Give the output file whatever name you wish to give it. "Caches.usr" will do just fine.


- check off whatever option choices you want to see for the caches. Check them ALL off the first time around, later you can fine tune the list if you like. Also be sure to check off the "use Geocaching specific icons" box, or whatever the wording is for that box. The XOG supports this feature.


- press GO (or start or run or,, whatever it's called lol)


Once it's done you can close the program and unplug the XOG.


Now, start the XOG and go into menu => options, and go to Panel 3 (I think). Click on the "transfer" option and chose to "load" waypoints. In the popup panel select your "Caches.usr" file and press OK.


You're DONE!


Now when you go to the map page you should see all the caches that were in the pocket query. Click on one to see all the detail. OR, go to menu => find => address book, and you will see all the locations there too, you can choose to sort them either alphabetically or by distance from your location.


==> If your screen becomes CLUTTERED with all the caches there are ways of cleaning that up don't worry about that. For now just zoom in to reduce the clutter and we can work on the cleanup in our next lesson LOL


Enjoy :)

Link to comment

nordic - thanks for all your help! I didn't even think that I don't need a card reader!


I followed your directions, but all the chaches are named "geocache file generated by Groundspeak," and the icon, size, hint, etc isn't visible.


I used a pocket query I did along a route - I figured out that I had to unzip the folder. :unsure:


When I convert a cache individually, it works fine, so I'm confused.

Link to comment

Geez I don't know what that could be Celery.. I think I might have seen such a thing happen once, when I used a different utility (GPSbabel) to try & transfer a whole pocket query into the XOG.. all the caches had that same description


..try doing my directions but be SURE to use a .GPX file that came directly from GC.com, without passing it through any other software first.. Let me know how that works out

Link to comment

Geez I don't know what that could be Celery.. I think I might have seen such a thing happen once, when I used a different utility (GPSbabel) to try & transfer a whole pocket query into the XOG.. all the caches had that same description


..try doing my directions but be SURE to use a .GPX file that came directly from GC.com, without passing it through any other software first.. Let me know how that works out

I tried it again today. this time I ran a small pocket query (deleting 100 files manually yesterday was a pain!) of 25 and I did not zip it.

I pulled it directly from my email and put it on my desktop.

It does associate that file type with GSAK, but I can't believe it changes it!


Link to comment

Well, you don't need to click on the .GPX file directly (so GSAK won't open it). However that shouldn't have caused a problem.. does you problem still persist?


And,, if you are trying to delete all geocaching waypoints you don't need to do it one-by-one..


Go to menu => Options => panel 3" Select "reset options"


Say NO to "reset all the options". But for the next question say "YES" to "do you want to clear your address book". That'll delete all the waypoints from the address book.


..a problem of that though, it really does delete everything not just the Geocaches :anicute: there are solutions for this though, so you personal waypoints can be retained

Edited by NordicMan
Link to comment

hi nordicman,

well I have done all you said, I am a little confused on what to put in the inport and export files. I make a PQ and download it and save it in my documents, then I open GPXto USR and open the input file window and go to my recent documents and clik on the file I just saved, it is still in a zip file, and it loads both boxes so the I clear the export window and go to my documents and bring up XOG (F:) then I add caches.usr so it looks like this XOG(F:)caches.usr and that is in the export window, and then I clik on convert and it a window pops up saying downloaded 0 waypoints. When I turn off my xog and restart it and go to transfer load pop up panel the file is there but since it didnt downloar any way points there is no new ones. Do You understand, I am not very good at explaining this. But I know I am close just can't get it to load waypoints. Thanks for the help. Mike

Link to comment

Hi Mike. Yep you are soooooo close! Like Celery also noticed, I forgot to mention (sorry!!) if you are getting your pocket queries in a zipped file then you need to unzip it first BEFORE trying to read it with the GPXtoUSR program.


Try that & let me know how it works out.


I know it all seems unnecessary complicated at first (!) but once you get the procedure figured out it really is quite simple. "trust me" lol

Link to comment

Hi NordicMan,

Thanks, well I got it!!! but think I just slopped my way there. I opened it and it went to gsak and some how I found it in recent documents.and it worked but now I think I need to do a complete reset due to the fact that I didn't want all that on my map, just the name and size and I thought hint but that really spreads out on the map. I will see if it is just as easy just to have all the hint and all in the waypoint description, not on the map. So it wont hurt anything to reset, delete all my waypoints and start over right? I don't have any one on there that I go to, since I mostly just look for treasure!!Thanks again, any more hints would be nice.

Edited by highlandermike
Link to comment

That's great news mike, congrats for getting it all working!


I was going to say "if GSAK" was so determined to get its fingers into the pie then by all means use it. Personally I don't have GSAK, but don't doubt it is a more powerful tool than the GPXtoUSR, is probably able to fine tune your results better. But the GPXtoUSR works quite nicely too. To answer some of your other questions


1) yes you do need to erase all your waypoints off the XOG each time you want to reload new ones. Do it like I described in bottom half of post #15. Please note that this only removes the waypoints from the XOG internal memory, it does NOT erase them from the inserted SD memory card. This is a good thing!


2) You can clean up the cache view considerably by tweaking the settings in GPXtoUSR before the transfer. You can see on the options panel the LEFT side of the values to choose controls what information you can see on the MAP when a cache shows up. The RIGHT side of the options chooses what information is visible afer you CLICK on a cache.


Personally I left it so only the ICON is visible on the map view, but "everything" gets displayed when I click on the cache. Umm does that make sense?


After you have that little tweak adjusted, geocaching with the XOG is extremely satisfying & easy!

Edited by NordicMan
Link to comment

Sorry you're still having problems :unsure:



How do you delete the waypoints without deleting your personal ones?


Here's what I do.


-erase ALL stored waypoints/addresses

-key in all your "personal waypoints"

-once they are all in there, do a menu => options => transfer "save". Save them in some file name like "Personal.usr" or something like that.


That's it.


Now next time you erase "all" the waypoints from the XOG, add back the "Personal.usr" file along with the geocaching .USR files you want.

Link to comment

Hi nordicman,

well I do have it working, some how I have one PQin my documents that isn't in a zip file that has 500 waypoints in it and it loads into my xog. but I have tried again and again to get another PQ of another area and even one of my local area, and I cannot get an unzipped file to my documents. It is really baffeling to me. The one that is not a zip is not gsak, so I just dont know. but the 500 I have are really neat I am so glad I have that, If I cant figure it out I can always put new ones in my hand. Thanks for all the help.Mike

Link to comment

Hi again Mike. Well I am not sure what to do, your problem seems more to do with your PC setup than the Lowrance software. I know it's a pain to have to drag the zipped PQ's out of e-mail, stick it somewhere, and then unzip it. but that should be a fairly straightforward task. Are those "other files" .GPX files?


Remember you can "store" countless files to the XOG memory chip, all of which in total can contain countless thousands of waypointt. BUT, you can only "load" a maximum of 1000 waypoints to the XOG internal memory.


If the memory is nearly full and you want to load more, you need to first erase the ones from the address book THEN you can load a new file in.

Link to comment

Hi guys, Hey Celery, I didnt hear if you fixed the problem with all your waypoints coming up "geocache file generated by Groundspeak," . I was using my Moms new netbook, so I downloaded the lowrance program and not gsak and made a PQ and saved it to my documents. I then put it on my XOG and it down loaded all the stuff, except not the name and stuff I had hoped for. If you figured out the problem could you send it my way? thanks. Like I said before I do have 500 loaded on my XOG that are perfect, I don't knbow how I got the unzipped file in my documents, but it is there. That is the problem I have had before, I did to many different things trying to gt the stuff to work before I would actually go see if it worked, then I don't know which procedure worked, oh well, you know the weather is beautiful here in Eastern Washington. LOve that spring is here.

Link to comment

well I did it twice so I think I have it figured out, I am using Moms netbook that doesnt have gsak to mess with. I think that is what is wrong on my laptop. But I need to do it often just so I don't forget how I did it. Thanks for all the help. I really like this little XOG. Happy caching, Mike

Link to comment

Hey guys you know what, it's weird but I do get the same sorts of "problems" loading some pocket queries works fine, others create that frustrating "geocache file generated by...." message(!)


The "bad" pocket query files will consistently not work, the "good" pocket queries will consistently work fine, and I am at a loss to explain it.


I'm wondering if all pocket queries are created equal? Do some have internal data differences or what(?)

Link to comment

I had work stuff and end of the semester school stuff to do, so this is the first chance I've had to play with it again.

I've saved my personal addresses, so here goes!

cross your fingers!


I'm traveling for business this week and I already know there's a cache right across the street! it's a busy intersection with no crosswalk, so I'll wait until tomorrow to go grab it.



The only thing I did different was not encrypt and picked "Caches I have not found."

I also limited it to 50.



Trying again!


It worked two times in a row -

maybe they fixed the pocket queries? :D

Edited by Celerystalker
Link to comment

Hey guys I've been studying what is going on with those "dud" GPX files that cause that frustrating generic message to be attached to the caches instead of the actual name. No kidding, I have spotted something peculiar with "some" of the files, and you can see it too!


Open a .GPX file using notepad. I've found "good ones" begin with the following type of code:



"Bad" GPX files on the other hand have this sort of code at the beginning



I know they both look like a jumble of text(!) but one of the differences is that "bad files" have that "endcoding="utf-8"" line at the very beginning.. I actually don't know what it means or why the file structure is different,, but it does seam the Lowrance software & the XOG themselves are not to blame for the file handling quirk

Edited by NordicMan
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 2
  • Create New...