Jump to content

GARMIN eTREX LEGEND CX CONNECTION PROBLEM


Demius7
Followers 0

Recommended Posts

Hi we need some help. We have had our eTrex Legend CX for about a year and a half. We had to send it back last year because it stoped communicating with our computers and it just started turning off by itself. They replaced it for us but all of a sudden our eTrex is no longer connecting to computers. Has anyone had this problem. Yes we have tried all of the fixes on the Garmin website and when we told them the problem they just told us to try looking under device management once again. If you have had this problem could you please let us know how you fixed it.

 

So far we updated Mapsource and we updated our drivers. When we plug it in the GPS knows it is plugged in but it does not know it is connected. If that makes sense. Neither does the computer. We have also tried a new cord with the same problem.

 

Please help.. and thank you

 

Demius7 aka Tracey and Jay

Link to comment

What error message(s) are you getting?

 

When I bought my Venture Cx and Vista HCx, MapSource said it couldn't find the grmnusb.sys driver even though I had the most recent version of MapSource installed. All I had to do was tell it where to go look for the driver - under the I386 folder. This problem aroused when I plugged the USB cable into a different USB port! Same thing - just told MapSource to find the driver in the I386 folder and all was well.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 0
×
×
  • Create New...