Jump to content

Click Stick "enter" problems

Followers 0

Recommended Posts

On my Garmin Legend the click stick "enter function" seems to be intermittent. Sometimes it seems to function correctly, other times I cant enter using it. The directional functions work just fine. I can hear the click on all actions both directional and enter. I haven't had the problem with the directional functions. This seemed to be noticable after upgrading the software to 3.20 but I'm not real sure if that would have anything to do with this problem. Anyone have anything like this?

Link to comment

The click-stick on the eTrex line can be problematic. I had to return one (a Vista) to Garmin for repair due to a defective right-click. Some units are fine and never develop any problems. Maybe you somehow got an early manufacturing run unit...these -seem- to have the most problems (others have original first-run units and have never had a problem though...). I do know that the click-sticks on the newer units (they've had a year or so now to refine the stick) are better and more reliable. There is pretty much nothing you can do about it yourself and the firmware being the culprit is highly unlikely. I would contact Garmin for assitance and get an RMA for the unit.

First though, if you bought the unit retail and you are within the return time frame, I would exchange the unit at place of purchase for another before going through Garmin.

You may also try a search on these forums (enter "click stick" or "click-stick" in the search box) to read alot more regarding this issue.


[This message was edited by SergZak on May 12, 2003 at 07:34 PM.]

Link to comment

I purchased a Legend almost 2 years ago. It has worked flawlessly up until about 6 weeks ago. Now the click stick works most of the time. Sometimes I just half to keep working with it to get it to work. At one point I thought moisture may be causing the problem but I'm not so sure now. I'm afraid that at some point in the near future I may have to send it in for repairs. I'm sure, by now, it is out of warranty.

Link to comment

I bought a used legend unit which worked great for about a month and then had the same problem you speak of with the "Enter" function. My other Legend works fine and has for over 75 caches now. I think garmin has some manufaturing problems reading the threads through out the site.


Garmin will refurbish your unit to new for $99. That's a deal if you ask me.








Cache'n Retrievers


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 0
  • Create New...